Please remove google-gadgets source and binaries from archive

Bug #741964 reported by Chris Coulson on 2011-03-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
google-gadgets (Ubuntu)
Undecided
Unassigned
plasma-scriptengine-googlegadgets (Ubuntu)
Undecided
Unassigned

Bug Description

google-gadgets is using both jsapi and XPCOM quite extensively, which makes it difficult to support, and there doesn't seem to have been any upstream activity since May 2010. I had a go at porting this to xulrunner-2.0 this cycle and the start of my work is in bug 722611 (the patch is already 100kB in size, and still isn't finished), but I don't really have the time to invest in this and it doesn't look like anyone else is going to pick it up. Because of the Firefox release cycle, this is going to become more difficult to support in the future.

Most of the effort required to support this is because of changes to jsapi, which is going to keep changing. For most consumers of this we have now provided a dedicated libmozjs source package which is totally decoupled from the Firefox release cycle. However, google-gadgets can't use this when it is also using XPCOM

Martin Pitt (pitti) wrote :

Both removed and sync-blacklisted.

Changed in google-gadgets (Ubuntu):
status: New → Fix Released
Changed in plasma-scriptengine-googlegadgets (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers