[SRU] Cannot import basetest in python3

Bug #1735162 reported by Andrea Azzarone on 2017-11-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
google-apputils-python (Ubuntu)
Medium
Andrea Azzarone
Xenial
Undecided
Andrea Azzarone
Artful
Undecided
Andrea Azzarone

Bug Description

[Impact]
We need to get this SRUed in Xenial too as part of https://bugs.launchpad.net/xenial-backports/+bug/1735160

[Test Case]

To reproduce:

$ python3 -c "from google.apputils import basetest"

It will fail showing something like that:

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python3/dist-packages/google/apputils/basetest.py", line 37, in <module>
    import urlparse
ImportError: No module named 'urlparse'

[Regression Potential]
Please make sure:
$ python2 -c "from google.apputils import basetest"

still works

Andrea Azzarone (azzar1) on 2017-11-29
description: updated
Changed in google-apputils-python (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
importance: Undecided → Medium
status: New → In Progress
Andrea Azzarone (azzar1) on 2017-11-29
description: updated
description: updated

The attachment "gap.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Andrea Azzarone (azzar1) wrote :

Please find attached the proposed debdiff.

Andrea Azzarone (azzar1) on 2017-12-11
summary: - Cannot import basetest in python3
+ [SRU] Cannot import basetest in python3
description: updated
description: updated
Iain Lane (laney) wrote :

Hey, thanks for the patch!

Can you explain where the change comes from please? Adding DEP-3 headers to the patch would be the best way to do this.

Changed in google-apputils-python (Ubuntu Xenial):
assignee: nobody → Andrea Azzarone (azzar1)
Andrea Azzarone (azzar1) wrote :

Hey laney, thanks for the review. Please find attached the new debdiff with requested changes.

On Tue, Jan 09, 2018 at 03:01:30PM -0000, Andrea Azzarone wrote:
> Hey laney, thanks for the review. Please find attached the new debdiff
> with requested changes.

Thanks! Looks good in itself - but why did you only take part of that
patch, are the other bits not needed for some reason?

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Andrea Azzarone (azzar1) wrote :

Not needed to fix this bug. Also consider that there is another python3-fixes.patch which solves other python3 related issue. So there was no need to take it all.

Iain Lane (laney) wrote :

OK, I uploaded to bionic + xenial, thanks!

Iain Lane (laney) wrote :

(As in bug #1735160, I'm not sure if I have to fix this in Artful too - SRU team, please let us know if we should.)

Changed in google-apputils-python (Ubuntu Xenial):
status: New → In Progress
Andrea Azzarone (azzar1) wrote :

@sil2100 confirmed me that this is required.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package google-apputils-python - 0.4.1-1ubuntu3

---------------
google-apputils-python (0.4.1-1ubuntu3) bionic; urgency=medium

  * Additional fixes for Python 3. (LP: #1735162)

 -- Andrea Azzarone <email address hidden> Thu, 11 Jan 2018 10:04:59 +0000

Changed in google-apputils-python (Ubuntu):
status: In Progress → Fix Released
Iain Lane (laney) wrote :

Uploaded for 17.10 too

Changed in google-apputils-python (Ubuntu Artful):
status: New → In Progress
assignee: nobody → Iain Lane (laney)
assignee: Iain Lane (laney) → Andrea Azzarone (azzar1)
Robie Basak (racb) wrote :

SRU review:

The only code changes add Python 3 compatibility. Since python3-google-apputils shipped in Xenial, the package was broken as shipped and can be fixed under SRU policy.

The patch being included here (and in Bionic) has yet to be reviewed or accepted upstream.

I did notice one issue, but it is non-functional as the type of _STRING_TYPES and _INT_TYPES (whether a tuple or a raw instance of type) happen not to matter because of how they are used and I have commented on the pull request upstream.

Please make sure to test both Python 2 and Python 3 functionality during SRU verification.

Hello Andrea, or anyone else affected,

Accepted google-apputils-python into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/google-apputils-python/0.4.1-1ubuntu2.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in google-apputils-python (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Robie Basak (racb) wrote :

Unsubscribing sponsors.

Changed in google-apputils-python (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed-artful
Robie Basak (racb) wrote :

Hello Andrea, or anyone else affected,

Accepted google-apputils-python into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/google-apputils-python/0.4.1-1ubuntu2.17.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Unsubscribing ubuntu-sponsors.

Andrea Azzarone (azzar1) wrote :

'python3 -c "from google.apputils import basetest"' runs properly in Artufl now. Marking as verification-done.

tags: added: verification-done-artful
removed: verification-needed-artful
Andrea Azzarone (azzar1) wrote :

'python[3] -c "from google.apputils import basetest"' runs properly in Xeanial too now. Marking as verification-done.

tags: added: verification-done-xenial
removed: verification-needed-xenial
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package google-apputils-python - 0.4.1-1ubuntu2.17.10.1

---------------
google-apputils-python (0.4.1-1ubuntu2.17.10.1) artful; urgency=medium

  * Additional fixes for Python 3. (LP: #1735162)

 -- Andrea Azzarone <email address hidden> Thu, 11 Jan 2018 10:04:59 +0000

Changed in google-apputils-python (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for google-apputils-python has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package google-apputils-python - 0.4.1-1ubuntu2.16.04.1

---------------
google-apputils-python (0.4.1-1ubuntu2.16.04.1) xenial; urgency=medium

  * Additional fixes for Python 3. (LP: #1735162)

 -- Andrea Azzarone <email address hidden> Thu, 11 Jan 2018 10:04:59 +0000

Changed in google-apputils-python (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers