goldencheetah version 2.0.0-3ubuntu1 failed to build in oneiric

Bug #831278 reported by Matthias Klose
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
goldencheetah (Ubuntu)
Fix Released
High
Unassigned
Oneiric
Fix Released
High
Unassigned

Bug Description

goldencheetah version 2.0.0-3ubuntu1 failed to build in oneiric
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2694779

Details about the rebuild:
http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20110816-oneiric.html

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2694779/+files/buildlog_ubuntu-oneiric-amd64.goldencheetah_2.0.0-3ubuntu1_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 1238 lines into the build log:

/usr/bin/moc-qt4 -DQT_WEBKIT -DGC_HAVE_LIBOAUTH -DQXT_STATIC -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4/QtWebKit -I/usr/include/qt4 -I../qwt/src -I../qxt/src -I/usr/include -I. WeeklySummaryWindow.h -o moc_WeeklySummaryWindow.cpp
g++ -c -m64 -pipe -g -O2 -Wall -W -D_REENTRANT -DQT_WEBKIT -DGC_HAVE_LIBOAUTH -DQXT_STATIC -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4/QtWebKit -I/usr/include/qt4 -I../qwt/src -I../qxt/src -I/usr/include -I. -o moc_WeeklySummaryWindow.o moc_WeeklySummaryWindow.cpp
/usr/bin/moc-qt4 -DQT_WEBKIT -DGC_HAVE_LIBOAUTH -DQXT_STATIC -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4/QtWebKit -I/usr/include/qt4 -I../qwt/src -I../qxt/src -I/usr/include -I. Zones.h -o moc_Zones.cpp
g++ -c -m64 -pipe -g -O2 -Wall -W -D_REENTRANT -DQT_WEBKIT -DGC_HAVE_LIBOAUTH -DQXT_STATIC -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4/QtWebKit -I/usr/include/qt4 -I../qwt/src -I../qxt/src -I/usr/include -I. -o moc_Zones.o moc_Zones.cpp
/usr/bin/rcc -name application application.qrc -o qrc_application.cpp
g++ -c -m64 -pipe -g -O2 -Wall -W -D_REENTRANT -DQT_WEBKIT -DGC_HAVE_LIBOAUTH -DQXT_STATIC -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4/QtWebKit -I/usr/include/qt4 -I../qwt/src -I../qxt/src -I/usr/include -I. -o qrc_application.o qrc_application.cpp
g++ -m64 -Wl,-Bsymbolic-functions -o GoldenCheetah TwitterDialog.o qxtspanslider.o AerobicDecoupling.o Aerolab.o AerolabWindow.o AllPlot.o AllPlotWindow.o ANTplusController.o BasicRideMetrics.o BestIntervalDialog.o BikeScore.o BinRideFile.o DanielsPoints.o ChooseCyclistDialog.o Colors.o ColorButton.o CommPort.o Computrainer.o Computrainer3dpFile.o ConfigDialog.o CpintPlot.o CriticalPowerWindow.o CsvRideFile.o DBAccess.o DataProcessor.o DatePickerDialog.o Device.o DeviceTypes.o DeviceConfiguration.o DownloadRideDialog.o ErgFile.o ErgFilePlot.o FitRideFile.o FixGaps.o FixGPS.o FixSpikes.o FixTorque.o GcRideFile.o GoogleMapControl.o HistogramWindow.o HrTimeInZone.o HrZones.o IntervalItem.o LogTimeScaleDraw.o LogTimeScaleEngine.o LTMCanvasPicker.o LTMChartParser.o LTMOutliers.o LTMPlot.o LTMSettings.o LTMTool.o LTMTrend.o LTMWindow.o MainWindow.o ManualRideDialog.o ManualRideFile.o MetricAggregator.o Pages.o PeakPower.o PerfPlot.o PerformanceManagerWindow.o PfPvPlot.o PfPvWindow.o PolarRideFile.o PowerHist.o PowerTapDevice.o PowerTapUtil.o PwxRideFile.o QuarqdClient.o QuarqParser.o QuarqRideFile.o RawRideFile.o RealtimeData.o RealtimeController.o ComputrainerController.o RealtimeWindow.o RealtimePlot.o RideCalendar.o RideEditor.o RideFile.o RideFileCommand.o RideFileTableModel.o RideImportWizard.o RideItem.o RideMetadata.o RideMetric.o SaveDialogs.o RideSummaryWindow.o Season.o SeasonParser.o Serial.o SimpleNetworkController.o SimpleNetworkClient.o SpecialFields.o SplitRideDialog.o SrdRideFile.o SrmRideFile.o StressCalculator.o TacxCafRideFile.o TcxParser.o TcxRideFile.o TxtRideFile.o TimeInZone.o TimeUtils.o ToolsDialog.o TrainTabs.o TrainTool.o TrainWindow.o TRIMPPoints.o ViewSelection.o WeeklySummaryWindow.o WkoRideFile.o Zones.o main.o moc_TwitterDialog.o moc_qxtspanslider.o moc_qxtspanslider_p.o moc_Aerolab.o moc_AerolabWindow.o moc_AllPlot.o moc_AllPlotWindow.o moc_BestIntervalDialog.o moc_ChooseCyclistDialog.o moc_Colors.o moc_ColorButton.o moc_ConfigDialog.o moc_CpintPlot.o moc_CriticalPowerWindow.o moc_DatePickerDialog.o moc_DataProcessor.o moc_DownloadRideDialog.o moc_ErgFilePlot.o moc_GoogleMapControl.o moc_HistogramWindow.o moc_HrZones.o moc_LTMCanvasPicker.o moc_LTMPlot.o moc_LTMSettings.o moc_LTMTool.o moc_LTMWindow.o moc_MainWindow.o moc_ManualRideDialog.o moc_MetricAggregator.o moc_Pages.o moc_PerfPlot.o moc_PerformanceManagerWindow.o moc_PfPvPlot.o moc_PfPvWindow.o moc_PowerHist.o moc_QuarqdClient.o moc_RealtimeWindow.o moc_RealtimePlot.o moc_RideCalendar.o moc_RideEditor.o moc_RideFile.o moc_RideFileCommand.o moc_RideFileTableModel.o moc_RideImportWizard.o moc_RideItem.o moc_RideMetadata.o moc_SaveDialogs.o moc_RideSummaryWindow.o moc_Season.o moc_SplitRideDialog.o moc_StressCalculator.o moc_ToolsDialog.o moc_TrainTabs.o moc_TrainTool.o moc_TrainWindow.o moc_ViewSelection.o moc_WeeklySummaryWindow.o moc_Zones.o qrc_application.o -L/usr/lib/x86_64-linux-gnu ../qwt/lib/libqwt.a -lm /usr/lib/liboauth.a -lgcrypt -lz -lcurl -lnss3 -lQtWebKit -lQtSql -lQtXml -lQtGui -lQtNetwork -lQtCore -lpthread
g++: error: /usr/lib/liboauth.a: No such file or directory
make[2]: *** [GoldenCheetah] Error 1
make[2]: Leaving directory `/build/buildd/goldencheetah-2.0.0/src'
make[1]: *** [sub-src-make_default] Error 2
make[1]: Leaving directory `/build/buildd/goldencheetah-2.0.0'
dh_auto_build: make -j1 returned exit code 2
make: *** [build] Error 25
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110821-0207
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/goldencheetah-2.0.0

Tags: ftbfs oneiric
Matthias Klose (doko)
Changed in goldencheetah (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package goldencheetah - 2.0.0-3ubuntu2

---------------
goldencheetah (2.0.0-3ubuntu2) oneiric; urgency=low

  * shared-liboauth: new patch, fixes FTBFS due to changed location of
    liboauth (LP: #831278).
 -- Ilya Barygin <email address hidden> Fri, 02 Sep 2011 20:57:33 +0400

Changed in goldencheetah (Ubuntu Oneiric):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers