Please merge debian version of golang-golang-x-crypto-dev

Bug #1629412 reported by Nicholas Skaggs on 2016-09-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
golang-go.crypto (Ubuntu)
Undecided
Unassigned

Bug Description

The current ubuntu (xenial / yakkety) packages are missing needed updates. Specifically, juju needs golang.org/x/crypto/acme/autocert.

I can note that sid contains these updated packages, but yakkety is still missing them. See https://packages.debian.org/sid/all/golang-golang-x-crypto-dev/filelist.

tags: added: needs-debian-merge
description: updated
summary: - golang-golang-x-crypto-dev missing acme/autocert
+ Please merge debian version of golang-golang-x-crypto-dev
Steve Langasek (vorlon) wrote :

I've done rebuild tests of the revdeps of golang-go.crypto in
<https://launchpad.net/~vorlon/+archive/ubuntu/multiarch/+packages>. Results:

syncthing: FTBFS. not a regression, package in the release pocket also ftbfs in rebuild test, and package in yakkety-proposed, though built, FTBFS on a rebuild with all of -proposed minus golang-go.crypto with essentially the same test failures.
snapd: release version FTBFS, not previously reported in the rebuild test; -proposed version builds.
rkt: FTBFS in yakkety release, not a regression. dep-wait in yakkety-proposed.
juju-mongo-tools3.2: amd64-only build (test) failure; I can't imagine how the progress bar output is related to golang-go.crypto, so retrying the build and otherwise disregarding.
juju-2.0: yakkety release version FTBFS with uninstallable build-deps seemingly unrelated to golang-go.crypto. -proposed version builds fine, but of course this version has vendorized golang-go.crypto...
influxdb: release version FTBFS, reported in rebuild test; -proposed version builds.
golang-github-xenolf-lego: FTBFS on 32-bit archs, not a regression (present in yakkety release, package not built for those archs).
fleet: uninstallable build-deps due to etcd FTBFS. But also, FTBFS in yakkety release with downgraded golang-go.crypto.
etcd: FTBFS that's reproducible without golang-go.crypto.

So this looks good for moving ahead with the transition.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package golang-go.crypto - 1:0.0~git20160824.0.351dc6a-1ubuntu1

---------------
golang-go.crypto (1:0.0~git20160824.0.351dc6a-1ubuntu1) yakkety; urgency=low

  * Merge from Debian unstable (LP: #1629412). Remaining changes:
    - Build shared lib package.

golang-go.crypto (1:0.0~git20160824.0.351dc6a-1) unstable; urgency=medium

  * New upstream version.
  * Add myself to Uploaders.

 -- Steve Langasek <email address hidden> Mon, 03 Oct 2016 12:45:42 -0700

Changed in golang-go.crypto (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers