GOK missing dependency

Bug #19988 reported by Henrik Nilsen Omma on 2005-08-18
22
Affects Status Importance Assigned to Milestone
gok (Ubuntu)
Medium
Daniel Holbach

Bug Description

Starting GOK from the menu fails silently. Starting it from the command line
produces: ** ERROR **: Could not locate registry
aborting...

Henrik Nilsen Omma (henrik) wrote :

Oh, wait. It works after I install gnopernicus and reboot, and continues to work
after un-installing gnopernicus. I should do a fresh install and try again ...

sir_skiner (sir-skiner) wrote :

well, in my case there was missing some more dependencies... like at-spi.

Ramon de Ruiter (won) wrote :

I got:
$ gok
*** glibc detected *** free(): invalid pointer: 0x08095431 ***

But like #1, installing gcopernicus helped. The gok package should depend on
gcopernicus then.

Daniel Holbach (dholbach) wrote :

If that still happens for you, could you follow the instructions on
https://wiki.ubuntu.com/DebuggingProgramCrash and attach the output to this bug?

Matthew East (mdke) wrote :

This is a pretty big accessibility blocker. I think there is a case for an
-update if you can fix it.

Here is the backtrace:

(gdb) run
Starting program: /usr/bin/gok
[Thread debugging using libthread_db enabled]
[New Thread -1224156448 (LWP 9195)]

** ERROR **: Could not locate registry
aborting...

Program received signal SIGABRT, Aborted.
[Switching to Thread -1224156448 (LWP 9195)]
0xffffe410 in __kernel_vsyscall ()
(gdb) thread apply all bt

Thread 1 (Thread -1224156448 (LWP 9195)):
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb736b9b1 in raise () from /lib/tls/i686/cmov/libc.so.6
#2 0xb736d2c9 in abort () from /lib/tls/i686/cmov/libc.so.6
#3 0xb75997f4 in g_logv () from /usr/lib/libglib-2.0.so.0
#4 0xb7599828 in g_log () from /usr/lib/libglib-2.0.so.0
#5 0xb7dbb37c in cspi_init () from /usr/lib/libcspi.so.0
#6 0xb7db7e74 in SPI_init () from /usr/lib/libcspi.so.0
#7 0x080822c9 in gok_main_open (argc=1, argv=0xbff88ec4) at main.c:741
#8 0x08081ab5 in main (argc=1, argv=0xbff88ec4) at main.c:450

Daniel Holbach (dholbach) wrote :

Is this what you got after running all instructions from
https://wiki.ubuntu.com/DebuggingProgramCrash ?

Matthew East (mdke) wrote :

(In reply to comment #6)
> Is this what you got after running all instructions from
> https://wiki.ubuntu.com/DebuggingProgramCrash ?

Yes.

Ben Konrath (ben-bagu) wrote :

*** Bug 25563 has been marked as a duplicate of this bug. ***

Ben Konrath (ben-bagu) wrote :

I was having the same problem but I solved it by installing the at-spi package:

% sudo apt-get install at-spi

So it seems that gok should list the at-spi package as a dependency.

Daniel Holbach (dholbach) wrote :

Thanks for identifying the problem.

Daniel Holbach (dholbach) wrote :

 gok (1.0.5-2ubuntu2) dapper; urgency=low
 .
   * debian/control.in:
     - added at-spi to Depends. (Ubuntu: 13746)

Matthew East (mdke) wrote :

Please fix in Breeeeeezzzzzzy

Daniel Holbach (dholbach) wrote :

Matt, is it ok to upload the dependency change to breezy-updates? (just adding
at-spi?)

Matt Zimmerman (mdz) wrote :

    at-spi | 1.6.6-0ubuntu1 | breezy | source, amd64, hppa, i386, ia64,
powerpc, sparc
       gok | 1.0.5-1ubuntu4 | breezy | source, amd64, hppa, i386, ia64,
powerpc, sparc

at-spi is in main and available on the same architectures as gok, so I see no
problem with this. Let me know when it has been uploaded to breezy-updates

Daniel Holbach (dholbach) wrote :

i just installed gok and at-spi on a pristine breezy system and I still got the
same error messages. Installing gnopernicus (which depends on at-spi also) made
the error messages go away. The upload to breezy-updates will add at-spi AND
gnopernicus.

Daniel Holbach (dholbach) wrote :

uploaded to breezy-updates; will do an upload to dapper to fix gnopernicues
dependency.

Daniel Holbach (dholbach) wrote :

done

Ben Konrath (ben-bagu) wrote :

Adding Gnopernicus as a dep to GOK is totally broken. You do not need
Gnopernicus to run GOK. Please reopen the bug and fix the dependency problem
properly.

I think the problem now is that gok needs libgail-gnome-module as a dependency -
I guess I installed that when I was trying to get GOK running in the first
place. I don't have time to install ubuntu from scratch to test this out, sorry.

Bill-haneman (bill-haneman) wrote :

The current 'fix' is totally wrong, I agree with Ben. GOK does NOT DEPEND ON
GNOPERNICUS. There's something else wrong in your package dependency chain.

GOK should not require libgail-gnome either.

I believe that GOK ONLY requires gtk+, libgnome, at-spi, gail and the
sub-dependencies thereof. Strictly speaking it doesn't require gail either, but
in actual fact not much will work as expected without it because the other
application' accessibility requires gail.

PLEASE REOPEN THIS BUG as the current fix is not correct at all.

Daniel Holbach (dholbach) wrote :

I just tested it again and was not able to reproduce the problems with just
having gok, at-spi and libgail-gnome-module installed.

Is everybody alright with just adding "at-spi and libgail-gnome-module" or do
other problems exist?

Daniel Holbach (dholbach) wrote :

Fixed with last upload.

Changed in gok:
status: Unconfirmed → Fix Released
Colin Watson (cjwatson) wrote :

Daniel, could you fix this in the breezy-updates upload as well? Looking at this bug, I don't really want to approve it since the breezy-updates upload has:

-Depends: ${shlibs:Depends}, ${misc:Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}, at-spi, gnopernicus

Daniel Holbach (dholbach) wrote :

 gok (1.0.5-1ubuntu5) breezy-updates; urgency=low
 .
   * debian/control.in:
     - added at-spi as a Dependency.

Colin Watson (cjwatson) wrote :

The package in Dapper has libgail-gnome-module as a dependency too. Sorry to be a pain about this, but shouldn't the dependencies match up? If not, let me know and I'll approve your upload.

Colin Watson (cjwatson) wrote :

libgail-gnome-module doesn't seem to be a dependency of gok in Dapper any more, so I've accepted this breezy-updates upload. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.