[regression] ubuntu-emulator fails to start Mir demos

Bug #1486535 reported by Gerry Boland on 2015-08-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
kevin gunn
Mir
Fix Released
Critical
Alexandros Frantzis
0.14
Fix Released
Critical
Alexandros Frantzis
0.15
Fix Released
Critical
Alexandros Frantzis
goget-ubuntu-touch (Ubuntu)
Undecided
Unassigned
mir (Ubuntu)
Critical
Unassigned

Bug Description

On the emulator, many Mir clients are failing to start, with errors ranging from

$ mir_demo_client_egltriangle
No active outputs found.

$ mir_demo_client_eglsquare
error : could not determine display size

$ QT_QPA_PLATFORM=ubuntumirclient qmlscene test.qml
Loading module: 'libubuntu_application_api_touch_mirclient.so.3.0.0'
ASSERT: "displayOutput != nullptr" in file ../../../src/ubuntumirclient/screen.cpp, line 183

These all suggest the display configuration reported to clients is not correct. Checking this:

$ mirout
Connected to server: <default>
Card 0: Max 2 simultaneous outputs
Output 0: Card 0, LVDS, connected, 480x800+0+0, unused, on, 0mm x 0mm (0.0"), normal
     480x800 60.00*+
Output 0: Card 0, LVDS, connected, 480x800+0+0, unused, off, 0mm x 0mm (0.0"), normal
     480x800 60.00*+

which indicates there are no "used" outputs (also the 2 "Output 0" entries is suspicious)

To bring up emulator, do:
sudo ubuntu-emulator create touch --channel=ubuntu-touch/rc-proposed/ubuntu
ubuntu-emulator run touch
and you can connect into is via adb.

Related branches

Gerry Boland (gerboland) on 2015-08-19
Changed in mir:
status: New → Incomplete
status: Incomplete → New
importance: Undecided → Critical
Changed in mir:
assignee: nobody → Alexandros Frantzis (afrantzis)
Changed in mir:
status: New → In Progress
kevin gunn (kgunn72) on 2015-08-19
Changed in canonical-devices-system-image:
milestone: none → ww34-2015
assignee: nobody → kevin gunn (kgunn72)
importance: Undecided → Critical
status: New → In Progress
Changed in mir:
milestone: none → 0.16.0
Daniel van Vugt (vanvugt) wrote :

Fix committed to lp:mir/0.14 at revisision 2724. Scheduled for release in Mir 0.14.1.

Changed in mir:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Seems to be a regression, but not a regression in Mir. The code that was removed has been there for what looks like years. So the emulator itself has somehow regressed.

summary: - [emulator] mir display configuration incorrect, causing clients to fail
+ [regression] ubuntu-emulator fails to start Mir demos
tags: added: regression
Changed in mir:
status: Fix Committed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.16.0

Changed in mir:
status: In Progress → Fix Committed
Alexandros Frantzis (afrantzis) wrote :

> Seems to be a regression, but not a regression in Mir. The code that was removed has been there for what looks like years. So the emulator itself has somehow regressed.

There are two parts to the failure:

1. The display configuration reported by Mir is incorrect, which is clearly a Mir problem. The MP fixed this.
2. Failure to find a proper EGL config when EGL_COLOR_BUFFER_TYPE is specified, which is indeed an emulator bug. The MP provides a harmless workaround in Mir (i.e. EGL_RGB_BUFFER is the default, so we don't need to explicitly specify it) to unblock OTA6.

Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in mir (Ubuntu):
importance: Undecided → Critical
status: New → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
tags: added: regression-proposed
removed: regression
Daniel van Vugt (vanvugt) wrote :

Please keep that tag. I use it for periodic quality analysis.

tags: added: regression
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers