touch emulator shows "No data sources available"

Bug #1348949 reported by Hannie Dumoleyn on 2014-07-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
goget-ubuntu-touch (Ubuntu)
Undecided
Unassigned

Bug Description

What I did

23-7-2014
http://davidplanella.org/ubuntu-emulator-quickstart-guide/
sudo add-apt-repository ppa:ubuntu-sdk-team/ppa && sudo apt-get update
sudo apt-get install ubuntu-emulator
me@ubuntu:~$ sudo ubuntu-emulator create mijntouch --arch=i386
Succesfully created emulator instance mijntouch in /home/hannie/.local/share/ubuntu-emulator/mijntouch
me@ubuntu:~$ ubuntu-emulator run mijntouch

cgroup_path=user failed: invalid request
 * Setting up X socket directories... [ OK ]
 * Starting automatic crash report generation: apport

My computer crashed!!! Crash report .crash is too big to send as an attachment
========================================================
Troubleshooting
after having replaced the nouveau driver with nvidia version 304.117 for my GeForce 6, the emulator works. I got an introduction and on the display I now see date, time and the message "No data sources available". There is nothing I can do so far, because a lot of files seem to be missing (see terminal output below).
Example: I checked the first one:
trying to find: /usr/share/android/emulator/out/host/linux-x86/bin/bios.bin
This subdirectory /bin/ does contain files like emulator, emulator-x86 and others, but there is no bios.bin here. I found bios.bin in /usr/share/android/emulator/out/host/linux-x86/usr/share/pc-bios instead.
Is this normal?
========================================================
Output terminal 25 juli 2014
me@ubuntu:~$ ubuntu-emulator run mijntouch
emulator: autoconfig: -ramdisk /home/hannie/.local/share/ubuntu-emulator/mijntouch/ramdisk.img
emulator: autoconfig: -datadir /home/hannie/.local/share/ubuntu-emulator/mijntouch
emulator: Found target ABI=x86, architecture=x86
emulator: Found target API level: 19
emulator: using core hw config path: /home/hannie/.local/share/ubuntu-emulator/mijntouch/hardware-qemu.ini
emulator: keyset loaded from: /home/hannie/.android/default.keyset
emulator: trying to load skin file '/usr/share/ubuntu-emulator/skins/EDGE/layout'
emulator: skin network speed: 'full'
emulator: skin network delay: 'none'
emulator: Using initial system image: /home/hannie/.local/share/ubuntu-emulator/mijntouch/system.img
emulator: autoconfig: -initdata /home/hannie/.local/share/ubuntu-emulator/mijntouch/userdata.img
emulator: Physical RAM size: 512MB

emulator: Found target ABI=x86
Content of hardware configuration file:
  hw.cpu.arch = x86
  hw.ramSize = 512
  hw.screen = touch
  hw.mainKeys = yes
  hw.trackBall = yes
  hw.keyboard = no
  hw.keyboard.lid = no
  hw.keyboard.charmap = qwerty2
  hw.dPad = yes
  hw.gsmModem = yes
  hw.gps = yes
  hw.battery = yes
  hw.accelerometer = yes
  hw.audioInput = yes
  hw.audioOutput = yes
  hw.sdCard = yes
  hw.sdCard.path = /home/hannie/.local/share/ubuntu-emulator/mijntouch/sdcard.img
  disk.cachePartition = yes
  disk.cachePartition.path = /home/hannie/.local/share/ubuntu-emulator/mijntouch/cache.img
  disk.cachePartition.size = 66m
  hw.lcd.width = 480
  hw.lcd.height = 800
  hw.lcd.depth = 16
  hw.lcd.density = 160
  hw.lcd.backlight = yes
  hw.gpu.enabled = yes
  hw.camera.back = emulated
  hw.camera.front = none
  vm.heapSize = 48
  hw.sensors.proximity = yes
  hw.sensors.magnetic_field = yes
  hw.sensors.orientation = yes
  hw.sensors.temperature = yes
  hw.useext4 = yes
  kernel.path = /home/hannie/.local/share/ubuntu-emulator/mijntouch/ubuntu-kernel
  kernel.parameters = androidboot.hardware=goldfish clocksource=pit androidboot.console=ttyS2
  disk.ramdisk.path = /home/hannie/.local/share/ubuntu-emulator/mijntouch/ramdisk.img
  disk.systemPartition.initPath = /home/hannie/.local/share/ubuntu-emulator/mijntouch/system.img
  disk.systemPartition.size = 200m
  disk.dataPartition.path = /home/hannie/.local/share/ubuntu-emulator/mijntouch/userdata.img
  disk.dataPartition.size = 200m
  avd.name = <build>
.
QEMU options list:
emulator: argv[00] = "/usr/share/android/emulator/out/host/linux-x86/bin/emulator-x86"
emulator: argv[01] = "-show-kernel"
emulator: argv[02] = "-serial"
emulator: argv[03] = "stdio"
emulator: argv[04] = "-android-hw"
emulator: argv[05] = "/home/hannie/.local/share/ubuntu-emulator/mijntouch/hardware-qemu.ini"
Concatenated QEMU options:
 /usr/share/android/emulator/out/host/linux-x86/bin/emulator-x86 -show-kernel -serial stdio -android-hw /home/hannie/.local/share/ubuntu-emulator/mijntouch/hardware-qemu.ini
emulator: registered 'boot-properties' qemud service
emulator: nand_add_dev: system,size=0xc800000,initfile=/home/hannie/.local/share/ubuntu-emulator/mijntouch/system.img,pagesize=512,extrasize=0
emulator: mapping 'system' NAND image to /tmp/android-hannie/emulator-cULnk6
emulator: nand_add_dev: userdata,size=0xc800000,file=/home/hannie/.local/share/ubuntu-emulator/mijntouch/userdata.img,pagesize=512,extrasize=0
emulator: registered 'boot-properties' qemud service
emulator: Adding boot property: 'dalvik.vm.heapsize' = '48m'
emulator: Adding boot property: 'qemu.sf.lcd_density' = '160'
emulator: Adding boot property: 'qemu.hw.mainkeys' = '1'
emulator: Adding boot property: 'qemu.sf.fake_camera' = 'back'
emulator: nand_add_dev: cache,size=0x4200000,file=/home/hannie/.local/share/ubuntu-emulator/mijntouch/cache.img,pagesize=512,extrasize=0
emulator: Initializing hardware OpenGLES emulation support
emulator: KVM mode auto-enabled!
emulator: Kernel parameters: qemu.gles=1 qemu=1 console=ttyS0 android.qemud=ttyS1 androidboot.hardware=goldfish clocksource=pit androidboot.console=ttyS2 ndns=1
emulator: trying to find: /usr/share/android/emulator/out/host/linux-x86/bin/bios.bin

emulator: trying to find: /usr/share/android/emulator/out/host/linux-x86/bin/lib/pc-bios/bios.bin

emulator: trying to find: /usr/share/android/emulator/out/host/linux-x86/bin/../usr/share/pc-bios/bios.bin

emulator: trying to find: /usr/share/android/emulator/out/host/linux-x86/bin/vgabios-cirrus.bin

emulator: trying to find: /usr/share/android/emulator/out/host/linux-x86/bin/lib/pc-bios/vgabios-cirrus.bin

emulator: trying to find: /usr/share/android/emulator/out/host/linux-x86/bin/../usr/share/pc-bios/vgabios-cirrus.bin

emulator: warning: opening audio output failed

emulator: Found ro.adb.qemud build property: 1
emulator: control console listening on port 5554, ADB on port 5555
emulator: can't connect to ADB server: Connection refused
emulator: ping program: /usr/share/android/emulator/out/host/linux-x86/bin/ddms
goldfish_fb_get_pixel_format:167: display surface,pixel format:
  bits/pixel: 16
  bytes/pixel: 2
  depth: 16
  red: bits=5 mask=0xf800 shift=11 max=0x1f
  green: bits=6 mask=0x7e0 shift=5 max=0x3f
  blue: bits=5 mask=0x1f shift=0 max=0x1f
  alpha: bits=0 mask=0x0 shift=0 max=0x0
[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Linux version 3.4.0-3-goldfish (buildd@toyol) (gcc version 4.7.4 (Ubuntu/Linaro 4.7.4-1ubuntu2) ) #17-Ubuntu PREEMPT Tue Jul 1 15:56:32 UTC 2014
[ 0.000000] KERNEL supported cpus:
[ 0.000000] Intel GenuineIntel
[ 0.000000] AMD AuthenticAMD
[ 0.000000] NSC Geode by NSC
[ 0.000000] Cyrix CyrixInstead
[ 0.000000] Centaur CentaurHauls
[ 0.000000] Transmeta GenuineTMx86
[ 0.000000] Transmeta TransmetaCPU
[ 0.000000] UMC UMC UMC UMC
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009f000 (usable)
[ 0.000000] BIOS-e820: 000000000009f000 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000e8000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 000000001fff0000 (usable)
[ 0.000000] BIOS-e820: 000000001fff0000 - 0000000020000000 (ACPI data)
[ 0.000000] BIOS-e820: 00000000fffc0000 - 0000000100000000 (reserved)
[ 0.000000] Notice: NX (Execute Disable) protection missing in CPU!
[ 0.000000] DMI 2.4 present.
[ 0.000000] last_pfn = 0x1fff0 max_arch_pfn = 0x100000
[ 0.000000] init_memory_mapping: 0000000000000000-000000001fff0000
[ 0.000000] RAMDISK: 1fc0d000 - 1fff0000
[ 0.000000] ACPI Error: A valid RSDP was not found (20120320/tbxfroot-219)
[ 0.000000] 511MB LOWMEM available.
[ 0.000000] mapped low ram: 0 - 1fff0000
[ 0.000000] low ram: 0 - 1fff0000
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0x00000010 -> 0x00001000
[ 0.000000] Normal 0x00001000 -> 0x0001fff0
[ 0.000000] Movable zone start PFN for each node
[ 0.000000] Early memory PFN ranges
[ 0.000000] 0: 0x00000010 -> 0x0000009f
[ 0.000000] 0: 0x00000100 -> 0x0001fff0
[ 0.000000] SFI: Simple Firmware Interface v0.81 http://simplefirmware.org
[ 0.000000] PM: Registered nosave memory: 000000000009f000 - 00000000000a0000
[ 0.000000] PM: Registered nosave memory: 00000000000a0000 - 00000000000e8000
[ 0.000000] PM: Registered nosave memory: 00000000000e8000 - 0000000000100000
[ 0.000000] Allocating PCI resources starting at 20000000 (gap: 20000000:dffc0000)
[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 129919
[ 0.000000] Kernel command line: qemu.gles=1 qemu=1 console=ttyS0 android.qemud=ttyS1 androidboot.hardware=goldfish clocksource=pit androidboot.console=ttyS2 ndns=1
[ 0.000000] PID hash table entries: 2048 (order: 1, 8192 bytes)
[ 0.000000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
[ 0.000000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
[ 0.000000] Initializing CPU#0
[ 0.000000] Memory: 504240k/524224k available (5604k kernel code, 19532k reserved, 3218k data, 368k init, 0k highmem)
[ 0.000000] virtual kernel memory layout:
[ 0.000000] fixmap : 0xfffe3000 - 0xfffff000 ( 112 kB)
[ 0.000000] vmalloc : 0xe07f0000 - 0xfffe1000 ( 503 MB)
[ 0.000000] lowmem : 0xc0000000 - 0xdfff0000 ( 511 MB)
[ 0.000000] .init : 0xc0a9e000 - 0xc0afa000 ( 368 kB)
[ 0.000000] .data : 0xc07792a1 - 0xc0a9db80 (3218 kB)
[ 0.000000] .text : 0xc0200000 - 0xc07792a1 (5604 kB)
[ 0.000000] Checking if this processor honours the WP bit even in supervisor mode...Ok.
[ 0.000000] SLUB: Genslabs=15, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:16 nr_irqs:16 16
[ 0.000000] Console: colour VGA+ 80x25
[ 0.000000] Fast TSC calibration failed
[ 0.000000] TSC: Unable to calibrate against PIT
[ 0.000000] TSC: No reference (HPET/PMTIMER) available
[ 0.000000] Marking TSC unstable due to could not calculate TSC khz
[ 0.020000] Calibrating delay loop... 6498.71 BogoMIPS (lpj=32493568)
[ 0.050000] pid_max: default: 32768 minimum: 301
[ 0.050000] Security Framework initialized
[ 0.050000] AppArmor: AppArmor initialized
[ 0.050000] Yama: becoming mindful.
[ 0.050000] Mount-cache hash table entries: 512
[ 0.050000] Initializing cgroup subsys cpuacct
[ 0.050000] Initializing cgroup subsys devices
[ 0.050000] Initializing cgroup subsys freezer
[ 0.050000] Initializing cgroup subsys blkio
[ 0.050000] Initializing cgroup subsys perf_event
[ 0.050000] CPU: Intel Pentium II (Klamath) stepping 03
[ 0.050000] Performance Events: Broken PMU hardware detected, using software events only.
[ 0.050000] NMI watchdog: disabled (cpu0): hardware events not enabled
[ 0.050000] devtmpfs: initialized
[ 0.050000] EVM: security.selinux
[ 0.050000] EVM: security.SMACK64
[ 0.050000] EVM: security.capability
[ 0.050000] dummy:
[ 0.050000] NET: Registered protocol family 16
[ 0.050000] PCI: PCI BIOS revision 2.10 entry at 0xfb3c0, last bus=0
[ 0.050000] PCI: Using configuration type 1 for base access
[ 0.050000] bio: create slab <bio-0> at 0
[ 0.050000] ACPI: Interpreter disabled.
[ 0.050000] vgaarb: loaded
[ 0.050000] i2c-core: driver [tps65090] using legacy suspend method
[ 0.050000] i2c-core: driver [tps65090] using legacy resume method
[ 0.050000] SCSI subsystem initialized
[ 0.050000] usbcore: registered new interface driver usbfs
[ 0.050000] usbcore: registered new interface driver hub
[ 0.050000] usbcore: registered new device driver usb
[ 0.050000] PCI: Probing PCI hardware
[ 0.050000] PCI host bridge to bus 0000:00
[ 0.050000] pci_bus 0000:00: root bus resource [io 0x0000-0xffff]
[ 0.050000] pci_bus 0000:00: root bus resource [mem 0x00000000-0xffffffff]
[ 0.050000] pci 0000:00:01.0: PIIX/ICH IRQ router [8086:7000]
[ 0.050000] cfg80211: Calling CRDA to update world regulatory domain
[ 0.050000] NetLabel: Initializing
[ 0.050000] NetLabel: domain hash size = 128
[ 0.050000] NetLabel: protocols = UNLABELED CIPSOv4
[ 0.050000] NetLabel: unlabeled traffic allowed by default
[ 0.050000] Switching to clocksource pit
[ 0.050000] AppArmor: AppArmor Filesystem Enabled
[ 0.050000] pnp: PnP ACPI: disabled
[ 0.050000] NET: Registered protocol family 2
[ 0.050000] IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
[ 0.050000] TCP established hash table entries: 16384 (order: 5, 131072 bytes)
[ 0.050000] TCP bind hash table entries: 16384 (order: 4, 65536 bytes)
[ 0.050000] TCP: Hash tables configured (established 16384 bind 16384)
[ 0.050000] TCP: reno registered
[ 0.050000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[ 0.050000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[ 0.050000] NET: Registered protocol family 1
[ 0.050000] pci 0000:00:00.0: Limiting direct PCI/PCI transfers
[ 0.050000] pci 0000:00:01.0: PIIX3: Enabling Passive Release
[ 0.050000] pci 0000:00:01.0: Activating ISA DMA hang workarounds
[ 0.050000] Trying to unpack rootfs image as initramfs...
[ 0.126021] Freeing initrd memory: 3980k freed
[ 0.126021] platform rtc_cmos: registered platform RTC device (no PNP device found)
[ 0.126021] goldfish_new_pdev goldfish_device_bus at ff001000 irq 4
[ 0.126021] goldfish_new_pdev goldfish-battery at ff010000 irq 5
[ 0.126021] goldfish_new_pdev goldfish_memlog at ff011000 irq -1
[ 0.126021] goldfish_new_pdev goldfish_nand at ff012000 irq -1
[ 0.126021] goldfish_new_pdev qemu_pipe at ff013000 irq 6
[ 0.126021] goldfish_new_pdev goldfish_mmc at ff005000 irq 7
[ 0.126021] goldfish_new_pdev goldfish_tty at ff015000 irq 8
[ 0.126021] goldfish_new_pdev goldfish_tty at ff016000 irq 9
[ 0.126021] goldfish_new_pdev goldfish_fb at ff017000 irq 10
[ 0.126021] goldfish_new_pdev goldfish_events at ff018000 irq 3
[ 0.126021] goldfish_pdev_worker registered goldfish_device_bus
[ 0.126021] goldfish_pdev_worker registered goldfish-battery
[ 0.126021] goldfish_pdev_worker registered goldfish_memlog
[ 0.126021] goldfish_pdev_worker registered goldfish_nand
[ 0.126021] goldfish_pdev_worker registered qemu_pipe
[ 0.126021] goldfish_pdev_worker registered goldfish_mmc
[ 0.126021] goldfish_pdev_worker registered goldfish_tty
[ 0.126021] goldfish_pdev_worker registered goldfish_tty
[ 0.126021] goldfish_pdev_worker registered goldfish_fb
[ 0.126021] goldfish_pdev_worker registered goldfish_events
[ 0.126021] audit: initializing netlink socket (disabled)
[ 0.126021] type=2000 audit(1406301014.120:1): initialized
[ 0.145997] HugeTLB registered 4 MB page size, pre-allocated 0 pages
[ 0.155991] VFS: Disk quotas dquot_6.5.2
[ 0.155991] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[ 0.155991] fuse init (API version 7.18)
[ 0.155991] msgmni has been set to 992
[ 0.155991] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[ 0.155991] io scheduler noop registered
[ 0.155991] io scheduler deadline registered
[ 0.155991] io scheduler cfq registered (default)
[ 0.155991] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[ 0.155991] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
[ 0.155991] allocating frame buffer 480 * 800, got de000000
[ 0.169477] Non-volatile memory driver v1.3
[ 0.169477] console [ttyS0] enabled
[ 0.169477] Linux agpgart interface v0.103
[ 0.169477] [drm] Initialized drm 1.1.0 20060810
[ 0.169477] [drm:i915_init] *ERROR* drm/i915 can't work without intel_agp module!
[ 0.176018] brd: module loaded
[ 0.176018] loop: module loaded
[ 0.176018] Loading iSCSI transport class v2.0-870.
[ 0.176018] goldfish nand dev0: size c800000, page 512, extra 0, erase 32768
[ 0.176018] goldfish nand dev1: size c800000, page 512, extra 0, erase 32768
[ 0.176018] goldfish nand dev2: size 4200000, page 512, extra 0, erase 32768
[ 0.176018] tun: Universal TUN/TAP device driver, 1.6
[ 0.176018] tun: (C) 1999-2004 Max Krasnyansky <email address hidden>
[ 0.176018] ne2k-pci.c:v1.03 9/22/2003 D. Becker/P. Gortmaker
[ 0.176018] ne2k-pci 0000:00:02.0: found PCI INT A -> IRQ 9
[ 0.176018] eth0: RealTek RTL-8029 found at 0xc000, IRQ 9, 52:54:00:12:34:56.
[ 0.176018] e100: Intel(R) PRO/100 Network Driver, 3.5.24-k2-NAPI
[ 0.176018] e100: Copyright(c) 1999-2006 Intel Corporation
[ 0.176018] e1000: Intel(R) PRO/1000 Network Driver - version 7.3.21-k8-NAPI
[ 0.176018] e1000: Copyright (c) 1999-2006 Intel Corporation.
[ 0.176018] e1000e: Intel(R) PRO/1000 Network Driver - 1.9.5-k
[ 0.176018] e1000e: Copyright(c) 1999 - 2012 Intel Corporation.
[ 0.176018] sky2: driver version 1.30
[ 0.176018] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 0.176018] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 0.176018] uhci_hcd: USB Universal Host Controller Interface driver
[ 0.176018] usbcore: registered new interface driver usblp
[ 0.176018] Initializing USB Mass Storage driver...
[ 0.176018] usbcore: registered new interface driver usb-storage
[ 0.176018] USB Mass Storage support registered.
[ 0.176018] usbcore: registered new interface driver libusual
[ 0.176018] mousedev: PS/2 mouse device common for all mice
[ 0.176018] *** events probe ***
[ 0.176018] events_probe() addr=0xe1008000 irq=3
[ 0.176018] events_probe() keymap=qwerty2
[ 0.176018] input: qwerty2 as /devices/virtual/input/input0
[ 0.176018] rtc_cmos rtc_cmos: rtc core: registered rtc_cmos as rtc0
[ 0.176018] rtc0: alarms up to one day, 114 bytes nvram
[ 0.176018] device-mapper: uevent: version 1.0.3
[ 0.176018] device-mapper: ioctl: 4.22.0-ioctl (2011-10-19) initialised: <email address hidden>
[ 0.176018] cpuidle: using governor ladder
[ 0.176018] cpuidle: using governor menu
[ 0.176018] EFI Variables Facility v0.08 2004-May-17
[ 0.176018] usbcore: registered new interface driver usbhid
[ 0.176018] usbhid: USB HID core driver
[ 0.185962] ashmem: initialized
[ 0.185962] logger: created 256K log 'log_main'
[ 0.185962] logger: created 256K log 'log_events'
[ 0.185962] logger: created 256K log 'log_radio'
[ 0.185962] logger: created 256K log 'log_system'
[ 0.185962] Netfilter messages via NETLINK v0.30.
[ 0.185962] nf_conntrack version 0.5.0 (7940 buckets, 31760 max)
[ 0.185962] ctnetlink v0.93: registering with nfnetlink.
[ 0.185962] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 0.185962] TCP: cubic registered
[ 0.185962] NET: Registered protocol family 10
[ 0.185962] ip6_tables: (C) 2000-2006 Netfilter Core Team
[ 0.185962] NET: Registered protocol family 17
[ 0.185962] Registering the dns_resolver key type
[ 0.185962] registered taskstats version 1
[ 0.185962] AppArmor: AppArmor sha1 policy hashing enabled
[ 0.185962] console [netcon0] enabled
[ 0.185962] netconsole: network logging started
[ 0.185962] Freeing unused kernel memory: 368k freed
[ 0.185962] Write protecting the kernel text: 5608k
[ 0.185962] Write protecting the kernel read-only data: 2768k
Loading, please wait...
Begin: Loading essential drivers ... done.
Begin: Running /scripts/init-premount ... done.
[ 0.195962] systemd-udevd[94]: starting version 204
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... done.
Begin: Running /scripts/local-premount ... done.
[ 0.225926] mmc0: new SDHC card at address e118
[ 0.235918] mmcblk0: mmc0:e118 SU02G 4.00 GiB
[ 0.235918] mmcblk0: unknown partition table
[ 0.315816] initrd: mounting /dev/mmcblk0
[ 0.315816] EXT4-fs (mmcblk0): couldn't mount as ext3 due to feature incompatibilities
[ 0.325884] EXT4-fs (mmcblk0): couldn't mount as ext2 due to feature incompatibilities
[ 0.615799] EXT4-fs (mmcblk0): 2 orphan inodes deleted
[ 0.615799] EXT4-fs (mmcblk0): recovery complete
[ 0.635586] EXT4-fs (mmcblk0): mounted filesystem with ordered data mode. Opts: discard
[ 0.736057] EXT4-fs (loop0): couldn't mount as ext3 due to feature incompatibilities
[ 0.746470] EXT4-fs (loop0): couldn't mount as ext2 due to feature incompatibilities
[ 0.906339] EXT4-fs (loop0): recovery complete
[ 0.906339] EXT4-fs (loop0): mounted filesystem with ordered data mode. Opts: (null)
[ 0.906339] initrd: mounting system.img (image developer mode)
[ 1.066396] EXT4-fs (loop1): couldn't mount as ext3 due to feature incompatibilities
[ 1.076102] EXT4-fs (loop1): couldn't mount as ext2 due to feature incompatibilities
[ 1.086122] EXT4-fs (loop1): mounted filesystem with ordered data mode. Opts: (null)
[ 1.095547] initrd: device is generic_x86
[ 1.485899] initrd: checking mount label mtdblock2
[ 1.485899] initrd: mounting /dev/mtdblock2 as /root/android//cache
mount: mounting /dev/mtdblock2 on /root/android//cache failed: Invalid argument
[ 1.495700] initrd: mounting /root/var/lib/lxc/android/system.img as /root/android/system
Begin: Running /scripts/local-bottom ... done.
done.
Begin: Running /scripts/init-bottom ... done.
[ 2.616041] init: ureadahead-touch main process (268) terminated with status 5
[ 4.095557] init: no-cpu-hotplug main process (428) terminated with status 1
[ 5.276160] init: /dev/hw_random not found
[ 5.276160] init: cannot open '/initlogo.rle'
[ 5.326073] init: /dev/hw_random not found
[ 5.326073] healthd: wakealarm_init: timerfd_create failed
[ 5.346284] init: cannot find '/system/etc/install-recovery.sh', disabling 'flash_recovery'
[ 5.346284] init: cannot find '/system/bin/ubuntuappmanager.disabled', disabling 'ubuntuappmanager'
[ 5.525838] init: property 'sys.powerctl' doesn't exist while expanding '${sys.powerctl}'
[ 5.525838] init: powerctl: cannot expand '${sys.powerctl}'
[ 5.525838] init: property 'sys.sysctl.extra_free_kbytes' doesn't exist while expanding '${sys.sysctl.extra_free_kbytes}'
[ 5.525838] init: cannot expand '${sys.sysctl.extra_free_kbytes}' while writing to '/proc/sys/vm/extra_free_kbytes'
[ 5.525838] init: cannot find '/sbin/adbd', disabling 'adbd'
[ 8.465659] systemd-logind[585]: cgmanager: cgm_list_children for controller=systemd, cgroup_path=user failed: invalid request
 * Setting up X socket directories... [ OK ]
 * Starting automatic crash report generation: apport [ OK ]
emulator: User configuration saved to /home/hannie/.android/emulator-user.ini

Download full text (24.0 KiB)

On sábado 26 de julio de 2014 12h'58:48 ART, Hannie Dumoleyn wrote:
> Public bug reported:
>
> What I did
>
> 23-7-2014
> http://davidplanella.org/ubuntu-emulator-quickstart-guide/
> sudo add-apt-repository ppa:ubuntu-sdk-team/ppa && sudo apt-get update
> sudo apt-get install ubuntu-emulator
> me@ubuntu:~$ sudo ubuntu-emulator create mijntouch --arch=i386
> Succesfully created emulator instance mijntouch in
> /home/hannie/.local/share/ubuntu-emulator/mijntouch
> me@ubuntu:~$ ubuntu-emulator run mijntouch
>
> cgroup_path=user failed: invalid request
> * Setting up X socket directories...
> [ OK ]
> * Starting automatic crash report generation: apport
>
> My computer crashed!!! Crash report .crash is too big to send
> as an attachment
> ========================================================
> Troubleshooting
> after having replaced the nouveau driver with nvidia version
> 304.117 for my GeForce 6, the emulator works. I got an
> introduction and on the display I now see date, time and the
> message "No data sources available". There is nothing I can do
> so far, because a lot of files seem to be missing (see terminal
> output below).
> Example: I checked the first one:
> trying to find: /usr/share/android/emulator/out/host/linux-x86/bin/bios.bin
> This subdirectory /bin/ does contain files like emulator,
> emulator-x86 and others, but there is no bios.bin here. I found
> bios.bin in
> /usr/share/android/emulator/out/host/linux-x86/usr/share/pc-bios
> instead.
> Is this normal?

It's rolling until it finds it, the last trying to find is the one it
finds. I don't understand what this bug is about though.

> ========================================================
> Output terminal 25 juli 2014
> me@ubuntu:~$ ubuntu-emulator run mijntouch
> emulator: autoconfig: -ramdisk
> /home/hannie/.local/share/ubuntu-emulator/mijntouch/ramdisk.img
> emulator: autoconfig: -datadir
> /home/hannie/.local/share/ubuntu-emulator/mijntouch
> emulator: Found target ABI=x86, architecture=x86
> emulator: Found target API level: 19
> emulator: using core hw config path:
> /home/hannie/.local/share/ubuntu-emulator/mijntouch/hardware-qemu.ini
> emulator: keyset loaded from: /home/hannie/.android/default.keyset
> emulator: trying to load skin file
> '/usr/share/ubuntu-emulator/skins/EDGE/layout'
> emulator: skin network speed: 'full'
> emulator: skin network delay: 'none'
> emulator: Using initial system image:
> /home/hannie/.local/share/ubuntu-emulator/mijntouch/system.img
> emulator: autoconfig: -initdata
> /home/hannie/.local/share/ubuntu-emulator/mijntouch/userdata.img
> emulator: Physical RAM size: 512MB
>
> emulator: Found target ABI=x86
> Content of hardware configuration file:
> hw.cpu.arch = x86
> hw.ramSize = 512
> hw.screen = touch
> hw.mainKeys = yes
> hw.trackBall = yes
> hw.keyboard = no
> hw.keyboard.lid = no
> hw.keyboard.charmap = qwerty2
> hw.dPad = yes
> hw.gsmModem = yes
> hw.gps = yes
> hw.battery = yes
> hw.accelerometer = yes
> hw.audioInput = yes
> hw.audioOutput = yes
> hw.sdCard = yes
> hw.sdCard.path =
> /home/hannie/.local/share/ubuntu-emulator/mijntouc...

The bug is that I cannot do anything with the emulator. It shows me the message "No data sources available". I think during installation files have not landed in the right place, but I do not know why.
In David's quickstart guide it says: The phone UI – this is the visual part of the emulator, where you can interact with the UI in the same way you’d do it with a phone. You can use your mouse to simulate taps and slides.
The bug is that there is nothing to interact because there are no icons and there is nothing to tap with the mouse.
Do you want me to send you a screenshot of the message "No data sources available"?

More information: One example: the script looks for
emulator: trying to find: /usr/share/android/emulator/out/host/linux-x86/bin/lib/pc-bios/bios.bin
I found bios.bin in /usr/share/android/emulator/out/host/linux-x86/usr/share/pc-bios/bios.bin
Conclusion: during the installation with the command 'sudo apt-get install ubuntu-emulator' files are not placed in the right directories. I cannot move them elsewhere because files like bios.bin are protected.

After having reinstalled the emulator, I now get a black screen when running myinstance, ubuntu-emulator run mijntouch (see screenshot).

Matthew Paul Thomas (mpt) wrote :

Hannie, that the phone says "No data sources available" on first use is bug 1286276. That isn't specific to the emulator.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers