add GI marshalling test interface

Bug #1314441 reported by Tim Lunn on 2014-04-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gobject-introspection (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned

Bug Description

[Impact]
This is required by gjs 1.40.1 (which fixes GC re-entrancy issues that are causing 1000+ hits per day on errors.u.c), which we want to SRU into trusty

[Test Case]
N/A

[Regression Potential]
None, this only affects tests, and currently gjs is the only user of this new interface

ProblemType: BugDistroRelease: Ubuntu 14.10
Package: gobject-introspection 1.40.0-2
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Apr 30 12:01:35 2014
InstallationDate: Installed on 2012-09-23 (584 days ago)
InstallationMedia: Ubuntu GNOME Remix 12.10 "Quantal Quetzal" - Alpha amd64(20120922)SourcePackage: gobject-introspection
UpgradeStatus: No upgrade log present (probably fresh install)

Tim Lunn (darkxst) wrote :
Tim Lunn (darkxst) wrote :
description: updated
Martin Pitt (pitti) wrote :

Uploaded to utopic and to trusty-proposed queue. Unsubscribing sponsors.

Changed in gobject-introspection (Ubuntu Utopic):
status: New → Fix Committed
Changed in gobject-introspection (Ubuntu Trusty):
status: New → In Progress
Tim Lunn (darkxst) on 2014-04-30
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gobject-introspection - 1.40.0-2ubuntu1

---------------
gobject-introspection (1.40.0-2ubuntu1) utopic; urgency=medium

  * Add git_tests_implementation_interface.patch: git patch required by gjs
    1.40.1 (LP: #1314441)
 -- Tim Lunn <email address hidden> Sun, 27 Apr 2014 09:36:13 +1000

Changed in gobject-introspection (Ubuntu Utopic):
status: Fix Committed → Fix Released

Hello Tim, or anyone else affected,

Accepted gobject-introspection into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gobject-introspection/1.40.0-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gobject-introspection (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Tim Lunn (darkxst) wrote :

marking verification-done, since gjs 1.40.1 test suite passed

  /js/GIMarshalling: OK

https://launchpadlibrarian.net/174311025/buildlog_ubuntu-trusty-amd64.gjs_1.40.1-0ubuntu0.2_UPLOADING.txt.gz

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gobject-introspection - 1.40.0-1ubuntu0.1

---------------
gobject-introspection (1.40.0-1ubuntu0.1) trusty-proposed; urgency=medium

  * Add git_tests_implementation_interface.patch: git patch required by gjs
    1.40.1 (LP: #1314441)
 -- Tim Lunn <email address hidden> Sun, 27 Apr 2014 09:36:13 +1000

Changed in gobject-introspection (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gobject-introspection has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers