Disable TLS below 1.2 by default

Bug #1856428 reported by Dimitri John Ledkov on 2019-12-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnutls28 (Ubuntu)
Undecided
Unassigned
golang-1.13 (Ubuntu)
Undecided
Unassigned
nss (Ubuntu)
Undecided
Unassigned
openssl (Ubuntu)
Undecided
Unassigned

Bug Description

Disable TLS 1.0, TLS1.1, DTLS1.0

As part of focal commitment, we shall disable obsolete protocols by default.

Users can override this behaviour with a config file.

Related branches

CVE References

summary: - Raise minimum key requirements to 2k and disable TLS 1.0 and 1.1
+ Disable TLS1.0, TLS 1.1, DTLS1.0
description: updated
tags: added: id-5db1c4c64e98bd59adc18616
summary: - Disable TLS1.0, TLS 1.1, DTLS1.0
+ Disable TLS1.0, TLS 1.1
Changed in openssl (Ubuntu):
status: New → In Progress
Changed in openssl (Ubuntu):
status: In Progress → Fix Committed
Changed in gnutls28 (Ubuntu):
status: New → In Progress
Changed in nss (Ubuntu):
status: New → Triaged
Changed in gnutls28 (Ubuntu):
status: In Progress → Fix Committed
Changed in nss (Ubuntu):
status: Triaged → Fix Committed
summary: - Disable TLS1.0, TLS 1.1
+ Disable TLS below 1.2 by default
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nss - 2:3.48-1ubuntu1

---------------
nss (2:3.48-1ubuntu1) focal; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - d/libnss3.links: make freebl3 available as library (LP #1744328)
    - d/control: add dh-exec to Build-Depends
    - d/rules: make mkdir tolerate debian/tmp existing (due to dh-exec)
    - Disable reading fips_enabled flag in FIPS mode. libnss is
      not a FIPS certified library. (LP #1837734)
  * Set TLSv1.2 as minimum TLS version. LP: #1856428

nss (2:3.48-1) unstable; urgency=medium

  * New upstream release. Closes: #947131.
  * debian/control: Bump nspr build dependency to 4.24.
  * nss/lib/freebl/Makefile: Disable hardware AES on ARM softfloat to fix
    FTBFS on armel. Closes: #947246.

nss (2:3.47.1-1) unstable; urgency=medium

  * New upstream release.
    - Fixes CVE-2019-11745.

 -- Ubuntu Merge-o-Matic <email address hidden> Sun, 29 Dec 2019 03:43:36 +0000

Changed in nss (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnutls28 (Ubuntu):
status: Fix Committed → Fix Released
James Henstridge (jamesh) wrote :

For anyone who finds this bug, and wonders about the "Users can override this behaviour with a config file" part, here's what I did to get an OpenSSL-using application to talk to an old server that only supported TLSv1 (in my case, an old Mumble server):

1. create an "openssl.cnf" file somewhere with the following contents:

    openssl_conf = openssl_init

    [openssl_init]
    ssl_conf = ssl_sect

    [ssl_sect]
    system_default = system_default_sect

    [system_default_sect]
    CipherString = DEFAULT@SECLEVEL=1

2. set the OPENSSL_CONF environment variable to this file's path when running the application.

I wouldn't recommend making the change to the global /etc/ssl/openssl.cnf, or setting $OPENSSL_CONF for situations where it isn't needed, since this does reduce the default security.

Changed in openssl (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers