"pkg-config --static --libs gnutls" includes an option that gcc doesn't recognize (-R)

Bug #1478035 reported by Peter Maydell on 2015-07-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnutls26 (Ubuntu)
Undecided
Unassigned

Bug Description

The output of "pkg-config --static --libs gnutls" is the following:

-R/usr/lib/x86_64-linux-gnu -lgnutls -lgcrypt -lgpg-error -ltasn1 -lz -lp11-kit

However, gcc doesn't understand the "-R" option, so you can't pass the pkg-config output as a set of gcc command line options the way that pkg-config says you are supposed to be able to.

It seems likely to me that this -R option is an error and should be removed.

(The pkg-config output for a non-static build is fine.)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libgnutls-dev 2.12.23-12ubuntu2.2
ProcVersionSignature: Ubuntu 3.13.0-44.73-generic 3.13.11-ckt12
Uname: Linux 3.13.0-44-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.11
Architecture: amd64
Date: Fri Jul 24 15:49:47 2015
InstallationDate: Installed on 2014-05-22 (428 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
SourcePackage: gnutls26
UpgradeStatus: No upgrade log present (probably fresh install)

Peter Maydell (pmaydell) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers