Unable to connect using explicit FTP over TLS

Bug #1261459 reported by _dan_ on 2013-12-16
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
filezilla (Ubuntu)
Undecided
Unassigned
gnutls26 (Ubuntu)
Undecided
Unassigned

Bug Description

Since saucy, i am unable to connect to FTPs with tls using "explicit FTP over TLS".
error message:

Command: AUTH TLS
Response: 234 AUTH TLS successful
Status: Initializing TLS...
Error: GnuTLS error -89: Public key signature verification has failed.
Error: Could not connect to server

Other clients work well, also downloading the precompiled binary from the filezilla HP works, seems an ubuntu specific bug.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: filezilla 3.7.3-1ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-15.23-generic 3.11.10
Uname: Linux 3.11.0-15-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
Date: Mon Dec 16 18:10:59 2013
InstallationDate: Installed on 2013-12-13 (2 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
SourcePackage: filezilla
UpgradeStatus: No upgrade log present (probably fresh install)

_dan_ (dan-void) wrote :
_dan_ (dan-void) on 2014-02-28
affects: filezilla (Ubuntu) → gnutls26 (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnutls26 (Ubuntu):
status: New → Confirmed
Kimse (0-kh) wrote :

Status: Connection established, waiting for welcome message...
Response: 220 Server ready.
Command: AUTH TLS
Response: 234 AUTH TLS successful
Status: Initializing TLS...
Error: GnuTLS error -89: Public key signature verification has failed.
Error: Could not connect to server

_dan_ (dan-void) wrote :

Still present in 14.04

_dan_ (dan-void) on 2014-04-30
Changed in filezilla (Ubuntu):
status: New → Confirmed
Z4ndX (z4ndxx) wrote :

Still present in 14.04...

Benny Boy (bmartinp) wrote :

I have this problem in Ubuntu 14.04 up2date.

Tim Kosse (tim-kosse) wrote :

GnuTLS 2.12.x is too old. Please package FileZilla against GnuTLS 3.1.12 or greater.

Hiroshi Miura (miurahr) wrote :

I've added patches to build filezilla against later GnuTLS.

Hiroshi Miura (miurahr) wrote :

The attachment "debian/control to compile against libgnutls28" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers