gnuradio version 3.2.2.dfsg-1ubuntu6 failed to build in oneiric

Bug #835758 reported by Matthias Klose on 2011-08-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnuradio (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

gnuradio version 3.2.2.dfsg-1ubuntu6 failed to build in oneiric
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2694711

Details about the rebuild:
http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20110816-oneiric.html

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2694711/+files/buildlog_ubuntu-oneiric-i386.gnuradio_3.2.2.dfsg-1ubuntu6_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 4631 lines into the build log:

/usr/bin/ld: note: 'CppUnit::TextTestRunner::run(std::basic_string<char, std::char_traits<char>, std::allocator<char> >, bool, bool, bool)' is defined in DSO /usr/lib/libcppunit-1.12.so.1 so try adding it to the linker command line
/usr/lib/libcppunit-1.12.so.1: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[5]: *** [test_all] Error 1
make[5]: Leaving directory `/build/buildd/gnuradio-3.2.2.dfsg/gnuradio-core/src/tests'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/build/buildd/gnuradio-3.2.2.dfsg/gnuradio-core/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/build/buildd/gnuradio-3.2.2.dfsg/gnuradio-core'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/build/buildd/gnuradio-3.2.2.dfsg'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/gnuradio-3.2.2.dfsg'
make: *** [build-stamp] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110821-0158
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/gnuradio-3.2.2.dfsg

Matthias Klose (doko) on 2011-08-28
Changed in gnuradio (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Matthias Klose (doko) wrote :

fixed in 3.2.2.dfsg-1ubuntu7

Changed in gnuradio (Ubuntu Oneiric):
status: Confirmed → Fix Released
Matthias Klose (doko) wrote :

... but still ftbfs on armel

Changed in gnuradio (Ubuntu Oneiric):
status: Fix Released → Confirmed
Marcin Juszkiewicz (hrw) wrote :

Component gr-wxgui passed configuration checks; building.
checking for PyQt4 for Qt4... yes
checking for QTCORE... yes
checking for QTGUI... yes
checking for QTOPENGL... yes
checking qwt/qwt.h usability... no
checking qwt/qwt.h presence... no
checking for qwt/qwt.h... no
checking qwt-qt4/qwt.h usability... yes
checking qwt-qt4/qwt.h presence... yes
checking for qwt-qt4/qwt.h... yes
checking for main in -lqwt... no
checking for main in -lqwt-qt4... yes
checking qwtplot3d/qwt3d_plot.h usability... no
checking qwtplot3d/qwt3d_plot.h presence... no
checking for qwtplot3d/qwt3d_plot.h... no
checking qwtplot3d-qt4/qwt3d_plot.h usability... no
checking qwtplot3d-qt4/qwt3d_plot.h presence... yes
configure: WARNING: qwtplot3d-qt4/qwt3d_plot.h: present but cannot be compiled
configure: WARNING: qwtplot3d-qt4/qwt3d_plot.h: check for missing prerequisite headers?
configure: WARNING: qwtplot3d-qt4/qwt3d_plot.h: see the Autoconf documentation
configure: WARNING: qwtplot3d-qt4/qwt3d_plot.h: section "Present But Cannot Be Compiled"
configure: WARNING: qwtplot3d-qt4/qwt3d_plot.h: proceeding with the compiler's result
checking for qwtplot3d-qt4/qwt3d_plot.h... no
Could not find qwtplot3d headers
configure: error: Component gr-qtgui has errors; stopping.
make: *** [configure-stamp] Error 1
dpkg-buildpackage: error: debian/rules build gave error exit status 2

full armel buildlog: https://launchpadlibrarian.net/78357037/buildlog_ubuntu-oneiric-armel.gnuradio_3.2.2.dfsg-1ubuntu7_FAILEDTOBUILD.txt.gz

Marcin Juszkiewicz (hrw) wrote :

reason:
configure:31684: g++ -c -g -O2 -pthread -DQT_SHARED -I/usr/include/qt4 -I/usr/include/qt4/QtCore -DQT_SHARED -I/usr/include/qt4 -I/usr/include/qt4/QtGui -I/usr/include
/qt4/QtCore -I/usr/include/qwt-qt4 conftest.cpp >&5
In file included from /usr/include/qwtplot3d-qt4/qwt3d_types.h:26:0,
                 from /usr/include/qwtplot3d-qt4/qwt3d_drawable.h:7,
                 from /usr/include/qwtplot3d-qt4/qwt3d_label.h:10,
                 from /usr/include/qwtplot3d-qt4/qwt3d_axis.h:5,
                 from /usr/include/qwtplot3d-qt4/qwt3d_coordsys.h:4,
                 from /usr/include/qwtplot3d-qt4/qwt3d_plot.h:4,
                 from conftest.cpp:159:
/usr/include/qwtplot3d-qt4/qwt3d_openglhelper.h: In function 'const GLubyte* Qwt3D::gl_error()':
/usr/include/qwtplot3d-qt4/qwt3d_openglhelper.h:67:31: error: 'gluErrorString' was not declared in this scope
/usr/include/qwtplot3d-qt4/qwt3d_openglhelper.h: In function 'void Qwt3D::SaveGlDeleteLists(GLuint&, GLsizei)':
/usr/include/qwtplot3d-qt4/qwt3d_openglhelper.h:74:21: error: 'glIsList' was not declared in this scope
/usr/include/qwtplot3d-qt4/qwt3d_openglhelper.h:75:30: error: 'glDeleteLists' was not declared in this scope
/usr/include/qwtplot3d-qt4/qwt3d_openglhelper.h: In function 'void Qwt3D::getMatrices(GLdouble*, GLdouble*, GLint*)':
/usr/include/qwtplot3d-qt4/qwt3d_openglhelper.h:89:15: error: 'GL_MODELVIEW_MATRIX' was not declared in this scope
/usr/include/qwtplot3d-qt4/qwt3d_openglhelper.h:89:47: error: 'glGetDoublev' was not declared in this scope
/usr/include/qwtplot3d-qt4/qwt3d_openglhelper.h:90:15: error: 'GL_PROJECTION_MATRIX' was not declared in this scope
/usr/include/qwtplot3d-qt4/qwt3d_openglhelper.h: In function 'bool Qwt3D::ViewPort2World(double&, double&, double&, double, double, double)':
/usr/include/qwtplot3d-qt4/qwt3d_openglhelper.h:104:97: error: 'gluUnProject' was not declared in this scope
/usr/include/qwtplot3d-qt4/qwt3d_openglhelper.h: In function 'bool Qwt3D::World2ViewPort(double&, double&, double&, double, double, double)':
/usr/include/qwtplot3d-qt4/qwt3d_openglhelper.h:120:95: error: 'gluProject' was not declared in this scope
In file included from /usr/include/qwtplot3d-qt4/qwt3d_plot.h:5:0,
                 from conftest.cpp:159:
/usr/include/qwtplot3d-qt4/qwt3d_enrichment_std.h: At global scope:
/usr/include/qwtplot3d-qt4/qwt3d_enrichment_std.h:65:2: error: 'GLUquadricObj' does not name a type
/usr/include/qwtplot3d-qt4/qwt3d_enrichment_std.h:66:2: error: 'GLUquadricObj' does not name a type
/usr/include/qwtplot3d-qt4/qwt3d_enrichment_std.h:96:2: error: 'GLUquadricObj' does not name a type
/usr/include/qwtplot3d-qt4/qwt3d_enrichment_std.h:97:2: error: 'GLUquadricObj' does not name a type
/usr/include/qwtplot3d-qt4/qwt3d_enrichment_std.h:98:2: error: 'GLUquadricObj' does not name a type
/usr/include/qwtplot3d-qt4/qwt3d_enrichment_std.h:99:2: error: 'GLUquadricObj' does not name a type

Angel Abad (angelabad) wrote :

Fixed in 3.2.2.dfsg-1ubuntu7 upload

Changed in gnuradio (Ubuntu Oneiric):
status: Confirmed → Fix Released
Marcin Juszkiewicz (hrw) wrote :

3.2.2.dfsg-1ubuntu7 failed in oneiric - this package will not build on armel due to OpenGL

Changed in gnuradio (Ubuntu Oneiric):
status: Fix Released → Invalid
status: Invalid → Opinion
Changed in gnuradio (Ubuntu):
status: Fix Released → Opinion
tags: added: opengles
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers