Ubuntu

gnuplot is not GNU and not free Software

Reported by Martin Fischer on 2008-02-24
16
Affects Status Importance Assigned to Milestone
gnuplot (Debian)
New
Unknown
gnuplot (Ubuntu)
Critical
Unassigned

Bug Description

Binary package hint: gnuplot

Sadly,
gnuplot is only freeware, It is not allowed to distribute modified versions.
http://www.gnuplot.info/faq/faq.html#SECTION00037000000000000000

Move to restricted ?

Andrea Colangelo (warp10) wrote :

"Copyright" file within the packages says:

/*[
 * Copyright 1986 - 1993, 1998, 2004 Thomas Williams, Colin Kelley
 *
 * Permission to use, copy, and distribute this software and its
 * documentation for any purpose with or without fee is hereby granted,
 * provided that the above copyright notice appear in all copies and
 * that both that copyright notice and this permission notice appear
 * in supporting documentation.
 *
 * Permission to modify the software is granted, but not the right to
 * distribute the complete modified source code. Modifications are to
 * be distributed as patches to the released version. Permission to
 * distribute binaries produced by compiling modified sources is granted,
 * provided you
 * 1. distribute the corresponding source modifications from the
 * released version in the form of a patch file along with the binaries,
 * 2. add special version identification to distinguish your version
 * in addition to the base release version number,
 * 3. provide your name and address as the primary contact for the
 * support of your modified version, and
 * 4. retain our contact information in regard to use of the base
 * software.
 * Permission to distribute the released version of the source code along
 * with corresponding source modifications in the form of a patch file is
 * granted with same provisions 2 through 4 for binary distributions.
 *
 * This software is provided "as is" without express or implied warranty
 * to the extent permitted by applicable law.
]*/

It is surely not a canonical free license, but it should be enough to keep it in universe.
Setting this bug as incomplete, would someone more expert than me to say something on that?

Changed in gnuplot:
status: New → Incomplete
Craig Maloney (craig-decafbad) wrote :

Addendum, from the FAQ:

1.6 Legalities

Gnuplot is freeware authored by a collection of volunteers, who cannot make any legal statement about the compliance or non-compliance of gnuplot or its uses. There is also no warranty whatsoever. Use at your own risk.

Citing from the README of a mathematical subroutine package by R. Freund:

    For all intent and purpose, any description of what the codes are doing should be construed as being a note of what we thought the codes did on our machine on a particular Tuesday of last year. If you're really lucky, they might do the same for you someday. Then again, do you really feel *that* lucky?

1.7 Does gnuplot have anything to do with the FSF and the GNU project?

Gnuplot is neither written nor maintained by the FSF. It is not covered by the General Public License, either. It used to be distributed by the FSF, however, due to licensing issues it is no longer.

Gnuplot is freeware in the sense that you don't have to pay for it. However it is not freeware in the sense that you would be allowed to distribute a modified version of your gnuplot freely. Please read and accept the Copyright file in your distribution.

1.8 Where do I get further information?

See the main gnuplot web page http://www.gnuplot.info and references therein, mainly gnuplot links http://gnuplot.sourceforge.net/links.html.

Some documentation and tutorials are available in other languages than English. See http://gnuplot.sourceforge.net/help.html, section "Localized learning pages about gnuplot", for the most up-to-date list.

Changed in gnuplot:
status: Unknown → New
vexorian (vexorian) wrote :

Man, I was just about to use it for home work, quite a disappointment that it does such false advertizement by getting called gnuplot, I think they should have changed the name or something, I don't really get why it is so restrictive in distribution. I think it should be moved somewhere else. Since it was hosted in sourceforge and was in the hardy repo I thought it was at least open source, but no dice...

Craig Maloney (craig-decafbad) wrote :

Marking as confirmed. Checking to see if there's any other tagging needed.

Changed in gnuplot:
status: Incomplete → Confirmed
James Westby (james-w) on 2008-06-18
Changed in gnuplot:
importance: Undecided → Critical
Colin Watson (cjwatson) wrote :

The requirement to distribute modified versions as patches is explicitly allowed by http://www.ubuntu.com/community/ubuntustory/licensing, and Ubuntu's source package distribution method meets this requirement. What else is problematic here?

Emmet Hikory (persia) wrote :

Reviewing the license, I see three main points:

1) Permission to modify the software is granted, but not the right to distribute the complete modified source code. Modifications are to be distributed as patches to the released version.

    Looking at the source being distributed (apt-get source gnuplot), Ubuntu is compliant with the license by including patches to the source code as separate patches, rather than inline in the source (although the change for docs/gnuplot.texi is debatable).

2) Permission to distribute binaries produced by compiling modified sources is granted, provided you
... 3. provide your name and address as the primary contact for the support of your modified version

    While this is mentioned in the linked Debian bug, I'm not sure where such a change needs be made. It may be that the use of Maintainer is sufficient, or it may be that this belongs somewhre else (I only find references to "primary contact" in the license).

3) Permission to distribute the released version of the source code along with corresponding source modifications in the form of a patch file is granted with same provisions 2 through 4 for binary distributions.

    This is indeed the practice followed by Ubuntu for this package: the binaries are distributed with a special version (the "revision" code), with information that the appropriate contact is the Ubuntu developers, and with upstream contact information included in the source.

From #ubuntu-devel:

[21:59] <cjwatson> Hobbsee: the requirement to distribute as patches is explicitly allowed by http://www.ubuntu.com/community/ubuntustory/licensing
[21:59] <cjwatson> which other part of that is non-free
[22:03] <cjwatson> the only bit flagged by debian-legal as potentially awkward was the contact identification thing, which could be read to prohibit anonymous modifications (although I don't buy that inference)
[22:04] <cjwatson> happy to have a second opinion, but I think it's free
[22:04] <cjwatson> (and indeed I think there *should* be a second opinion)

Changed in gnuplot:
status: New → Fix Released
Lorenzo J. Lucchini (ljl) wrote :

It's in Debian, so, unless the issue's been already brought up, might it not be useful to report the issue to debian-legal, where they thrive with license subtleties and determining whether or not something is free enough to distribute?

Henrik Nilsen Omma (henrik) wrote :

IMO the license walks a fine line between freeware and free software. It does allow you to make changes and distribute them but in an awkward form.

The reason it's problematic is that it doesn't encourage the positive cycle that you naturally get with other free licenses in that improvements easily feed into the trunk of the project or alternatively gives you the right to fork.

It's basically the minix license which allowed the distribution of patch sets but not the full modified source. You could fork it in theory but it would have to be forever distributed as a combination of the original source at the version you forked and an ever-growing set of patches.

That said, debian-legal do consider this to be DFSG-free but consider it to be a compromise. From the linked Debian bug:

> 4. Integrity of The Author's Source Code
>
> The license may restrict source-code from being distributed in
> modified form _only_ if the license allows the distribution of "patch
> files" with the source code for the purpose of modifying the program at
> build time. The license must explicitly permit distribution of software
> built from modified source code. The license may require derived works
> to carry a different name or version number from the original
> software. (This is a compromise. The Debian group encourages all authors
> not to restrict any files, source or binary, from being modified.)

And the copyright license for gnuplot does allow you to distribute the
modified version provided that you:

> 1. distribute the corresponding source modifications from the
> released version in the form of a patch file along with the binaries,

So it does qualify to be in Debian free, even though it IS
GPL-incompatible (e.g. it may not be distributed in binary form with the
GNU readline library linked to it), because of that additional restriction.

--------

I think we should follow Debian here and recognise that while it's not a standard free software license our own guidelines do allow for it as Colin points out. Some may not agree with that policy choice but that's a different matter.

To allow us to move on I'm closing the bug report.

Changed in gnuplot:
status: Confirmed → Invalid
Changed in gnuplot (Debian):
status: Fix Released → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.