Ubuntu

gpg2: pkglue.c:41: mpi_from_sexp: Assertion `data' failed.

Reported by Anders Kaseorg on 2011-07-23
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gnupg2 (Debian)
Fix Released
Unknown
gnupg2 (Ubuntu)
High
Dave Walker

Bug Description

I get the following error messages about half the time when using gpg2 in oneiric:

gpg2: pkglue.c:41: mpi_from_sexp: Assertion `data' failed.
Aborted (core dumped)

Based on http://marc.info/?l=gcrypt-devel&m=130963052602822&w=3 , I tried this upstream patch and confirmed that it fixes the problem:
http://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git;a=commitdiff;h=13290b0e0fcf3a493e4848b29329d56b69bc4dd9

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnupg2 2.0.17-2ubuntu1 [modified: usr/share/doc/gnupg2/changelog.Debian.gz]
ProcVersionSignature: Ubuntu 3.0.0-6.7-generic 3.0.0-rc7
Uname: Linux 3.0.0-6-generic x86_64
NonfreeKernelModules: openafs
Architecture: amd64
Date: Sat Jul 23 15:31:23 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnupg2
UpgradeStatus: No upgrade log present (probably fresh install)

Anders Kaseorg (anders-kaseorg) wrote :
Anders Kaseorg (anders-kaseorg) wrote :
tags: added: patch
removed: unity-2d
Changed in gnupg2 (Ubuntu):
status: New → Confirmed
Martin Pool (mbp) wrote :

I get this too.

It seems like running 'gpg --update-trustdb' may work around the problem? (I don't know; perhaps it's just intermittent?)

Martin Pool (mbp) wrote :

No, I spoke too soon, it still fails.

Anders Kaseorg (anders-kaseorg) wrote :

Can you try my patch in comment 2 (also built in https://launchpad.net/~anders-kaseorg/+archive/ppa )? It completely fixed it for me.

tags: added: regression-release
Martin Pool (mbp) on 2011-08-11
Changed in gnupg2 (Ubuntu):
assignee: nobody → Martin Pool (mbp)
Martin Pool (mbp) wrote :

I have a test build of that in http://pad.lv/ppa/mbp

Martin Pool (mbp) wrote :

I'm just going to try a duplicity run (which starts gpg many times) to see if it fixes the problem. It certainly looks like it will.

Martin Pool (mbp) on 2011-08-11
Changed in gnupg2 (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
Changed in gnupg2 (Debian):
status: Unknown → New
Martin Pool (mbp) wrote :

daviey spoke to me on irc about sponsoring an upload of this.

Changed in gnupg2 (Ubuntu):
assignee: Martin Pool (mbp) → Dave Walker (davewalker)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnupg2 - 2.0.17-2ubuntu2

---------------
gnupg2 (2.0.17-2ubuntu2) oneiric; urgency=low

  * debian/patches/gnupg2-fix-libgcrypt.diff: Fix assertion failure with
    libgcrypt 1.5.0. (LP: #815190)
 -- Anders Kaseorg <email address hidden> Sat, 23 Jul 2011 15:50:51 -0400

Changed in gnupg2 (Ubuntu):
status: In Progress → Fix Released
Changed in gnupg2 (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.