"an user" should be "a user"

Bug #135238 reported by Malcolm Parsons
8
Affects Status Importance Assigned to Milestone
GnuPG
Fix Released
Unknown
gnupg2 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnupg2

"Owner trust may not be set while using an user provided trust database\n"
should say
"Owner trust may not be set while using a user provided trust database\n"

Revision history for this message
Malcolm Parsons (malcolm-parsons) wrote :
Changed in gnupg2:
assignee: nobody → warp10
status: New → In Progress
Revision history for this message
Andrea Colangelo (warp10) wrote :

Debdiff based on Malcolm patch.
Builded, installed and tested.

Revision history for this message
Andrea Colangelo (warp10) wrote :

Debdiff based on Malcolm patch.
Builded, installed and tested.

Changed in gnupg2:
assignee: warp10 → nobody
status: In Progress → Confirmed
Revision history for this message
Reinhard Tartler (siretart) wrote :

this change will break all translations of that file. Do you know about the upstream inclusion status of this change?

Changed in gnupg2:
status: Confirmed → Incomplete
Revision history for this message
Malcolm Parsons (malcolm-parsons) wrote :

Reverting pointless status change.

Feel free to report upstream.

Changed in gnupg2:
status: Incomplete → Confirmed
Changed in gnupg2:
importance: Undecided → Low
Revision history for this message
Reinhard Tartler (siretart) wrote : Re: [Bug 135238] Re: "an user" should be "a user"

Sorry, I'm rejecting this bug because it would break all 29 translations
included in the source package. I'm CC'ing upstream with this email so
that they know about this trivial patch.

Dear gnupg developers, we received a trivial patch for a typo in a
(translated) message. You can read at http://launchpad.net/bugs/135238
the full context. Please consider it for inclusion.

  status wontfix

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Changed in gnupg2:
status: Confirmed → Won't Fix
Revision history for this message
Malcolm Parsons (malcolm-parsons) wrote :

That is not how upstream bug reporting works.

Changed in gnupg2:
status: Won't Fix → Confirmed
Revision history for this message
Reinhard Tartler (siretart) wrote :

Malcolm Parsons <email address hidden> writes:

> That is not how upstream bug reporting works.

Please do so yourself then.

In the meantime, I've unsubscribed myself and ubuntu-main-sponsors,
since I don't see anything to do here.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Revision history for this message
Werner Koch (wk) wrote :

On Fri, 16 Nov 2007 21:05, <email address hidden> said:
> Sorry, I'm rejecting this bug because it would break all 29 translations
> included in the source package. I'm CC'ing upstream with this email so

Well there are far less than 29 complete translations, so I see no
reason not to fix it. A new version of gnupg2 will be released this
month.

Salam-Shalom,

   Werner

--
Die Gedanken sind frei. Auschnahme regelt ein Bundeschgesetz.

Revision history for this message
Reinhard Tartler (siretart) wrote :

Werner Koch <email address hidden> writes:

> On Fri, 16 Nov 2007 21:05, <email address hidden> said:
>> Sorry, I'm rejecting this bug because it would break all 29 translations
>> included in the source package. I'm CC'ing upstream with this email so
>
> Well there are far less than 29 complete translations, so I see no
> reason not to fix it. A new version of gnupg2 will be released this
> month.

Thank you very much!

I've counted 29 files in po/*.po in the package, but I have to admit
that I haven't worked on the package yet, so I don't know about the
status of these translations.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Changed in gnupg:
status: Unknown → New
Revision history for this message
Malcolm Parsons (malcolm-parsons) wrote :

Translations can be trivially fixed at the same time as changing the incorrect string.

Even if that wasn't the case, this is the best time in a release cycle to make string changes, so that the translation teams can fix them before release.

Changed in gnupg:
status: New → Fix Released
Changed in gnupg2:
status: Confirmed → Triaged
Revision history for this message
Daniel Holbach (dholbach) wrote :

Kees: can you take a look at it?

Kees Cook (kees)
Changed in gnupg2:
assignee: nobody → keescook
milestone: none → later
Revision history for this message
Kees Cook (kees) wrote :

This has been fixed upstream.

Changed in gnupg2:
assignee: kees → nobody
status: Triaged → Fix Committed
Artur Rona (ari-tczew)
Changed in gnupg2 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.