Doesn't create settings correctly on first start

Bug #76983 reported by Sebastian Breier on 2006-12-23
12
Affects Status Importance Assigned to Milestone
gnupg (Ubuntu)
Medium
Scott Kitterman

Bug Description

Binary package hint: gnupg

-----
tomcat@merau:~$ gpg
gpg: directory `/home/tomcat/.gnupg' created
gpg: can't open `/gnupg/options.skel': No such file or directory
gpg: keyring `/home/tomcat/.gnupg/secring.gpg' created
gpg: keyring `/home/tomcat/.gnupg/pubring.gpg' created
gpg: Go ahead and type your message ...

gpg: Interrupt caught ... exiting
-----

Seems like the default option files are not set correctly.

Happens on feisty.

Related branches

description: updated
Revision history for this message
Michael Bienia (geser) wrote :

Thanks for your bug report.

This was already reported to the gnupg developers: http://lists.gnupg.org/pipermail/gnupg-devel/2006-December/023461.html

The relevant svn commit should be
http://marc.theaimsgroup.com/?l=gnupg-commit-watchers&m=116549111216855&w=2

Changed in gnupg:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Revision history for this message
Luis F. Lopez (luis.lopez) wrote :

A work-around for this issue is to copy the options file from /usr/share/gnupg:

~$ cp /usr/share/gnupg/options.skel ~/.gnugpg/gpg.conf

Revision history for this message
Fabien Tassin (fta) wrote :

Still not integrated into Gutsy. The patch has been created more than 6 months ago and is quite simple.
Please consider it at least for 1.4.6-2ubuntu3.

Changed in gnupg:
assignee: nobody → kitterman
importance: Low → Medium
status: Confirmed → In Progress
Revision history for this message
Scott Kitterman (kitterman) wrote :

I've attached a debdiff for where I've gotten on the gnupg bugs that I think should be addressed in this upload. I've built and installed the resulting package on Feisty (I'm waiting for libcurl to get straight before I start running Gutsy). I've verified that the 61 patch to modify the default skeleton file for Bug #15485 works and the file is correctly modified and installed in /usr/share/gnupg. What still isn't happening even after the changes linked to above from upsteam (currently codified in the 60 patch) is the copying to the user's gpg.conf.

So, please have a look.

Revision history for this message
Scott Kitterman (kitterman) wrote :

There is one error in the debdiff....

The 60 patch is commented out in 00list. That's not the cause of my problem.

Revision history for this message
Michael Bienia (geser) wrote :

Here is an updated debdiff. Changes compared to the previous debdiff:

* Enable the 60 patch in 00list
* Update the 60 patch to also apply the changes to configure and g10/Makefile.in

* Add libcurl4-gnutls-dev to build-depends. This fixes bug #62864 for me.

Revision history for this message
Kees Cook (kees) wrote :

This looks good; one question: why does patch 60 have log_error switched to log_info?

Revision history for this message
Scott Kitterman (kitterman) wrote :

It was in the same svn commit as the fix for installing the conf file and seemed to make sense.

I don't think its critical if you don't want to make the change, but haven't tested without it.

Revision history for this message
Kees Cook (kees) wrote :

I think it is cleaner to separate logical changes, so I have dropped the logging portion of the patch. Everything else looks (and works) great. Thanks, I've uploaded it! :)

Revision history for this message
Michael Bienia (geser) wrote :

gnupg (1.4.6-2ubuntu3) gutsy; urgency=low

  [ Scott Kitterman ]
  * Add 'debian/patches/60_install_options_skel.dpatch': Patch to
    install options file from upstream (LP: #76983)
  * Add 'debian/patches/61_use_agent_default.dpatch': Patch to set gpg
    (or gpg2) and gpgsm to use a passphrase agent by default (LP: #15485)
  * Add 'debian/patches/70_trust_error.dpatch': Patch to disallow illegal
    zero response for trust level changes (LP: #39459)

  [ Michael Bienia ]
  * Add libcurl4-gnutls-dev to Build-Depends to fix gpg running into a timeout
    updating the keyring (LP: #62864)

 -- Michael Bienia <email address hidden> Fri, 06 Jul 2007 20:56:05 +0200

Changed in gnupg:
status: In Progress → Fix Released
Revision history for this message
Sebastian Breier (tomcat42) wrote :

Big THANK YOU for fixing this. This bug really shouldn't have been in a release, but at least it's fixed now. :-)

Revision history for this message
Scott Kitterman (kitterman) wrote :

Just a note for anyone finding this bug later:

~/.gnupg/gpg.conf only gets installed if there is not ~/.gnupg dir for the user (e.g. on first run of gpg), so existing users that installed when this bug existed will have to:

$ cp /usr/share/gnupg/options.skel ~/.gnugpg/gpg.conf

to correct this problem. We discussed options to automate this on IRC and concluded that the automatic options were all too risky.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers