[Merge] gnupg 1.4.11-3 from debian (unstable)

Bug #720905 reported by Rico Tzschichholz on 2011-02-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnupg (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnupg

I have merged the current debian unstable version 1.4.11-3.
The debdiff is attached and the package is located here http://people.ubuntu.com/~ricotz/gnupg/

gnupg (1.4.11-3ubuntu1) natty; urgency=low

  * Resynchronise with Debian (LP: #720905). Remaining changes:
    - Disable mlock() test since it fails with ulimit 0 (on buildds).
    - Set gpg (or gpg2) and gpgsm to use a passphrase agent by default.
    - Fix udeb build failure on powerpc, building with -O2 instead of -Os.
    - Only suggest gnupg-curl and libldap; recommendations are pulled into
      minimal, and we don't need the keyserver utilities in a minimal Ubuntu
      system.
  * debian/{control,rules}: Remove the Win32 build (and mingw32
    build-dependency), since mingw32 is in universe, and will remain so for
    the forseeable future.

 -- Rico Tzschichholz <email address hidden> Tue, 22 Feb 2011 10:54:10 +0100

Related branches

summary: - [Merge] gnupg 1.4.11-3 from debian (experimental)
+ [Merge] gnupg 1.4.11-3 from debian (unstable)
description: updated
Benjamin Drung (bdrung) on 2011-02-21
tags: added: merge
Benjamin Drung (bdrung) wrote :

You forgot to close this bug with the merge. Why do you install gpgv.exe in /usr/bin?

Rico Tzschichholz (ricotz) wrote :

You are right, i have follow debian to close here. Shipping the win32 executeable won't work on ubuntu with the mingw32 compiler in universe. I am going to drop this gpgv-win32 package.

description: updated
Benjamin Drung (bdrung) wrote :

There speaks nothing against keeping the gpgv-win32 package even if the mingw32 compiler is in universe. The question was why you changed the install location for gpgv.exe.

Rico Tzschichholz (ricotz) wrote :

I didnt change the installation location. This is where the -3 debian package installs it, but they will change it to /usr/bin/win32 to follow the other *-win32 packages. Anyway dropping it seems to be the way since for gzip and cpio the *-win32 was dropped too.

Benjamin Drung (bdrung) wrote :

The Win32 build should be a separate point and not be under "Remaining changes", because this diff wasn't there by the last merge.

Rico Tzschichholz (ricotz) wrote :

I don't really understand what you mean. This change is also a difference to the Debian packagine and should be listed as one like the others.

Benjamin Drung (bdrung) wrote :

Here's an example for the changelog:

* Remaining change:
  - carried change 1
  - carried change 2
* New difference 1
* New difference 2

Rico Tzschichholz (ricotz) wrote :

It's fixed now

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnupg - 1.4.11-3ubuntu1

---------------
gnupg (1.4.11-3ubuntu1) natty; urgency=low

  * Resynchronise with Debian (LP: #720905). Remaining changes:
    - Disable mlock() test since it fails with ulimit 0 (on buildds).
    - Set gpg (or gpg2) and gpgsm to use a passphrase agent by default.
    - Fix udeb build failure on powerpc, building with -O2 instead of -Os.
    - Only suggest gnupg-curl and libldap; recommendations are pulled into
      minimal, and we don't need the keyserver utilities in a minimal Ubuntu
      system.
  * debian/{control,rules}: Remove the Win32 build (and mingw32
    build-dependency), since mingw32 is in universe, and will remain so for
    the forseeable future.

gnupg (1.4.11-3) unstable; urgency=low

  * Install gpg setuid root again on kFreeBSD. We dropped this
    bit earlier because it's not necessary anymore on Linux, but
    the kFreeBSD kernel still requires it for secure memory.
    Thanks Robert Millan for the patch. (Closes: 598471)
  * Add a gpgv-win32 package, to be used by win32-loader. Patch
    from Didier Raboud (Closes: #612462).

gnupg (1.4.11-2) experimental; urgency=low

  * Update standards-version to 3.9.1, no changes needed.
  * Apply patch based on Werner Koch's work that (again)
    resolves a build failure on mips(el); issue addressed
    in 1.4.10-4 was only partly solved upstream.
  * Add README.Debian with smart card reader info, thanks
    Jonathan Nieder (Closes: #575763).

gnupg (1.4.11-1) experimental; urgency=low

  * New upstream release (Closes: #600587).
    + Obsoletes all previously existing Debian patches:
      567580_menu_prompt_reflects_program.dpatch
      560692_fix_fatal_after_homedir_creation.dpatch
      489225_catch_expired_primary_key_with_valid_subkey.dpatch
      fix_infinite_loop_r5264.dpatch
      567593_improve_info_and_faq.dpatch
      551709_fix_info_link_entry.dpatch
      560995_fix_ftbfs_on_sparc64.dpatch
      mips_gcc4.4.dpatch
      553175_document_primary_uid_sign.dpatch
    + No longer ships outdated faq.html.

  * Update references to RFC 2440 into RFC 4880. Thanks
    Christoph Anton Mitterer (Closes: #592294).
 -- Rico Tzschichholz <email address hidden> Tue, 22 Feb 2011 11:00:25 +0100

Changed in gnupg (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers