Tries to create temp files under ~/.gnupg but doesn't create the dir

Bug #1541925 reported by Sebastien Bacher on 2016-02-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GnuPG
Fix Released
Unknown
gnupg (Ubuntu)
High
Unassigned

Bug Description

That's a regression since the 1.4.20 update which impacts the software-properties tests [1]

the error is
"test_add_gpg_key (tests.test_dbus.TestDBus) ... gpg: failed to create temporary file `/home/ubuntu/.gnupg/.#lk0x21044c0.adt.7314': No such file or directory"

the command called is
"/usr/bin/gpg --no-options --no-default-keyring --no-auto-check-trustdb --trust-model always --keyring /build/software-properties-0.96.17/tests/aptroot/etc/apt/trusted.gpg --secret-keyring /tmp/tmpohq9ksnp/secring.gpg --quiet --batch --import /build/software-properties-0.96.17/tests/data/testkey.gpg"

which fails if there is no .gnupg directory

[1] https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/s/software-properties/20160203_235320@/log.gz

Changed in gnupg (Ubuntu):
importance: Undecided → High
Marc Deslauriers (mdeslaur) wrote :

Caused by 6f992d94ea708535b2f3a3de22b429401d59fac9

Changed in gnupg:
status: Unknown → New
Martin Pitt (pitti) on 2016-02-09
Changed in gnupg (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnupg - 1.4.20-1ubuntu2

---------------
gnupg (1.4.20-1ubuntu2) xenial; urgency=medium

  * debian/patches/lp1541925.patch: Make sure directory exists before
    creating the lock. (LP: #1541925)

 -- Marc Deslauriers <email address hidden> Tue, 09 Feb 2016 14:39:34 -0500

Changed in gnupg (Ubuntu):
status: Triaged → Fix Released
Changed in gnupg:
status: New → In Progress
Changed in gnupg:
status: In Progress → Unknown
Changed in gnupg:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.