The gnumeric translation template seems to have been incorrectly imported

Bug #451138 reported by David Planella on 2009-10-14
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
gnumeric (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnumeric

Having a look at the gnumeric translation templates in Launchpad at:

  https://translations.launchpad.net/ubuntu/karmic/+source/gnumeric/+pots/gnumeric

there seems to be something wrong with it. I've noticed that:

* The upstream template at l10n.gnome.org has got 3323 strings, whereas the one in Launchpad has only got about half of them (1501)

* Almost all translations are empty, although upstream is translated in many languages

* The template looks suspiciously similar to the other one in the same package ('gnumeric-functions')

We should investigate that. It might be that the gnumeric-functions template has been imported to the wrong template.

Goyo (goyodiaz) wrote :

Gnumeric translation is definitely broken at least in Spanish. Function descriptions are translated but gnumeric interface is not.

Adi Roiban (adiroiban) on 2009-10-26
Changed in gnumeric (Ubuntu):
status: New → Confirmed
Changed in ubuntu-translations:
status: New → Confirmed
importance: Undecided → Medium
daniele80 (daniele80) wrote :

I confirm, Gnumeric translation is broken in Italian too. (karmic koala)

German translation is also missing in 9.10 Karmic Koala.

There are translations in the gnumeric source tarball, e.g. http://ftp.gnome.org/pub/GNOME/sources/gnumeric/1.9/gnumeric-1.9.9.tar.bz2

As a workaround, you could extract the translation from the “po” directory and move it to the right place. E.g., for the German translation:

sudo msgfmt -o /usr/share/locale-langpack/de/LC_MESSAGES/gnumeric.mo de.po

But of course these should be added to the appropriate Ubuntu packages and the Launchpad translation service.

David Planella (dpm) wrote :

After finding out what the problem is, we should manually regenerate and import the template to Launchpad, so that the next language pack updates fix this.

fcm95 (fcm95) wrote :

Hi
I confirm this bug.
Ubuntu Karmic 9.10 same problem !

Bye

Pierre Slamich (pierre-slamich) wrote :

Any update on this ? Are we allowed to import the translations from the Tarball into Launchpad ?
When is the next language pack update scheduled for ?

David Planella (dpm) wrote :

Pierre,

We still have to look into the cause of this.

The next language pack update will be some time next week, as discussed on the Ubuntu Translations Coordinators list [1], but they will still present this bug, as we've still not found the cause of the issue. In the meantime, I've manually uploaded correct templates and translations to see if they are imported and exported correctly.

[1] https://lists.launchpad.net/ubuntu-translations-coordinators/msg00339.html

Victor Vargas (kamus) wrote :

I have checked this issue under Ubuntu Lucid and is solved for gnumeric 1.10.1-1ubuntu1, I will mark this problem as Fix Released, then. Thanks!

Changed in gnumeric (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Released
Gabor Kelemen (kelemeng) on 2011-05-18
Changed in ubuntu-translations:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers