Ubuntu

cannot release a graph in gnumeric after click and drag

Reported by Lucio on 2009-01-12
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Gnumeric
Fix Released
Medium
gnumeric (Ubuntu)
Medium
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned
goffice (Ubuntu)
Medium
Unassigned
Intrepid
Medium
Unassigned
Jaunty
Medium
Unassigned

Bug Description

Binary package hint: gnumeric

TEST CASE:
1. Start gnumeric
2. create an empty graph
3. click and drag the graph

Result: When mouse button is released graph still follows mouse
Expected result: Graph should be released when mouse button is

Issue is seen on both intrepid and jaunty versions of gnumeric (1.8.3 and 1.8.4).

Since graphs are a vital part of gnumeric this makes the application highly crippled to all users running stock versions in intrepid and jaunty.

The bug exists in the goffice library gnumeric uses for plotting. An existing upstream patch (currently in Karmic's version) modifies foocanvas to work around a behaviour change in gtk 2.14 that caused the bug.

Changed in gnumeric:
status: Unknown → New
Hib Eris (hiberis) wrote :

I can reproduce this issue on both Intrepid and Jaunty.

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in gnumeric:
status: New → Confirmed
Martin Erik Werner (arand) wrote :

I was seeing this as well on jaunty, upgrading to 1.9.6 though debian sid repo mitigated:

gnumeric & gnumeric-common: 1.8.4-3ubuntu2 >> 1.9.6-1
libgoffice-0-6 >> libgoffice-0-8
libgoffice-common-0-6 >> libgoffice-common-0-8

Martin Erik Werner (arand) wrote :

This was apparently down to a gtk issue, it was fixed with changes in the 1.8.4 release though.

I would suggest that this should be backported to jaunty, since it is a _very_ obvious and annoying problem, that affects everyone using gnumeric in ubuntu

As 'arand' noted in comment #2, Jaunty has gnumeric 1.8.4 already. If this was fixed in a later release, it will need a SRU submitted. Procedures to submit the SRU are at https://wiki.ubuntu.com/StableReleaseUpdates#Procedure. Please do steps 1 and 2 of the SRU Procedure to bring the need to a developer's attention. Thanks for helping improve Ubuntu

John (john-m-lang) wrote :

According to comment #17 on the Gnome bug #566652, this has just been fixed in goffice: http://git.gnome.org/cgit/goffice/commit/?h=goffice-0-6&id=bfcd25ce71fce582af48f834c14a956249dc3ea6

I have not tested this to check if this actually fixes the bug.

The source package for gnumeric in Ubuntu is gnumeric (ubuntu). When the bug is fixed in gnumeric, it will be fixed in the gnumeric component of goffice. It is not necessary to open a separate task for goffice, since gnumeric is a component of goffice.

Changed in goffice (Ubuntu):
status: New → Invalid
Changed in gnumeric:
status: New → Fix Released
description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Karmic Koala.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in gnumeric (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Fix Released
Martin Erik Werner (arand) wrote :

I can confirm that the patch mentioned in comment #5 (http://git.gnome.org/cgit/goffice/commit/?h=goffice-0-6&id=bfcd25ce71fce582af48f834c14a956249dc3ea6), if applied to current libgoffice-0-6 in jaunty fixes this bug. Since the patch is seemingly minor I'd guess it'd be a good idea getting it into jaunty.

Martin Erik Werner (arand) wrote :

Okay, here's the debdiff for above mentioned patch.

Martin Erik Werner (arand) wrote :

Patched version is now also available for testing through my ppa: https://launchpad.net/~arand/+archive/ppa

John (john-m-lang) wrote :

The patched version in arand's PPA fixes this for me. I haven't experienced any regressions so far.

Thanks!

Changed in goffice (Ubuntu):
status: Invalid → Fix Released
LaserJock (laserjock) on 2009-07-31
Changed in gnumeric (Ubuntu):
status: Fix Released → Invalid
Changed in goffice (Ubuntu):
importance: Undecided → Medium
Changed in goffice (Ubuntu Intrepid):
importance: Undecided → Medium
Changed in goffice (Ubuntu Jaunty):
importance: Undecided → Medium
Changed in goffice (Ubuntu Intrepid):
status: New → Triaged
Changed in goffice (Ubuntu Jaunty):
status: New → Triaged
Changed in gnumeric (Ubuntu Intrepid):
status: New → Invalid
Changed in gnumeric (Ubuntu Jaunty):
status: New → Invalid
description: updated
LaserJock (laserjock) on 2009-07-31
description: updated
LaserJock (laserjock) wrote :

OK, I've uploaded arand's patch to intrepid-proposed and jaunty-proposed with minor changelog tweaks to conform to policy a bit better.

Changed in goffice (Ubuntu Intrepid):
status: Triaged → In Progress
Changed in goffice (Ubuntu Jaunty):
status: Triaged → In Progress
Steve Langasek (vorlon) wrote :

Accepted into intrepid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in goffice (Ubuntu Intrepid):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

Accepted into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in goffice (Ubuntu Jaunty):
status: In Progress → Fix Committed
John (john-m-lang) wrote :

Using the package in jaunty-proposed fixes this bug for me. I have not encountered any regressions yet. Thanks for pushing this through.

Martin Pitt (pitti) on 2009-08-26
tags: added: verification-done
removed: verification-needed
Martin Pitt (pitti) wrote :

Copied to -updates.

Changed in goffice (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Changed in goffice (Ubuntu Intrepid):
status: Fix Committed → Fix Released
Changed in gnumeric:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.