gnumeric crashes on print preview of certain spreadsheets (hardy regression)

Bug #207802 reported by James Troup
6
Affects Status Importance Assigned to Milestone
gnumeric (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnumeric

gnumeric crashes when I select print preview on certain spreadsheets. Unfortunately these spreadsheets contain confidential information, so I can't attach it. I did manage to get a backtrace with symbols though which is attached.

Revision history for this message
James Troup (elmo) wrote :
Revision history for this message
James Troup (elmo) wrote :

Actually through binary search, I managed to identify the item/cell that was causing the crash, so example spreadsheet which causes the crash is attached.

Revision history for this message
Jonathan Carter (jonathan) wrote : Re: [Bug 207802] Re: gnumeric crashes on print preview of certain spreadsheets (hardy regression)

I can confirm that this bug is present in Gnumeric 1.8.1-1ubuntu1.

For what it's worth, when I open it in a terminal, I get the message:

"** (gnumeric:29349): WARNING **: Unrecognized image file format
"

If I replace the EMF file with a PNG file, it seems to work fine.
Maybe the part that generates the PDF's for preview does not
understand the EMF format?

James Troup (elmo)
Changed in gnumeric:
status: New → Confirmed
Revision history for this message
arno_b (arno.b) wrote :

On intrepid, when a try to open the given speadsheet, gnumeric say 'bad format'.
Do you still experienced such a crash?

gnumeric:
  Installé : 1.8.3-3ubuntu2
  Candidat : 1.8.3-3ubuntu2
 Table de version :
 *** 1.8.3-3ubuntu2 0
        500 ftp://ftp.free.fr intrepid/main Packages
        100 /var/lib/dpkg/status

Changed in gnumeric:
importance: Undecided → Medium
Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Jaunty Jackalope. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in gnumeric:
status: Confirmed → Incomplete
Revision history for this message
Matthias Mailänder (mailaender) wrote :

Maybe this is a duplicate of #439480 "Printing crashes gnumeric with sigsegv".

Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in gnumeric (Ubuntu):
status: Incomplete → Invalid
status: Invalid → Incomplete
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers