gnumeric no longer offers to save as csv/tsv etc (text), despite listing such files when choosing "All files" as save type

Bug #1163533 reported by Christopher Barrington-Leigh on 2013-04-02
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gnumeric (Ubuntu)
Undecided
Alex

Bug Description

I launched gnumeric under 13.04 beta to load a .tsv (tab-delim text) file.
It loads fine, but does not allow me to save it as the same.
It should.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gnumeric 1.12.1-1ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-16.26-generic 3.8.5
Uname: Linux 3.8.0-16-generic x86_64
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
Date: Tue Apr 2 14:47:44 2013
InstallationDate: Installed on 2013-03-18 (14 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130318)
MarkForUpload: True
SourcePackage: gnumeric
UpgradeStatus: No upgrade log present (probably fresh install)

Andreas J Guelzow (aguelzow) wrote :

.tsv .csv etc files are not full spreadsheet formats, so you can not 'save as' such a file. This does not stop you from importing from or exporting to those kind of file types. Just use the data->importdata or data->exportdata menu items.

Note that you will need to use the configurable text exporter to write a .tsv file.

Thanks. I think these options simply moved (?).
I'm rejecting my bug...

Changed in gnumeric (Ubuntu):
status: New → Invalid

The documentation still says to do Save As and choose "Text (configurable)" as the format. It seems like Data : Export just opens the Save As dialog with this text format available.

Damian Yerrick (tepples) wrote :

I ran into this same issue. It's a bug in the feature's discoverability, and it could be solved by adding a notice below the "File type:" pop-up menu stating that other file formats are available in Data > Export.

Changed in gnumeric (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnumeric (Ubuntu):
status: New → Confirmed
David Oneill (david-m-oneill) wrote :

Is there any reason why the save as dialog doesn't support exporting as well?

To myself (and I would guess to many if not most other users), "Save-as" is the go to location for making a file. Splitting export vs save-as seems like forcing the user interface to conform to the internals of the program instead of having the user interface reflect how the program will be used.

Please consider changing the save-as dialog to allow exporting from there.

If not, at least include a note explaining how to export in the save-as dialog.

Bradford (caseybrad) wrote :

I note that in addition to the generally counterintuitive location of the export function (under data rather than file, where this option is almost universally found), if a user opens a tab delimited or comma separated file, and attempts to save it, it will default to saving in a spreadsheet format, but will retain the .txt extension, which clearly implies that the format remains unchanged.
Considering the large number of users working in these formats, it seems the obvious answer is to permit saving in multiple formats from the save-as dialog, as expected by the majority of users, but a notice indicating how this can be accomplished should absolutely be included.

Gerard Weatherby (gweatherby) wrote :

It would greatly improve usability to have the csv option visible from the File -> Save As menu.

Bryce Nesbitt (bryce2) wrote :

This is a discovery bug:
too hard to discover how to export TSV/CSV.

Alex (alexvaa) on 2016-12-07
Changed in gnumeric (Ubuntu):
assignee: nobody → Alex (alexvaa)
Bryce Nesbitt (bryce2) wrote :

File->Export is a more normal location.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers