gnumeric crashed with signal 5 in g_realloc()

Bug #1023254 reported by Mark Underwood on 2012-07-11
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnumeric (Ubuntu)
Low
Unassigned

Bug Description

1) lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

2) apt-cache policy gnumeric
gnumeric:
  Installed: 1.10.17-1ubuntu2
  Candidate: 1.10.17-1ubuntu2
  Version table:
 *** 1.10.17-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/universe i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in Gnumeric via the Terminal:
cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/gnumeric/+bug/1023254/+attachment/3228006/+files/blanked.ods && gnumeric --no-splash blanked.ods

is the file opens successfully.

4) What happens instead is it crashes consistently with error:
(gnumeric:2530): GLib-ERROR **: /build/buildd/glib2.0-2.32.3/./glib/gmem.c:230: failed to allocate 2147483648 bytes
Trace/breakpoint trap (core dumped)

WORKAROUND: Use LibreOffice Calc.

 apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.5.3-0ubuntu1
  Candidate: 1:3.5.3-0ubuntu1
  Version table:
 *** 1:3.5.3-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnumeric 1.10.17-1ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-25.40-generic 3.2.18
Uname: Linux 3.2.0-25-generic x86_64
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
Date: Tue Jul 10 23:05:27 2012
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnumeric
UpgradeStatus: Upgraded to precise on 2012-04-29 (72 days ago)

summary: - never opens and slowly consumes all memory
+ Gnumeric never opens, eats all memory and crashes.

I suspect that is the same as bug http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=642135 that was fixed in September 2011. It is included in all 1.11.x releases of Gnumeric.

mchngl84, thank you for reporting this and helping make Ubuntu better. Could you please attach the document that demonstrates this problem?

Changed in gnumeric (Ubuntu):
status: New → Incomplete
  • blanked.ods Edit (9.3 KiB, application/vnd.oasis.opendocument.spreadsheet)

I have attached the document. Thanks much.

mchngl84, I successfully generated a crash report that is being processed by the retracer https://bugs.launchpad.net/ubuntu/+source/gnumeric/+bug/1026536 . Once it is processed, I will mark it a duplicate of this one. However, the issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://bugzilla.gnome.org/ . If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about the status. Thanks in advance.

Changed in gnumeric (Ubuntu):
importance: Undecided → Low
status: Incomplete → Triaged
summary: - Gnumeric never opens, eats all memory and crashes.
+ gnumeric crashed with signal 5 in g_realloc()
description: updated
tags: added: i386
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1023254

tags: added: iso-testing
Andreas J Guelzow (aguelzow) wrote :

The file in question contains a named range/ named expression called CRSE_HIST$srt12$0 and many other s of the same form. ODF 1.2 part 2, section 5.11 states:

Expressions should limit the names of their identifiers to only ([UNICODE]) letters, underscores,
and digits, not including patterns that look like cell references or the words True or False.
Identifier ::= ( LetterXML
(LetterXML | DigitXML | '_' | CombiningCharXML)* )
- ( [A-Za-z]+[0-9]+ )
- ([Tt][Rr][Uu][Ee]) - ([Ff][Aa][Ll][Ss][Ee])

The above name does not satisfy the identifier requirement.

Note that this is not gnumeric bug http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=642135 but https://bugzilla.gnome.org/show_bug.cgi?id=690925. The latter will be fixed in 1.12.1 and later.

mchngl84, thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Trusty Tahr.

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please perform as much as possible of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

lsb_release -rd
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04

apt-cache policy gnumeric
gnumeric:
  Installed: 1.12.9-1
  Candidate: 1.12.9-1
  Version table:
 *** 1.12.9-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

no longer affects: gnumeric
Changed in gnumeric (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.