gnuift exits in error on start

Bug #31582 reported by David Cabecinhas on 2006-02-16
6
Affects Status Importance Assigned to Milestone
gnuift (Ubuntu)
Medium
Unassigned

Bug Description

gnuift exists in erro on program start with the current version on Ubuntu Dapper (0.1.14-6.1).
I have included a stack trace of what is going on when gnuift aborts.
If more info is needed I can provide it.

daca@ubuntu:~/gnuift-0.1.14$ gdb /usr/bin/gift
(...)
(gdb) r
Starting program: /usr/bin/gift
[Thread debugging using libthread_db enabled]
[New Thread 935647456 (LWP 19911)]
GIFT:Starting Server
Random number generator has been seeded with 19911
CAlgorithmCollection.cc:204:throwing AnVENotFound occured: /home/daca/gift-config.mrml

terminate called after throwing an instance of 'VENotFound'

Program received signal SIGABRT, Aborted.
[Switching to Thread 935647456 (LWP 19911)]
0xffffe410 in __kernel_vsyscall ()

(gdb) thread apply all bt

Thread 1 (Thread 935647456 (LWP 19911)):
#0 0xffffe410 in __kernel_vsyscall ()
#1 0x37c769a1 in raise () from /lib/tls/i686/cmov/libc.so.6
#2 0x37c782b9 in abort () from /lib/tls/i686/cmov/libc.so.6
#3 0x37e55c1e in __gnu_cxx::__verbose_terminate_handler ()
   from /usr/lib/libstdc++.so.6
#4 0x37e53915 in __gxx_personality_v0 () from /usr/lib/libstdc++.so.6
#5 0x37e5394a in std::terminate () from /usr/lib/libstdc++.so.6
#6 0x37e53a7e in __cxa_throw () from /usr/lib/libstdc++.so.6
#7 0x37f1e611 in CAlgorithmCollection (this=0x3fea3afc,
    inConfigFileName=@0x3fea381c) at CAlgorithmCollection.cc:204
#8 0x37f16456 in CSessionManager (this=0x3fea3afc,
    inSessionFileName=@0x3fea3c94, inConfigFileName=@0x3fea3c90,
    inI18nFileName=@0x3fea3c8c) at CSessionManager.cc:518
#9 0x0805191c in main (argc=1, argv=0x3fea3d74) at Server.cc:625

Gauvain Pocentek (gpocentek) wrote :

I reject this bug because it's not a bug.
After googling a little, I found that you need to run gift-add-collection.pl before using gift.

Changed in gnuift:
status: Unconfirmed → Rejected
David Cabecinhas (david-cab) wrote :

This is an abnormal behaviour of the program, therefore it's a bug.
Given the "gift-add-collection.pl" command has not been run the software should alert the user with a meaningfull error message and should exit cleanly.
Please consider correcting this or at least report it to upstream.

Changed in gnuift:
status: Rejected → Unconfirmed
Barry deFreese (bddebian) wrote :

Can gift-add-collection.pl be added to postinst or is there some rationale as to why it cannot? Thank you.

Changed in gnuift:
status: Unconfirmed → Needs Info
Paul Dufresne (paulduf) wrote :

Seems to still exist on Gutsy:
Random number generator has been seeded with 9622
CAlgorithmCollection.cc:204:throwing AnVENotFound occured: /home/paul/gift-config.mrml

terminate called after throwing an instance of 'VENotFound'

Program received signal SIGABRT, Aborted.
[Switching to Thread -1212257584 (LWP 9622)]

Paul Dufresne (paulduf) wrote :

Making state go from Incomplete to Confirmed, as the question seems adressed to package Maintainer rather than the initial reporter.

Changed in gnuift:
status: Incomplete → Confirmed
Barry deFreese (bddebian) wrote :

Does it run correctly after running the gift-add-collection.pl? Thanks.

Changed in gnuift:
status: Confirmed → Incomplete
huiii (a00ps) wrote :

i can confirm abnormal termination

jo@mercur:~$ gift
GIFT:Starting Server
Random number generator has been seeded with 14954
CAlgorithmCollection.cc:204:throwing AnVENotFound occured: /home/jo/gift-config.mrml

terminate called after throwing an instance of 'VENotFound'
Aborted (core dumped)

running ubuntu feisty.

huiii (a00ps) wrote :

yes, minutes later i found the solution as unfortunately it occurs cause of wrong initialisation by the user. this is due to lack of an how to get started thing. i found one and it helped to get started. since than i have no abnormal termination!
check this hier:
http://osdir.com/ml/gnu.gift.general/2006-05/msg00024.html

success

Nick Ellery (nick.ellery) wrote :

Looks like this issue has been resolved. Closing the bug.

Changed in gnuift:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers