Gnucash can't read (or write ?) its own files

Bug #68339 reported by Raph-old on 2006-10-26
2
Affects Status Importance Assigned to Milestone
gnucash (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnucash

Hello,

After upgrading from Dapper to Edgy, I happily noticed that Gnucash 2 was available. Once started, it tries to open my pre-2.0 Gnucash book, and then launches the XML import druid. So far so good, I choose the right strings, apply, etc etc. The file opens successfully, everything is fine, all my old stuff is here, and I can add transactions.

Unfortunately, once the file is saved, it can't be accessed any more. I suspect Gnucash not to save the file correctly, since the file size is ridiculously small after saving it. The backup file is correctly saved though, and if I try to open that one, I have the import druid again, which shows that the file is backed up and let unchanged.

When launched in an xterm, I have this (trying to open a file which have been previously saved)

*****
gnucash: [M] "Found Finance::Quote version ""1.11"
/home/raph/.gnucash/books/Clean_Account.xac:2: parser error : Start tag expected, '<' not found
[Top]
^
*****

...with the parser error repeated three times.

The import druid doesn't seem to be faulty since I tried to create brand new files with Gnucash 2 and the result is still the same. Export feature produces weird files too (they seem incomplete, only the accounts are listed, no transactions).

After some web crawling I found a help request about the same problem on Gnucash's mailing list, but no one answered it. I couldn't find anything else.

The installed version of Gnucash is 2.0.1-3ubuntu3, and I have an up-to-date Edgy system (upgraded from a Dapper a couple of days ago, some problems occured since this wasn't the final release but I'm a long-time Debian user and I managed to get it updated just fine playing with dpkg and apt-get ; nothing should be missing since ubuntu-desktop and its dependencies are installed).

I wish I could do some more testing and report more but now I'm stuck somehow, I don't know what to check next.

Best regards,

--
Raph

After some more testing I understood what was happening. In fact Gnucash writes in ~/.gnucash/books some data about the book itself, unfortunately under the same filename, overwriting it. Previous versions (1.x) didn't do this, and it was OK to store one's books in ~/.gnucash/books, but now it doesn't work anymore.

The right way to make it work is to store one's books anywhere... but in ~/.gnucash/books.

andi5 (andi5) wrote :

From my point of view, all directories ~/.${app}, like ~/.gnucash, belong to the application. Yes, they are owned by the user in the unix sense, but you are not supposed to work there unless somebody tells you to do that. So I think this is notabug (rejected).

andi5 (andi5) wrote :

See my comment above

Changed in gnucash:
status: Unconfirmed → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers