Change libgoffice dependency from 0.4 to 0.6

Bug #270200 reported by Saivann Carignan on 2008-09-14
10
Affects Status Importance Assigned to Milestone
gnucash (Debian)
Fix Released
Unknown
gnucash (Ubuntu)
Low
Michael Casadevall

Bug Description

Binary package hint: gnucash

Current gnucash package builds on deprecated libgoffice 0.4 library while it can now build on current 0.6 .

libgoffice 0.4 is deprecated and soon not used by any application. libgoffice 0.6 fixes some issues (bug 269698) and remove landscape functionnality which was completely broken in current gnucash. Therefore, gnucash should now build on 0.6 instead of 0.4 .

Testing has been done to see if everything works correctly with libgoffice 0.6 and the only regression is bug 269687, which appears on all applications that uses gtkprint (most of all GNOME applications) and that needs to be fixed in gtk.

Related branches

Here's the debdiff. Since this is a change in dependency, subscribed motu-release to get an ack to make sure this is Ok.

Changed in gnucash:
assignee: nobody → sonicmctails
importance: Undecided → Low
milestone: none → intrepid-alpha-6
status: New → In Progress
Changed in gnucash:
status: Unknown → New
Luke Yelavich (themuso) wrote :

ACK from me.
Please get it uploaded.

 affects ubuntu/gnucash
 status confirmed

Changed in gnucash:
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnucash - 2.2.6-2ubuntu1

---------------
gnucash (2.2.6-2ubuntu1) intrepid; urgency=low

  * Switched libgoffice-0 to libgoffice-0-6 dependency (LP: #270200)

 -- Michael Casadevall <email address hidden> Sun, 14 Sep 2008 13:57:06 -0400

Changed in gnucash:
status: Confirmed → Fix Released
Saivann Carignan (oxmosys) wrote :

Michael Casadevall : Many thanks for your work.

Changed in gnucash:
importance: Unknown → Undecided
importance: Undecided → Unknown
status: New → Unknown
Changed in gnucash:
status: Unknown → New
Changed in gnucash (Debian):
status: New → Fix Committed
Changed in gnucash (Debian):
status: Fix Committed → New
Changed in gnucash (Debian):
status: New → Confirmed
Changed in gnucash (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.