some keys stopped working: left & right arrows, backspace

Bug #1306500 reported by toccata on 2014-04-11
166
This bug affects 38 people
Affects Status Importance Assigned to Milestone
gnucash (Ubuntu)
High
Unassigned

Bug Description

Following the bug comments below, it seems that problem is specific to systems that have the package "ibus", but not the package "ibus-gtk", installed. Kubuntu installations seem to be typically affected.

Workaround:
sudo apt-get install ibus-gtk

Original Description:
Following the last update, gnucash has become extremely painfull to use: it's not possible aymore to edit the cell contents in an easy way: direction keys, backspace, suppression keys are not working.
The application cannot be used with this bug.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: gnucash 1:2.6.1-2
Uname: Linux 3.14.0-031400-generic x86_64
ApportVersion: 2.14.1-0ubuntu2
Architecture: amd64
CurrentDesktop: KDE
Date: Fri Apr 11 11:37:59 2014
SourcePackage: gnucash
UpgradeStatus: No upgrade log present (probably fresh install)

toccata (jdruel) wrote :
toccata (jdruel) wrote :

Further investigation consisted in reinstalling gnucash version 2.4 from 13.10. Same behaviour, so the bug could be related to a gtk grid bug:
https://bugs.launchpad.net/ubuntu/+source/gnucash/+bug/1247702

If I press on the arrow keys inside a cell, I have to switch to another application then back again to see the refresh.
Not sure where I have to declare this bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnucash (Ubuntu):
status: New → Confirmed
Scott Wood (scott-buserror) wrote :

FWIW, I'm seeing the same thing with XFCE as the desktop.

There's an upstream bug that may or may not be relevant:
https://bugzilla.gnome.org/show_bug.cgi?id=661915

That bug relates to X Input Method (I didn't enable that, but I don't know if the latest Ubuntu update did, and I don't know how to check). Even if X Input Method isn't involved, the symptoms are similar enough that maybe there's some common cause.

toccata (jdruel) wrote :

Great info Scott. I performed the following steps (not sure they are all relevant).
I installed scim packages and im-switch. Then I launched im-switch from the command line and choose
"use setting by the sysadmin". Relaunch X-session, launch gnucash: arrow keys are now working.
I'll see if there are unwanted side effects to this.

Scott Wood (scott-buserror) wrote :

I encountered similar (but not identical) misbehavior in chromium:
https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1307648

A suggested workaround for the chromium bug is "ibus exit" -- when I tried it, both the chromium and gnucash issues went away.

ronny (ronny-standtke) wrote :

Same issue here. I can confirm that after executing "ibus exit" in a terminal, gnucash is again usable. Unfortunately, I had to do this after every login. I fixed the issue permanently by removing the ibus package.

Installing the package "ibus-gtk" and restarting the ibus daemon fixed the problem for me.

Rohit V. Bhute (rvbhute) wrote :

I am using Xubuntu 14.04. Using ibus input method. Running "ibus exit" solves the issue.

Rohit V. Bhute (rvbhute) wrote :

One more issue I noticed - with ibus on, the file saving in GnuCash is noticeably slower than when ibus if off (through "ibus exit").

Heather Kordinak (hmkordinak) wrote :

I had this same issue with certain keys not working in Gnucash and saving taking a long time. The ibus daemon was also the problem for me in Lubuntu 14.04.

Tim Taylor (drtimt) wrote :

I am also suffering from this issue (both the inability to use the delete key, and occasional very slow save times). The "ibus exit" trick works for me, but I also just found another workaround which you can do without exiting ibus:

After pressing the delete key (once or multiple times) in Gnucash, press control-Space (this is the default keyboard shortcut in the ibus preferences to select the next input method). Unless you have set up multiple input methods in ibus, it won't actually switch anything, but it does seem to have the effect of flushing the buffer, so the delete action then gets executed.

Colin Law (colin-law) wrote :

Still present on Ubuntu 14.10. Fixed by
sudo apt-get install ibus-gtk
and logging out and in.

If ubuntu is going to install ibus by default then perhaps the fix is to include ibus-gtk as a dependency in the gnucash package.

Changed in gnucash (Ubuntu):
importance: Undecided → High
starox (starox) wrote :

This bugs affects me on ubuntu 15.04
installing ibus-gtk solves the problem

Jim Snyder-Grant (jimsg) wrote :

This bug affects me on ubuntu 15.10, and installing ibus-gtk solves the problem.
Hmm: my GnuCash version is still 2.6.3 (rev 4e4a032+ from 2014-05-30).

The command "ibus exit" works like a charme!

description: updated
description: updated
James Hagborg (blucoat) wrote :

This bug seems to affect any application using wxWidgets (KiCad and pgAdmin, in addition to a test wxWidgets app with just a text box). Installing both the "ibus-gtk" and "ibus-gtk3" packages fixed it for me.

ullix (ullix) wrote :

I have a fresh install of Ubuntu-Mate 16.04, and copied the home directory from a previous 14.04 installation.

I had the problem of Gnucash with left & right arrows, backspace and also delete not working.

Installation (and logout/in) of ibus-gtk alone did NOT help. I also had to deinstall ibus! After logout/in it is working now.

Mike Kobler (mkobler) wrote :

A recent 'apt upgrade' caused me to hit this bug on my Ubuntu-Mate 16.04 installation. Looking over my apt history, I see that the ibus package was installed about the time the problem started to show up.

Installing ibus-gtk and ibus-gtk3 did not resolve the issue, though stopping the ibus daemon does appear to work.

Confirmed on Mint 17.1 and ibus 1.5.5 using GNUCash 2.6.1 rev 76cba80+. Right and left arrow keys, delete, backspace do not work. Numbers and letters work but with delays or loss of keystrokes. Stopping the ibus daemon resolves the issue. Installing ibus-gtk did not resolve the issue.

I had two machines running nearly identical Linux Mint 18.3 Sylvia. I saw the problem on one only, and it was associated with very high cpu use (almost 100% on one execution unit/core) by gnucash 2.6.19.

Both had ibus installed and the one without a problem had ibus-gtk while neither had ibus-gtk3.
On the one with the problem, ibus did not appear to be running at all.

After various combinations of installing ibus-gtk, rebooting & so on I found that ibus was now running, and I still had the problem. Then 'ibus exit' in a terminal made the problem and the cpu usage go away instantly, without even restarting gnucash.

Is there a reason to not simply 'apt remove ibus', given I use English on a US keyboard layout?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.