GNUBG (backgammon) - Desktop stops responding to mouse clicks

Bug #932455 reported by Michael Petch on 2012-02-15
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gnubg (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu 11.10
Release: 11.10

  Installed: 0.90+20091206-4.1
  Candidate: 0.90+20091206-4.1
  Version table:
 *** 0.90+20091206-4.1 0
        500 http://ca.archive.ubuntu.com/ubuntu/ oneiric/universe i386 Packages
        100 /var/lib/dpkg/status

This problem also exists on 64bit Ubuntu. This problem doesn't exist on Ubuntu 11.04. If you build from the latest GNUBG source (CVS) the bug still exists. This bug is not found in the product when built/installed on Debian Wheezy or current Sid environments.

The bug doesn't seem to be related to the X-Server. If I run GNUBG remotely from Ubuntu onto another Xwindow system via SSH, I get similar behavior. In this case only GNUBG stops responding to the mouse clicks.

The bug is high priority since it renders the product and your desktop unusable until the program is killed. To produce the problem start a new match against the computer via File menu/New.../Click GNU Backgammon vs Human/Click OK. Make a few moves against the computer. On the right hand side in the move list under the "gnubg" column click one of the moves the computer made. At this point the analysis pane will appear below the move list and the mouse fails to respond to mouse clicks on the desktop rendering Ubuntu useless. Killing the application manually does work.

Although the mouse doesn't work as expected the keyboard still functions, both on the desktop and in GNUBG.

This bug has been reported by a number of users and more info can be found here:

http://savannah.gnu.org/bugs/?34864
http://lists.gnu.org/archive/html/bug-gnubg/2012-02/msg00006.html

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: software-center 5.0.3.1
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
Uname: Linux 3.0.0-14-generic i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Wed Jan 4 18:19:59 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Michael Petch (mpetch) wrote :
Michael Petch (mpetch) on 2012-02-15
description: updated
Michael Petch (mpetch) wrote :

After spending an evening in the debugger I accidentally stumbled upon a temporary solution to get GNUBG functional under Ubuntu 11.10 .

The issue involves a feature of Ubuntu's desktop that I despise - those overlay scrollbars (scrollbars that popout past the edge of a window to save real estate inside a widget). For some reason the overlay scrollbars under Ubuntu 11.10 do not work with GNUBG for some *yet* unknown reason.

If you want to turn overlay scrollbars off for just GNUBG so that launching from the menu works then do this from a command terminal:

sudo nano /usr/share/applications/gnubg.desktop

Modify the line that starts with Exec= and replace it with this new one:

Exec=env LIBOVERLAY_SCROLLBAR=0 gnubg -w

This should allow GNUBG tro run properly, and you will notice it will use standard scrollbars

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnubg (Ubuntu):
status: New → Confirmed

My AC100 (ARM-Netbook) froze a few days at times while playing gnubg on an AC100 (ARM-Netbook) running the fully updated beta1 of 12.04. However, gnubg no longer froze for the last two days. Plus, I cannot reproduce this bug according to the above description (fully updated again many times, that is).

Happy to do more testing, if advised what to do.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnubg - 0.90+20120127-3

---------------
gnubg (0.90+20120127-3) unstable; urgency=low

  * Depend on libpng-dev instead of libpng12-dev. (Closes: #662355)

 -- Russ Allbery <email address hidden> Sun, 04 Mar 2012 20:11:41 -0800

Changed in gnubg (Ubuntu):
status: Confirmed → Fix Released
V F (trivia21) wrote :

This bug still exists for me on Ubuntu 12.04 LTS. Whenever I click on any previous move (possibly after analysis), the system stops responding to mouse clicks. I usually need to press Ctrl+Q to exit gnubg. This way I lose the game record with no chance to look at the analysis. 100% reproducible for me.

I installed gnubg from ubuntu software center, then compiled it from the latest source code (gnubg-source-SNAPSHOT-20120630.tar.gz on 30-Jun-2012 04:50), and the bug still exists.

I couldn't find the package gnubg - 0.90+20120127-3.

There is no /usr/share/applications/gnubg.desktop on my system, and creating it doesn't help as well.

Michael Petch (mpetch) wrote :

Hi VF,

The reason building from source doesn't fix this issue (at present) is because the issue is in Debian Ubuntu systems only, and the workaround is a Debian Ubuntu specific fix. First of all, I'm going to recommend downloading an installing the version you couldn't find (0.90+20120127-3). Installing these packages should create the necessary gnubg.desktop file so that when launched from a gnome3/unity menu it should work properly. You must download gnubg and gnubg-data from these locations:

http://launchpadlibrarian.net/103709007/gnubg_0.90%2B20120127-3_amd64.deb
http://launchpadlibrarian.net/103697408/gnubg-data_0.90%2B20120127-3_all.deb

After downloading you can install them from the command line using:

sudo dpkg -i gnubg-data_0.90+20120127-3_all.deb gnubg_0.90+20120127-3_amd64.deb

Once these are installed you should be able to launch GNUBG through the GUI using the menus/icons, and there should now be a /usr/share/applications/gnubg.desktop that contains Exec=env LIBOVERLAY_SCROLLBAR=0 gnubg -w .

If you are rolling your own build from source you must alter how you launch GNUBG. For example if you rolled your own build from source, you could launch from the source directory using:

LIBOVERLAY_SCROLLBAR=0 ./gnubg

or if you installed GNUBG from source (and did a 'make install' to the default /usr/local) directory you can launch GNUBG like this:

LIBOVERLAY_SCROLLBAR=0 /usr/local/bin/gnubg

Let me know how you make out.

Michael Petch (mpetch) wrote :

If you are using a 32bit system then you'll want to install:

http://launchpadlibrarian.net/103697407/gnubg_0.90%2B20120127-3_i386.deb

instead of the amd64 version I posted before. The gnubg-data files are the same for both 32/64bit.

Michael Petch (mpetch) wrote :

I have committed a change to the latest GNUBG source code. The change will appear in future source code snapshots after July 1st, 2012 . It is available as of this message in CVS. For those building GNUBG from source, and wish to have GNUBG run properly on Ubuntu you must do the following:

Normally you run ./autogen.sh, followed by ./configure, followed by "make", and possibly "sudo make install " .

For those familiar with this process, you must alter your configure command slightly to include code to work around this bug and force overlay scrollbars off. the configure process should be amended to be something like:

./configure CFLAGS="-DNO_OVERLAYSCROLLBARS"

With this change, you should be able to run GNUBG without setting any environment variables ahead of time. The downside is that GNUBG will always run with standard scrollbars (not overlayed ones). This fix is temporary until a proper solution can be put in place (And there is a solution).

V F (trivia21) wrote :

Hey,

Thanks for your answer. All the above mentioned solutions work. Personally I didn't like overlay scrollbars anyway.

Have a nice day!

Ad van de Pol (yogiman) wrote :

Hi, Michael
I do my best, but like to report two things:
- libreadline5-dev is not available, but two other packages can replace this. i assume this happened.
- autogen.sh doesn't exist

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers