Ubuntu

Support Application Indicators

Reported by Asif Youssuff on 2010-03-14
154
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Gnote
New
Wishlist
gnote (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: gnote

This application should be investigated to be ported to use Application
Indicators for Lucid - https://edge.launchpad.net/indicator-application

Kai Mast (kai-mast) wrote :

Doesn't support AppIndicators in Maverick either.

Robert Roth (evfool) on 2011-04-21
Changed in gnote (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
anilg (anil-verve) wrote :

oh.. please fix this! You can't let tomboy get away with their fancy indicator menu integration :)

Sebastien Bacher (seb128) wrote :

GNOME recommends dropping the status icon in this case, see https://bugzilla.gnome.org/show_bug.cgi?id=632000

Changed in gnote:
importance: Unknown → Medium
status: Unknown → New
Changed in gnote:
status: New → Fix Released
anilg (anil-verve) wrote :

I installed the latest version of gnote from the stable ppa, and it's still using non-indicator menus. Do I need to do something else to get this working?

Robie Basak (racb) wrote :

The upstream commit for this appears to be http://git.gnome.org/browse/gnote/commit/?id=d5f2c8b1cd8159a2898bce1cefa2c1e1bc03d2d8. The upstream bug is "drop status icon use", not "use application indicators instead of status icon". So upstream seems to consider it fixed; yet this bug is not. If we want indicator support then I suppose we need to open a new upstream bug.

TomasHnyk (sup) wrote :

Yes, that would be nice. Also, it would be nice to remove this bug, I think it is possible now: http://blog.launchpad.net/bug-tracking/removing-a-project-from-a-shared-bug-report

Vibhav Pant (vibhavp) on 2012-04-26
Changed in gnote (Ubuntu):
status: Confirmed → Fix Released
Robie Basak (racb) wrote :

Vibhav,

I don't understand. Does the current version actually support application indicators, and if so in which release did this happen?

As far as I understand, this bug is "Support Application Indicators". gnote in Ubuntu currently does not support application indicators. Thus this bug is not fixed.

The upstream bug is "drop status icon". This bug is "support application indicators". Clearly the two are not the same, and this upstream bug should not really be on the bug watch.

Changed in gnote (Ubuntu):
status: Fix Released → Confirmed
TomasHnyk (sup) wrote :

This is the proper upstream report. The developers are not much interested in this, so I guess it will not happen until someone steps up.

Changed in gnote:
importance: Medium → Unknown
status: Fix Released → Unknown
Changed in gnote:
importance: Unknown → Wishlist
status: Unknown → New
Jake Li (gnozil) wrote :

Please fix it!!!!
After upgrading to 13.04, the situation became worse. I can still use the whitelist feature in 12.10, but it is dropped since 13.04.
I need it!!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.