Ubuntu

flegita doesn't show device-choice-dialog and backfires

Reported by kubuntux on 2008-04-15
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnomescan (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: flegita

I have a Dell-Laptop that has an integrated webcam. When I start felgita (0.4.1-0ubuntu4) on Hardy it tries to access /dev/video0 (webcam) and aborts with the error-message "Invalid Argument". xsane does the same as long as you're not member of the scanner group, which is unfortunately default!! (I would say this is also a kind of bug ;-) ) After adding the user to the scanner group xsane shows a dialog that lets you choose between the scan devices whereas flegita goes on withe the error-message.

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 or 9.04?

Changed in gnomescan:
status: New → Incomplete
Tero Keinänen (kenkku) wrote :

This happens for me in Intrepid. (with integrated webcam, /dev/video0 and a HP Photosmart)

Tero Keinänen (kenkku) on 2008-12-22
Changed in gnomescan:
status: Incomplete → Confirmed
Étienne BERSAC (bersace) wrote :

Hi,

Yes, webcam cause issue in 0.4. 0.6 ignore them. 0.8 should support them properly. Please update to 0.8.

Regards,
Étienne.

Étienne BERSAC (bersace) wrote :

Hi,

Yes, webcam cause issue in 0.4. 0.6 ignore them. 0.8 should support them properly. Please update to 0.6.1.

Regards,
Étienne.

Tero Keinänen (kenkku) wrote :

Thanks, Étienne! I upgraded to 0.6.1 from your PPA (https://launchpad.net/~bersace/+archive) and the message is gone. I hope the new version will make it to the main repositories soon.

mavosaure (mavosaure) wrote :

Hi!

Using Intrepid, I've got exactly the same problem with a multifunction printer & scan HP C5280.
Notice that I'm using a laptop (Dell studio 17) with an integrated webcam.
XSane works without anuy problem.

gnomescan: 0.4.1-0ubuntu4

:~$ scanimage -L
device `v4l:/dev/video0' is a Noname Laptop_Integrated_Webcam_2M virtual device
device `hpaio:/usb/Photosmart_C5200_series?serial=MY88SG215C0559' is a Hewlett-Packard Photosmart_C5200_series all-in-one

:~$ scanimage
scanimage: open of device v4l:/dev/video0 failed: Invalid argument.

Note although that the bug #312097 seems to be a duplicate from this one.
https://bugs.launchpad.net/ubuntu/+bug/312097

I'll try the PPA and I'll give feedback.

mavosaure (mavosaure) wrote :

@ Étienne BERSAC :
Using your PPA, I've got a warning message about partial update :
"Certaines mises à jour ne peuvent pas être installées"

I suppose that it's due to the fact of a difference in the name of the packages :
~$ apt-cache policy gnomescan
gnomescan:
  Installé : 0.4.1-0ubuntu4
  Candidat : 0.4.1-0ubuntu4
 Table de version :
 *** 0.4.1-0ubuntu4 0
        500 http://fr.archive.ubuntu.com intrepid/universe Packages
        100 /var/lib/dpkg/status

~$ apt-cache policy gnome-scan
gnome-scan:
  Installé : (aucun)
  Candidat : 0.6.2-0ubuntu1~ppa1
 Table de version :
     0.6.2-0ubuntu1~ppa1 0
        500 http://ppa.launchpad.net intrepid/main Packages

So I'll try to remove gnomescan and add your gnome-scan.

mavosaure (mavosaure) wrote :

Yeaaaaaaaaah!

It works perfectly for me.
Thanks for this update!
I think the status could be changed to "fix commited" or "fix released"... but don't want to do any mistake.

I know that's Jaunty's release is not so far, but it could be a good idea to backport this package?

@ Étienne BERSAC :
note also this awfull bug in your PPA's package : URL project is wrong in the about dialog! ;-)

Merci pour cette appli.... beaucoup plus agréable visuellement que XSane! :-D

Changed in gnomescan (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers