Ubuntu

Set Name to Gnomeradio in desktop file

Reported by Triniton Adam on 2012-11-23
54
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gnomeradio (Debian)
New
Unknown
gnomeradio (Ubuntu)
Low
POJAR GEO

Bug Description

Actually the name of application is displayed as "FM-Radio Tuner" :)
See screenshot

As discussed in various places we shouldn't use the generic name in the name
field in the desktop files:
https://mail.gnome.org/archives/desktop-devel-list/2009-August/msg00117.html

We should also have consistency between the Name field, the name used in the
titlebar, the name used in the application menu (gnome-shell), the
about box, and the documentation.

GNOME Goal: Correct Desktop Files https://live.gnome.org/GnomeGoals/CorrectDesktopFiles

Can we change the name in the desktop file to reflect this?

current gnomeradio desktop file:

-----------------------------------------

[Desktop Entry]
Name=FM-Radio Tuner
Comment=Listen to FM-radio
Exec=gnomeradio
Icon=gnomeradio
Categories=AudioVideo;Audio;Tuner
StartupNotify=true
Terminal=false
Type=Application
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=gnomeradio
X-GNOME-Bugzilla-Component=general
X-GNOME-DocPath=gnomeradio/gnomeradio.xml
X-Ubuntu-Gettext-Domain=gnomeradio

------------------------------------------

Any suggestion to change this would be welcome

Thanks

Triniton Adam (trinitonadam) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnomeradio (Ubuntu):
status: New → Confirmed
Buda Servantes (budaservantes) wrote :

My proposal:

[Desktop Entry]
_Name=Gnomeradio
_GenericName=FM Radio Tuner
_Comment=Listen to FM radio
Exec=gnomeradio
Icon=gnomeradio
Categories=GNOME;GTK;AudioVideo;Audio;Tuner;
StartupNotify=true
Terminal=false
Type=Application
X-GNOME-FullName=Gnomeradio FM Radio Tuner
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=gnomeradio
X-GNOME-Bugzilla-Component=general
X-GNOME-DocPath=gnomeradio/gnomeradio.xml

description: updated
Robert Roth (evfool) on 2012-11-25
Changed in gnomeradio (Ubuntu):
importance: Undecided → Low
POJAR GEO (geoubuntu) on 2013-04-08
description: updated
description: updated
POJAR GEO (geoubuntu) on 2013-04-09
summary: - Use Gnomeradio as desktop file Name
+ Set Name to Gnomeradio in desktop file
Changed in gnomeradio (Debian):
status: Unknown → New
Iain Lane (laney) wrote :

Hi,

Thanks, but it seems that the substitution isn't working correctly; see:

laney@raring> dpkg --fsys-tarfile gnomeradio_1.8-2ubuntu10_amd64.deb | tar x -O --wildcards \*gnomeradio.desktop
[Desktop Entry]
[…]
X-GNOME-Bugzilla-Version=@VERSION@

Setting to Incomplete - please reset once this is fixed.

Changed in gnomeradio (Ubuntu):
status: Confirmed → Incomplete
POJAR GEO (geoubuntu) wrote :

OK, thanks
I maded changes for saucy

Changed in gnomeradio (Ubuntu):
status: Incomplete → Confirmed
POJAR GEO (geoubuntu) on 2013-04-30
Changed in gnomeradio (Ubuntu):
assignee: nobody → POJAR GEO (geoubuntu)
POJAR GEO (geoubuntu) wrote :

Now substitution working correctly; see:

geoubuntu@raring:~$ dpkg --fsys-tarfile gnomeradio_1.8-2ubuntu10_i386.deb | tar x -O --wildcards \*gnomeradio.desktop
[Desktop Entry]
Name=Gnomeradio
GenericName=FM Radio Tuner
X-GNOME-FullName=Gnomeradio FM Radio Tuner
Comment=Listen to FM radio
Exec=gnomeradio
Terminal=false
Type=Application
Icon=gnomeradio
X-GNOME-DocPath=gnomeradio/gnomeradio.xml
Categories=GNOME;GTK;AudioVideo;Audio;Tuner;
StartupNotify=true
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=gnomeradio
X-GNOME-Bugzilla-Component=general
X-Ubuntu-Gettext-Domain=gnomeradio

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnomeradio - 1.8-2ubuntu10

---------------
gnomeradio (1.8-2ubuntu10) saucy; urgency=low

  * Updated debian/patches/gnomeradio.desktop.patch: Set Name to Gnomeradio in
    desktop file. (LP: #1082423)
 -- POJAR GEORGE <email address hidden> Thu, 11 Apr 2013 20:20:02 +0000

Changed in gnomeradio (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.