Ubuntu

[SRU] Gnomeradio: Unable to Record Audio

Reported by Zicu Radu on 2012-05-25
100
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Gnomeradio
Won't Fix
High
gnomeradio (Debian)
New
Unknown
gnomeradio (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

I can't record in gnomeradio either, just an empty sound-file is what I get.

SRU Request for precise

#### SRU Justification ###

[Impact]
The recording audio with gnomeradio isn't possible currently in precise.

[Test Case]
1) Install gnomeradio
2) Load module snd_mixer_oss:
 sudo modprobe snd_mixer_oss
3) Run gnomeradio in a terminal
4) Start recording audio by press recording (red) button

With the version in precise, it will error out with:

(gnomeradio:2084): gnomeradio-WARNING **: GStreamer runtime error: Could not open audio device for recording.

You can't record in gnomeradio either, just an empty sound-file (0 byte) is what you get.

With the version in precise-proposed, sound recording is possible and generate an normal sound-file (see screenshoot 2).

[Development fix]
This issue is fix in quantal gnomeradio-1.8-2ubuntu2

[Regression Potential]
The potential for regression is extremely low as the recording isn't currently possible.

Zicu Radu (zradu1100) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnomeradio (Ubuntu):
status: New → Confirmed
POJAR GEO (geoubuntu) wrote :
summary: - I can't record in gnomeradio
+ [SRU] Can't record in gnomeradio
description: updated
POJAR GEO (geoubuntu) wrote :
POJAR GEO (geoubuntu) on 2012-05-26
description: updated
description: updated
description: updated
POJAR GEO (geoubuntu) on 2012-05-26
description: updated
POJAR GEO (geoubuntu) on 2012-05-26
description: updated
POJAR GEO (geoubuntu) on 2012-05-26
description: updated
POJAR GEO (geoubuntu) on 2012-05-26
summary: - [SRU] Can't record in gnomeradio
+ [SRU] Gnomeradio: Unable to Record Audio
Triniton Adam (trinitonadam) wrote :

I confirm this bug in precise and quantal

description: updated
POJAR GEO (geoubuntu) wrote :

SRU for precise: gnomeradio_1.8-2ubuntu1.1

1) Use autoaudiosrc plugin which can decide for us what audio src use, whether it is a linux/unix solution (PA, OSS, Alsa) or other.

2) In addition, changed from a GtkButton to a GtkFileChooserButton, instead of fidling around with the dialog in recording file selection.

description: updated
description: updated
description: updated
POJAR GEO (geoubuntu) wrote :

SRU Request for precise

#### SRU Justification ###

[Impact]
The recording audio with gnomeradio isn't possible currently in precise.

[Test Case]
1) Install gnomeradio
2) Load module snd_mixer_oss: sudo modprobe snd_mixer_oss
3) Run gnomeradio in a terminal
4) Start recording audio by press recording (red) button

With the version in precise, it will error out with:

(gnomeradio:2084): gnomeradio-WARNING **: GStreamer runtime error: Could not open audio device for recording.

You can't record in gnomeradio either, just an empty sound-file (0 byte) is what you get. (see screenshoot 1)

With the version in precise-proposed, sound recording is possible and generate an normal sound-file (see screenshoot 2).

[Regression Potential]
The potential for regression is extremely low as the recording isn't currently possible.

#######

gnomeradio 1.8 running on Ubuntu 12.04 LTS.

Zicu Radu (zradu1100) on 2012-05-28
description: updated
description: updated
POJAR GEO (geoubuntu) wrote :
POJAR GEO (geoubuntu) wrote :
Triniton Adam (trinitonadam) wrote :

Please nominate this bug for precise and quantal.
I think this bug affects all users of precise and quantal distribution.
Thanks.

Don't think it needs to be nominated, per se, for Quantal since it's a
development release ("work in progress"), but yes, it need to be nominated
for Precise.

Sincerely,
kroq-gar78

On Sun, May 27, 2012 at 8:26 PM, Triniton Adam <email address hidden>wrote:

> Please nominate this bug for precise and quantal.
> I think this bug affects all users of precise and quantal distribution.
> Thanks.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1004761
>
> Title:
> [SRU] Gnomeradio: Unable to Record Audio
>
> Status in “gnomeradio” package in Ubuntu:
> Confirmed
>
> Bug description:
> I can't record in gnomeradio either, just an empty sound-file is what I
> get.
> (see screenshot)
>
> When start gnomeradio from terminal and try to record this error show
> up:
>
> (gnomeradio:2084): gnomeradio-WARNING **: GStreamer runtime error:
> Could not open audio device for recording.
>
> Also, I think it is better to change GtkButton to a
> GtkFileChooserButton, instead of fidling around with the dialog to
> choose a destination folder for recording file location.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnomeradio/+bug/1004761/+subscriptions
>

Mario Compaq (mariocompaq) wrote :

Since the description of application is:

"Gnomeradio is a FM-radio tuner for the GNOME desktop. It should work with every FM tuner card that is supported by video4linux. Remote controls are supported via (optional) LIRC-support. Gnomeradio can also record radio using GStreamer.",

and one of application function (record radio), doesn't work in ubuntu 12.04 LTS and affects all users, the "Importance" of this bug should be changed from "Undecided" to "High".

Thanks.

tags: added: patch
Zicu Radu (zradu1100) wrote :

Recording the audio in Gnomeradio (Ubuntu 12.04 LTS) is far too complicated task.

TEST CASE:

1. Try to record audio with gnomeradio function:

OUTPUT THIS ERROR:

(gnomeradio:22694): gnomeradio-WARNING **: GStreamer runtime error: Could not open audio device for recording.

2. Try to record audio with gnomeradio started and gstreamer command line:

$ gst-launch-0.10 osssrc ! audioconvert ! wavenc ! filesink location=record.wav

OUTPUT THIS ERROR:

Setting pipeline to PAUSED ...
ERROR: Pipeline doesn't want to pause.
ERROR: from element /GstPipeline:pipeline0/GstOssSrc:osssrc0: Could not open audio device for recording.
Additional debug info:
gstosssrc.c(380): gst_oss_src_open (): /GstPipeline:pipeline0/GstOssSrc:osssrc0:
Unable to open device /dev/dsp for recording: No such file or directory
Setting pipeline to NULL ...
Freeing pipeline ...

$ gst-launch-0.10 autoaudiosrc ! audioconvert ! wavenc ! filesink location=record.wav

OUTPUT THIS SUCCES:

Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstAudioSrcClock

I build gnomeradio from http://bazaar.launchpad.net/~geoubuntu/ubuntu/precise/gnomeradio/1004761/revision/8 and I tested gnomeradio record function and it's WORK!
Thanks.

The proposed solution in this geoubuntu revision:

The code in "rec_tech.c" should use either "autoaudiosrc" element insted of "osssrc" for the audio source recording.

Changed in gnomeradio:
importance: Unknown → High
status: Unknown → New
Zicu Radu (zradu1100) on 2012-05-30
tags: added: record
removed: patch
tags: added: precise
removed: record
POJAR GEO (geoubuntu) on 2012-05-31
tags: added: sru
Changed in gnomeradio (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnomeradio - 1.8-2ubuntu2

---------------
gnomeradio (1.8-2ubuntu2) quantal; urgency=low

  * debian/patches/gnomeradio-ngettext.patch: Adds ngettext support for messages
    strings. (LP: #980633)
  * debian/patches/gnomeradio-help.patch: Fixed frecquency value step in manual
    chapter "Usage/Frequency". (LP: #980652)
  * debian/patches/gnomeradio-prefs.patch: Switched from a GtkButton to a
    GtkFileChooserButton, instead of fidling around with the dialog.
  * debian/patches/gnomeradio-function.patch: Added a new function, so that
    lirc.c doesn't touch the internals of gui.c anymore.
  * debian/patches/gnomeradio-license.patch: Added license dialog and website
    label to "About Gnomeradio" dialog. (LP: #997473)
  * debian/patches/gnomeradio-record.patch: Changed audio source from osssrc to
    autoaudiosrc that automatically detects an appropriate audio source to use.
    (LP: #1004761)
  * Updated debian/patches/gnomeradio-v4l2.patch to fix the tooltip typo, use
    "dev/radio0" (the official name of the radio device). (LP: #1005127)
  * debian/gnomeradio.sgml: Fixed ending tag mismatch.
  * Switch to debhelper compat level v8.
 -- POJAR GEORGE <email address hidden> Tue, 12 Jun 2012 11:44:06 -0400

Changed in gnomeradio (Ubuntu):
status: Confirmed → Fix Released
Zicu Radu (zradu1100) wrote :

Thanks for this fix.
I tested this in quantal and record function work nice now.
I expect this bug to be released for precise soon.
Thanks again.

Buda Servantes (budaservantes) wrote :

I want to thank you for fixing the problem.

POJAR GEO (geoubuntu) on 2012-06-13
Changed in gnomeradio (Ubuntu):
assignee: nobody → POJAR GEORGE (geoubuntu)
assignee: POJAR GEORGE (geoubuntu) → nobody
POJAR GEO (geoubuntu) wrote :

The SRU request for precise is now on the sponsoring queue

James Page (james-page) on 2012-06-15
Changed in gnomeradio (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
James Page (james-page) wrote :

Hi Pojar

The package for precise-proposed has now been uploaded and is waiting approval from the SRU team.

You need to document the SRU in this bug report following https://wiki.ubuntu.com/StableReleaseUpdates and then subscribe ubuntu-sru - at which point it will be reviewed.

Thanks for your work on this bug.

POJAR GEO (geoubuntu) on 2012-06-15
description: updated
description: updated
description: updated
Zicu Radu (zradu1100) wrote :

The SRU request for precise is now on the sponsoring queue

Changed in gnomeradio (Ubuntu Precise):
status: New → Confirmed
Zicu Radu (zradu1100) wrote :

Oliver Grawert (ogra) wrote 21 hours ago:

since the patch seems to work according to the bug comments in bug 1004761, i uploaded to precise-proposed now, please notify the SRU team (https://wiki.ubuntu.com/StableReleaseUpdates) in the bug to take care of further processing.

Changed in gnomeradio (Ubuntu Precise):
status: Confirmed → Fix Committed
description: updated

Hello Zicu, or anyone else affected,

Accepted gnomeradio into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnomeradio/1.8-2ubuntu1.1 in a few hours and then in the -proposed repository. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.
If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Zicu Radu (zradu1100) wrote :

All is fine now, thanks.

tags: added: verification-done
removed: verification-needed
Mario Compaq (mariocompaq) wrote :

Thanks for fix this bug.
Now, with package from proposed, recording audio is work with gnomeradio.
I post screenshot to ilustrate this

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnomeradio - 1.8-2ubuntu1.1

---------------
gnomeradio (1.8-2ubuntu1.1) precise-proposed; urgency=low

  * debian/patches/gnomeradio-record.patch: Changed audio source from osssrc to
    autoaudiosrc that automatically detects an appropriate audio source to use.
    (LP: #1004761)
  * debian/patches/gnomeradio-prefs.patch: Switched from a GtkButton to a
    GtkFileChooserButton, instead of fidling around with the dialog.
 -- POJAR GEORGE <email address hidden> Sat, 26 May 2012 09:54:22 +0000

Changed in gnomeradio (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in gnomeradio:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.