Programs using libglade have problem with their UI

Bug #76218 reported by Emilio Pozuelo Monfort
16
Affects Status Importance Assigned to Milestone
GnomeBaker
Unknown
Unknown
gnomebaker (Ubuntu)
Medium
Emilio Pozuelo Monfort

Bug Description

I have Feisty up-to-date, and with the latest update of Gnomebaker (0.6.0-6ubuntu1), I can open Gnomebaker, but once opened, I can't create a new project (dvd data, cd data and cd audio).

Looking at the logs, and the terminals, I can say that the problem seems to belong to libglade2-0, in which depends Gnomebaker.

Regards
Pochu

Revision history for this message
Niall Creech (sevenmachines-deactivatedaccount) wrote :
Download full text (3.9 KiB)

the top menu bar entries and the top new,open and save icons at below the top menu also dont work, terminal output below.

~$ gnomebaker

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_show_file_browser'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_open_project'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_close_project'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_show_hidden_files'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_burn_iso'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_up'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_show_human_readable_file_sizes'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_notebook_switch_page'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_down'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_new_data_cd_project'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_copy_cd'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_remove'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_new_audio_project'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_import'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_about'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_copy_dvd'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_export_playlist'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_quit'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_clear'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_preferences'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_new_project'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_save_project'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_new_data_dvd_project'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_save_project_as'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_burn_dvd_iso'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_refresh'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_blank_cdrw'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_open_recent_project'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_format_dvdrw'.

(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_delete'.

(gnomebaker:6657): libglade-WARNING **: co...

Read more...

Revision history for this message
C.Kontros (coryisatm) wrote :

I have this exact issue also. I think its effecting multiple burning apps also. ie: I cant burn a .iso in any app. I think has to so with:

"(gnomebaker:6657): libglade-WARNING **: could not find signal handler 'gnomebaker_on_format_dvdrw'."

Changed in gnomebaker:
status: Unconfirmed → Confirmed
Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

The bug is in glade library, and not in gnomebaker.

description: updated
Revision history for this message
Sebastien Bacher (seb128) wrote :

the glade file is shipped by the application, reassigning

Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

>the glade file is shipped by the application, reassigning

Are you sure on that?

Revision history for this message
didier (did447-deactivatedaccount) wrote :

>the glade file is shipped by the application, reassigning
> Are you sure on that?
Yes it's a gnomebaker linking issue. I don't know if it's a change in its package or a compiler change since edgy but -rdynamic (or -export-dynamic) is missing and handler functions aren't exported.

Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :
Changed in gnomebaker:
assignee: nobody → tsmithe
status: Confirmed → In Progress
Revision history for this message
didier (did447-deactivatedaccount) wrote :

A different one. Do the same without adding a false direct dep on libgmodule

With Makefile.in because automake produce a big an messy patch.

Revision history for this message
Toby Smithe (tsmithe) wrote :

I'm deassigning myself as I'm not sure why I was assigned in the first place.

Changed in gnomebaker:
assignee: tsmithe → nobody
Changed in gnomebaker:
assignee: nobody → pochu
Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :
Revision history for this message
Daniel T Chen (crimsun) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 23 Jan 2007 19:54:57 -0500
Source: gnomebaker
Binary: gnomebaker
Architecture: source
Version: 0.6.0-6ubuntu2
Distribution: feisty
Urgency: low
Maintainer: Goedson Teixeira Paixao <email address hidden>
Changed-By: Daniel T Chen <email address hidden>
Description:
 gnomebaker - application for CD/DVD creation in the GNOME desktop
Changes:
 gnomebaker (0.6.0-6ubuntu2) feisty; urgency=low
 .
   [Emilio Pozuelo]
   * debian/patches/19_-export-dynamic_for_glade.dpatch: Add, based on
     guidance from <did447 at gmail dot com>, fixing libglade problem
     (Closes Ubuntu: #76218).
Files:
 4dfb18c71a40cf32fa3846b8fe5dfb8f 762 gnome optional gnomebaker_0.6.0-6ubuntu2.dsc
 fc5e7c5088034a9b1c1bc440502f61a8 24469 gnome optional gnomebaker_0.6.0-6ubuntu2.diff.gz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFFtq8te9GwFciKvaMRAtU/AJ4sG9xbE0rsBpp6LBT1tDabdFD1IQCcCAF/
c/FSfut+9I5j+jjd6cRVKDA=
=yL4P
-----END PGP SIGNATURE-----

Changed in gnomebaker:
assignee: pochu → crimsun
importance: Undecided → Medium
status: In Progress → Fix Committed
Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

Upload committed. Thanks to didier for the patch, Áron Sisak and Michael Bienia for their help on patching the source tree, and Daniel T Chen for uploading the package!

Changed in gnomebaker:
assignee: crimsun → pochu
Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

My first fix! ^_^

Changed in gnomebaker:
assignee: pochu → nobody
status: Fix Committed → Fix Released
Changed in gnomebaker:
assignee: nobody → pochu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.