Gnome Sound Preferences help refers to a system bell, but it's called system beep.

Bug #161787 reported by crf on 2007-11-10
10
Affects Status Importance Assigned to Milestone
gnome2-user-docs (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

The help for the gnome sound preferences refers to a System Bell, but it's called a System Beep in the sound preferences themselves. See section 8.4.5.3. of the gnome preferences help.

The help file should be updated.

ProblemType: Bug
Architecture: i386
Date: Fri Nov 9 17:54:09 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/yelp
NonfreeKernelModules: ltmodem
Package: yelp 2.20.0-0ubuntu3
PackageArchitecture: i386
ProcCmdline: gnome-help ghelp:///usr/share/gnome/help/user-guide/C/user-guide.xml?goscustmulti-2
ProcCwd: /home/chris
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp
Uname: Linux paqsaq 2.6.22-14-386 #1 Sun Oct 14 22:36:54 GMT 2007 i686 GNU/Linux

crf (chrisfahlman) wrote :
Murat Gunes (mgunes) wrote :

Thanks for your bug report; confirming.

Dean Sas (dsas) wrote :

Gnome Sound Preferences help is contained in the gnome-user-guide rather than ubuntu-docs

Dean Sas (dsas) wrote :

According to the upstream bug this applet has been redesigned and the documentation not updated, the linked upstream bug contains a list of all of the differences.

Changed in gnome2-user-docs:
importance: Undecided → Low
status: Confirmed → Triaged
Changed in gnome2-user-docs:
status: Unknown → New
ptoye (i-launchpad-ptoye-com) wrote :

Err... as a newbie to Ubuntu who wants to use the sound card, the lack of accurate documentation is a real turn-off.

As well as the change from "bell" to "beep" (which is pretty trivial), there's also the issue of the completely new user interface on the "general" tab. A lot of the fields are not exactly self-explanatory (at least to a newbie).

To be honest, assigning a low priority to documentation is self-defeating. Linux will never take off until this casual attitude is changed. Yes, I know that MS documentation & help files are equally badly maintained, but there's so much larger a user base that bulletin boards & help sites quickly fill up with fixes. And then there are books like "Windows xxx Annoyances" which help (albeit a year too late given the publication cycle). Linux appears to have none of this, only a "community" which, as soon as a difficult question is asked, goes rapidly silent.

Changed in gnome2-user-docs:
assignee: nobody → desktop-bugs

I would like the developers to elevate the importance of this bug.

This issue is present in jaunty, in the beta, with all the packages up to date.

I have found it impossible to disable the system beep in any way. None of the configuration options noted above work for me. I also cannot simply blacklist the pcspkr or snd-sprk module, because my laptop has the speaker built into the sound card - which means the only way to disable it, is to blacklist the module for the entire sound card - which means no sound of any kind whatsoever.

And the beep is really bloody annoying. I know ubuntu developers put it there willingly several versions back, so it's not like you have to search around trying to find it - how hard can it be to put an option on it, whether to enable it or not at shutdown?

Thanks.

Also, the pcspkr creates static for me on reboot, which is an extra annoyance.

Changed in gnome2-user-docs:
status: New → Fix Released
Changed in gnome2-user-docs:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.