gnome-web-photo --help shows wrong binary name

Bug #669620 reported by Serrano Pereira on 2010-11-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-web-photo (Ubuntu)
Low
Unassigned

Bug Description

REGRESSION NOTE: This was cause with the update in Bug #625801

I don't understand why "gnome-web-photo --help" prints:

Usage:
  gnome-web-photo.real [OPTION...]

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-web-photo 0.8-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.35-23.36-generic-pae 2.6.35.7
Uname: Linux 2.6.35-23-generic-pae i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Mon Nov 1 20:45:47 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-web-photo

Micah Gersten (micahg) wrote :

Thank you for reporting this to Ubuntu. How are you launching gnome-web-photo?

Changed in gnome-web-photo (Ubuntu):
status: New → Incomplete

I first noticed the problem when I wanted to use Shutter to create a website screenshot. Shutter returns the error:
JPEG parameter struct mismatch: library thinks size is 372, caller expects 356.

I then later found out that it was using gnome-web-photo to create the screenshot, to which I tried the following command in gnome-terminal:
serrano@saibot:~$ gnome-web-photo.real http://www.google.com/
gnome-web-photo.real: error while loading shared libraries: libxul.so: cannot open shared object file: No such file or directory

That's the problem, you should be using gnome-web-photo, not
gnome-web-photo.real

On 11/01/2010 04:56 PM, Serrano Pereira wrote:
> I first noticed the problem when I wanted to use Shutter to create a website screenshot. Shutter returns the error:
> JPEG parameter struct mismatch: library thinks size is 372, caller expects 356.
>
> I then later found out that it was using gnome-web-photo to create the screenshot, to which I tried the following command in gnome-terminal:
> serrano@saibot:~$ gnome-web-photo.real http://www.google.com/
> gnome-web-photo.real: error while loading shared libraries: libxul.so: cannot open shared object file: No such file or directory
>

You are right. It works just fine without the .real suffix. Then I don't understand why "gnome-web-photo --help" prints:

Usage:
  gnome-web-photo.real [OPTION...]

Guess I should file a bug for Shutter, since this isn't a gnome-web-photo bug.

Micah Gersten (micahg) wrote :

I've changed this bug into a bug for the help issue showing the wrong binary. I'll get this fixed in Natty and then SRUd. Thanks for catching thing. As for the shutter issue, can you please file another bug with reproduce steps and subscribe me (micahg) to the bug?

summary: - gnome-web-photo missing required libxul.so
+ gnome-web-photo --help shows wrong binary name
description: updated
Changed in gnome-web-photo (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → Low
status: Incomplete → Triaged
Micah Gersten (micahg) on 2010-11-02
description: updated
tags: added: lucid regression-update
Micah Gersten (micahg) on 2010-11-02
Changed in gnome-web-photo (Ubuntu Lucid):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → Low
status: New → Triaged
Changed in gnome-web-photo (Ubuntu Maverick):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → Low
status: New → Triaged

Thanks in advance for fixing this bug. I'll soon file that Shutter bug.

Micah Gersten (micahg) wrote :

Development task is invalid now since this has been ported to webkit and only has one binary.

Changed in gnome-web-photo (Ubuntu):
assignee: Micah Gersten (micahg) → nobody
status: Triaged → Invalid
Adolfo Jayme (fitojb) on 2013-05-17
no longer affects: gnome-web-photo (Ubuntu Lucid)
no longer affects: gnome-web-photo (Ubuntu Maverick)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers