gnome-web-photo missing required libxul.so

Bug #625801 reported by Oded Arbel on 2010-08-28
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Shutter
Undecided
Unassigned
gnome-web-photo (Ubuntu)
Medium
Micah Gersten
Lucid
Medium
Unassigned

Bug Description

Reason for SRU:
App might not start if multiple xulrunner-1.9.2 directories are on the system

Test Case:
1. /usr/bin/gnome-web-photo -f --timeout=30 --mode=photo 'http://google.com' test.png
2. Notice that it can't load because of libxul.so
(/usr/bin/gnome-web-photo.real: error while loading shared libraries: libxul.so: cannot open shared object file: No such file or directory)
3. Install -proposed version
4. /usr/bin/gnome-web-photo -f --timeout=30 --mode=photo 'http://google.com' test.png
(should finish this time)

------------------------------------------------------

Binary package hint: gnome-web-photo

When trying to use gnome-web-photo to take a screenshot of a webpage, gnome-web-photo always fails with the error message:

Load timed out; consider increasing the timeout (use 0 for no timeout)

The gnome-web-photo help screen mentioned the name as gnome-web-photo.real. Trying to run that shows an error message about missing libxul.so:

---8<---
$ /usr/bin/gnome-web-photo -f --timeout=30 --mode=photo 'http://www.geek.co.il' test.png
Load timed out; consider increasing the timeout (use 0 for no timeout)
oded.a@sepiroth:~$ /usr/bin/gnome-web-photo.real -f --timeout=30 --mode=photo 'http://www.geek.co.il' test.png
/usr/bin/gnome-web-photo.real: error while loading shared libraries: libxul.so: cannot open shared object file: No such file or directory
---8<---

Running it as
---8<---
LD_LIBRARY_PATH=/usr/lib/xulrunner-1.9.2.10pre /usr/bin/gnome-web-photo.real -f --timeout=30 --mode=photo 'http://www.geek.co.il' test.png
---8<---
works fine

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-web-photo 0.8-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-19.26-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
Architecture: amd64
Date: Sat Aug 28 15:37:53 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100701)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-web-photo

Oded Arbel (oded-geek) wrote :
Oded Arbel (oded-geek) wrote :

This also affects shutter as it uses gnome-web-photo for the "website screenshot" feature, and it always reports the incorrect error message generated by gnome-web-photo, even when using it to screenshot very simple websites with long timeouts.

Changed in shutter:
status: New → Invalid
Oded Arbel (oded-geek) wrote :

Mario - are you trying to say that this bug does not affect Shutter? Because I'm pretty sure it does.

Well, Shutter only uses gnome-web-photo. Therefore it is not a bug in Shutter's code. If the bug gets fixed in gnome-web-photo or not - nothing has to be changed for Shutter.

Maybe the meaning of "Affects" is not clear enough here.

Oded Arbel (oded-geek) wrote :

As far as I understand, "Affect" means - this bug exhibits itself as broken behavior in the following projects..

As in - when this specific bug is in effect, using "take a screenshot of a website" in Shutter always returns a "timeout" even for simple web sites and regardless of what the timeout is.

For example - under Maverick choose "take a screenshot of a website", type "http://www.google.com/" and hit ENTER. Expected result: A screenshot of Google should appear. Actual result: a dialog with the error message described above appears.

That being said, currently I can't reproduce the problem in neither shutter nor gnome-web-photo. Apparently something was fixed.

Micah Gersten (micahg) wrote :

Thank you for reporting this to Ubuntu. I have confirmed this and I will work on a fix for Maverick. Please report any other issues you may find.

Changed in gnome-web-photo (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → Medium
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-web-photo - 0.8-0ubuntu4

---------------
gnome-web-photo (0.8-0ubuntu4) maverick; urgency=low

  * fix LP: #625801 - gnome-web-photo missing required libxul.so; update
    wrapper script to use the current xulrunner-1.9.2 directory instead of
    any directory matching xulrunner-1.9.2*
    - update debian/scripts/gnome-web-photo
  * Explicitely build depend on xulrunner-1.9.2-dev due to change in wrapper
    script
    - update debian/control
  * Drop extra '\' file that got into the diff
    - drop \
 -- Micah Gersten <email address hidden> Mon, 30 Aug 2010 13:31:48 -0500

Changed in gnome-web-photo (Ubuntu):
status: In Progress → Fix Released
Micah Gersten (micahg) wrote :

Lucid debdiff attached, just needs sponsoring

Changed in gnome-web-photo (Ubuntu Lucid):
importance: Undecided → Medium
status: New → Confirmed
Stefano Rivera (stefanor) wrote :

Uploaded to lucid-proposed

Changed in gnome-web-photo (Ubuntu Lucid):
status: Confirmed → Fix Committed
Chris Coulson (chrisccoulson) wrote :

Hmmm, why is gnome-web-photo setting LD_LIBRARY_PATH anyway? It looks like it's using the standalone XPCOM glue, so it shouldn't need the GRE directory defined in LD_LIBRARY_PATH. I suspect that might be working around a real bug (ie, directly linking against libxul, which it shouldn't be doing)

Chris Coulson (chrisccoulson) wrote :

So, this is actually using the dependent glue (which is why it's liking against libxul and libxpcom). I'd prefer it if we converted this to use the standalone glue, and then we can drop the wrapper script entirely

Martin Pitt (pitti) wrote :

Not sure, should we accept the current SRU then, or replace it with something better (cf Chris' comment)?

Martin Pitt (pitti) wrote :

Chris, Micah, ping?

Micah Gersten (micahg) wrote :

As I understand it, we'll try to fix this for Natty and then backport when we update to Firefox 4.x.

Martin Pitt (pitti) wrote :

So I'll reject the current upload for now. Please feel free to reuse the version number.

Accepted gnome-web-photo into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Micah Gersten (micahg) wrote :

As a follow up to the xpcom issue, Bug #427817 is already filed, so I'll milestone it for Natty.

Stefano Rivera (stefanor) wrote :

Just tried to verify this, new version works, but so does the current one. How do I get multiple xulrunner-1.9.2 directories on my system (as specified in the test case).

You shouldn't be able to in theory, but a failed upgrade might result
in the directory not being removed. If you want to test if it breaks
you can always add a fake directory like this:
sudo mkdir /usr/lib/xulrunner-1.9.2.2/
and watch it fail.

I happen to have an old /usr/lib/xulrunner-1.9.2a1pre directory lying
around.

On 10/24/2010 12:17 PM, Stefano Rivera wrote:
> Just tried to verify this, new version works, but so does the current
> one. How do I get multiple xulrunner-1.9.2 directories on my system (as
> specified in the test case).
>

Stefano Rivera (stefanor) wrote :

Righto, happy with that.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-web-photo - 0.8-0ubuntu3.1

---------------
gnome-web-photo (0.8-0ubuntu3.1) lucid-proposed; urgency=low

  * fix LP: #625801 - gnome-web-photo missing required libxul.so; update
    wrapper script to use the current xulrunner-1.9.2 directory instead of
    any directory matching xulrunner-1.9.2*
    - update debian/scripts/gnome-web-photo
  * Explicitely build depend on xulrunner-1.9.2-dev due to change in wrapper
    script
    - update debian/control
 -- Micah Gersten <email address hidden> Sun, 12 Sep 2010 10:29:27 +0200

Changed in gnome-web-photo (Ubuntu Lucid):
status: Fix Committed → Fix Released

I'm running gnome-web-photo 0.8-0ubuntu5 on Maverick and it still sais it's missing libxul.so. Am I missing something?

Micah Gersten (micahg) wrote :

Please file a new bug and we'll see what the issue is.

On 10/31/2010 04:24 PM, Serrano Pereira wrote:
> I'm running gnome-web-photo 0.8-0ubuntu5 on Maverick and it still sais
> it's missing libxul.so. Am I missing something?
>

I just filed the new bug: Bug #669620

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers