In karmic the program hangs on anything

Bug #445338 reported by Paweł T. Jochym on 2009-10-07
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-web-photo (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-web-photo

After upgrade to karmic the gnome-web-photo hangs on anything I throw at it.

How to reproduce:
You can get a hang by following invocation (one line):
gnome-web-photo --mode=photo --format=png 'http://josm.openstreetmap.de/wmsplugin/YahooDirect.html?bbox=19.9832655,50.0639502,20.0161869,50.1061982&srs=EPSG:4326&width=500&height=499' file.png

You should get the bitmap of arial photo of cracow/poland in the file.png (you can test this in browser). Instead the program just hangs without any message consuming 100% cpu.

Even worse it is used as thumbnailer by nautilus. Just create empty file file.html and watch the hourglass icon for it and CPU soaring to 100% without any result. Furthermore - it blocks further updates of other icons until you kill the process.

The actual hanging process is /usr/bin/gnome-web-photo.real

This seems to be quite serious. Maybe not critical but high priority in my book.

ProblemType: Bug
Architecture: i386
Date: Wed Oct 7 12:35:13 2009
DistroRelease: Ubuntu 9.10
Package: gnome-web-photo 0.8-0ubuntu2
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=pl_PL.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: gnome-web-photo
Uname: Linux 2.6.31-11-generic i686

Paweł T. Jochym (jochym) wrote :
andypiper (andypiperuk) wrote :

I've hit this bug today - I want to use gnome-web-photo with shutter but it hangs. I've tried running at the command-line with both xulrunner-1.9.1.5 (hang) and xulrunner-1.9.0.14 (outputs some text about registering some mozilla.org python loaders, then hangs).

Paul Gevers (paul-climbing) wrote :

Instead of hanging, it times out on my box with no load whatsoever. Setting this bug to confirmed.

$ gnome-web-photo --mode=photo --format=png 'http://josm.openstreetmap.de/wmsplugin/YahooDirect.html?bbox=19.9832655,50.0639502,20.0161869,50.1061982&srs=EPSG:4326&width=500&height=499' file.png
Load timed out; consider using --force or increasing the timeout (use 0 for no timeout)

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic

$ apt-cache showpkg gnome-web-photo
Package: gnome-web-photo
Versions:
0.8-0ubuntu2 (/var/lib/apt/lists/nl.archive.ubuntu.com_ubuntu_dists_karmic_universe_binary-i386_Packages) (/var/lib/dpkg/status)
 Description Language:
                 File: /var/lib/apt/lists/nl.archive.ubuntu.com_ubuntu_dists_karmic_universe_binary-i386_Packages
                  MD5: 411e580ab135d36cfbd2d619361eeae2

Reverse Depends:
  shutter,gnome-web-photo
  beagle,gnome-web-photo
Dependencies:
0.8-0ubuntu2 - libatk1.0-0 (2 1.20.0) libc6 (2 2.4) libcairo2 (2 1.2.4) libfontconfig1 (2 2.4.0) libfreetype6 (2 2.2.1) libgcc1 (2 1:4.1.1) libgconf2-4 (2 2.23.2) libglib2.0-0 (2 2.16.0) libgtk2.0-0 (2 2.17.10) libjpeg62 (0 (null)) libnspr4-0d (2 4.7.3-0ubuntu1~) libpango1.0-0 (2 1.14.0) libpng12-0 (2 1.2.13-4) libstdc++6 (2 4.1.1) libxml2 (2 2.6.27) zlib1g (2 1:1.1.4) gconf2 (2 2.10.1-2) xulrunner-1.9.1 (0 (null))
Provides:
0.8-0ubuntu2 -
Reverse Provides:

Changed in gnome-web-photo (Ubuntu):
status: New → Confirmed
Barteq (barteqpl) wrote :

Same here. gnome-web-photo hangs making thumbnails of random html file. It causes no thumbnails at all (in Gnome).

Jan27 1:15 /usr/bin/gnome-web-photo.real --mode=thumbnail --timeout=16 --size=128 file:///home/barteq/bookmarks.html /tmp/.gnome_desktop_thumbnail.PVHG7U

Since Jan27 (today Jan 31). The only good thing is that it makes no load on cpu.

Linux thinkpad 2.6.31-18-generic #55-Ubuntu SMP Fri Jan 8 14:55:26 UTC 2010 i686 GNU/Linux

Ubuntu 9.10

Package: gnome-web-photo
Versions:
0.8-0ubuntu2 (/var/lib/apt/lists/ubuntu.task.gda.pl_ubuntu_dists_karmic_universe_binary-i386_Packages) (/var/lib/dpkg/status)

Barteq (barteqpl) wrote :

Made a little bit of debugging and finally thumbnailer works again.
The problem was /usr/lib/libnspr4.so. After moving it into another location and doing ldconfig, gnome-web-photo started working again.

libnsp4 is Netscape Portable Runtime library which is needed by many system tools (like Firefox or Evolution for example). Don't know why after changing name of this library, xulrunner don't need it any more. Before it hanged while trying to load this lib.

Be aware - this trick works only with xulrunner-1.9.1.7 (/usr/lib/xulrunner-1.9.1.7). With older versions it might return error about missing library.

Amano (amano) wrote :

I had the same issue where it would hang and not generate thumbnails for HTML . I ended up un-installing any beta Firefox web browsers and xulrunners that weren't with the regular Ubuntu repos, now everything works again. I also tested the OP link and it worked fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers