gnome-web-photo segfaults on simple command line usage

Bug #429125 reported by David Dean on 2009-09-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-web-photo (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-web-photo

I'm using gnome-web-photo to download satellite imagery for the JOSM Openstreetmap editor, but I am getting segmentation faults when using gnome-web-photo:

    david2@olivaw:~$ gnome-web-photo "http://www.google.com" /tmp/tmp.png
    /usr/bin/gnome-web-photo: line 29: 11354 Segmentation fault LD_LIBRARY_PATH="$MOZLIBPATH:$LD_LIBRARY_PATH" /usr/bin/gnome-web-photo.real $@

This only started happening in the past couple of days, so this problem may have been caused by a recent package update regression, but I'm not sure how to check that.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: gnome-web-photo 0.6-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-web-photo
Uname: Linux 2.6.28-15-generic i686

David Dean (ddean-ieee) wrote :
Fabián Rodríguez (magicfab) wrote :

Attaching result of
strace -o gnome-web-thumbnail-segfault-strace.log gnome-web-thumbnail http://google.com google.png

Changed in gnome-web-photo (Ubuntu):
status: New → Confirmed
importance: Undecided → Low

Architecture: amd64
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia wl
Package: gnome-web-photo 0.8-0ubuntu2
PackageArchitecture: amd64
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-12.41-generic
Uname: Linux 2.6.31-12-generic x86_64
UserGroups: adm admin cdrom dialout libvirtd lpadmin netdev plugdev sambashare

tags: added: apport-collected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers