Comment 10 for bug 1704533

Christophe C (batra3) wrote :

In fact the problem is simple : libgweather-common.deb had not package the traductions (!!).

In debian sid, libgweather-common.deb (3.26.0-1) include (a part of) the trad files in /usr/share/locale. For example :
/usr/share/locale/et/LC_MESSAGES/libgweather-3.0.mo
/usr/share/locale/et/LC_MESSAGES/libgweather-locations.mo
/usr/share/locale/eu/LC_MESSAGES/libgweather-3.0.mo
/usr/share/locale/eu/LC_MESSAGES/libgweather-locations.mo
/usr/share/locale/fr/LC_MESSAGES/libgweather-3.0.mo
/usr/share/locale/fr/LC_MESSAGES/libgweather-locations.mo
.......

See here the complet list of "normals" files : https://packages.debian.org/sid/all/libgweather-common/filelist.

In Ubuntu 17.10 and 18.04, libgweather-common.deb has NOT these files. /usr/share/locale is not include.

I picked the 2 files which interess me in libgweather-common.deb from sid :
/usr/share/locale/fr/LC_MESSAGES/libgweather-3.0.mo
/usr/share/locale/fr/LC_MESSAGES/libgweather-locations.mo
and i copied them (in root) in the same directory on my disk. And GNOME-WEATHER just Work. In french.

So please, rebuild libgweather-common.deb with /usr/share/locale/. Or directly use the sid version....