Preferences option for Removable Drives doesnt control Removable drives

Bug #202457 reported by Jeremy Wilkins on 2008-03-15
92
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
One Hundred Papercuts
Undecided
Unassigned
gnome-volume-manager
Invalid
Medium
gnome-volume-manager (Ubuntu)
Low
Unassigned
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-volume-manager

In System -> Preferences there is a link for 'Removable Drives and Media'. This no longer controls Removable Drives - this is handled by Nautilus' edit->preferences menu.

Martin Pitt (pitti) wrote :

Indeed it should be renamed to more accurately reflect g-v-m's purpose.

Changed in gnome-volume-manager:
status: New → Confirmed
Jeremy Wilkins (jeb-jdwilkins) wrote :

Should there also be some link to the nautilus settings? I only knew where to find the settings because of something I'd seen on p.g.o?

Changed in gnome-volume-manager:
status: Unknown → New
dennis1200 (dennis-fiser) wrote :

The nautilus settings are a pale comparison to the former Removable Drives menu - failing to autodetect plenty of [non-default] installed programs, as seen in Bug 191475. This almost feels like a regression, and disturbingly similar to the Windows autolaunch menu, which limits your choices to a short, defaults-based list. Why not just restore the option to run any command? For example, I prefer Exaile for music, and VLC for DVD. Rhythmbox and Totem get uninstalled pretty quickly. Without Totem, it doesn't detect any DVD software, and the drop-down is completely greyed-out/inaccessible.

At least create a link - I only found out where it was by searching the forums. This is basic functionality stuff.

Alexander Jones (alex-weej) wrote :

From my duplicate report, which existed only because the original reporter here couldn't spell "Removable" :P

Since the switch to GVFS and GIO in Nautilus, these settings have moved from gnome-volume-properties to the "Media" tab of nautilus-file-management-properties.

We're in need of a cleanup here, gnome-volume-manager as a whole is no longer is relevant to "volumes", but controls actions for basically any HAL device. As such, we should rename the preference tool to "Removable Hardware" at the very least.

Furthermore, I suggest we unhide the "File Management" preference tool, as we really need that back in the menus for dealing with removable media, now.

Ultimately, this Media tab should vanish from Nautilus's preferences and its functionality put back into g-v-m, but this is beyond our scope. I'd still make a case for it upstream, however.

and

I would argue, in this case, that breaking the translations is simply
not a problem as ALL translations are currently 100% inaccurate.

description: updated

I have been happily using a custom script to import my photographs from my camera.

This is still set in "Removable drives and media preferences", but it never runs.

I cannot find any way to set my script to run via the 'media' tab in Nautilus, so this would not appear to be the solution.

Sancho (sancho-sancho) wrote :

The removable drives are missing.
The problem of autorun is only a part of the tab's previous functionality.
I need to disable automount of media -otherwise I am stuck and can't work with damaged USB sticks etc.
The system automaticaly tries to scan the inserted disk and it will get stuck.
This is causing a serious usability issue for me.

Richard Laager (rlaager) wrote :

I'm of the opinion these options should simply be moved back. If you rename the preferences option, then I would have looked there and not found anything relevant (or still found Removable Hardware or whatever) and I'd be in the same boat. The location in Nautilus is non-discoverable.

Richard Laager (rlaager) wrote :

This bug should be folded into bug #214621.

Richard Laager (rlaager) wrote :

Henry Gomersall's description in bug #214621:

With the introduction of Hardy, the dialogue for setting the policy for handling the insertion of different media (CD, DVD, Photo flash cards etc) has been moved from the "Removable drives and media" capplet to the Nautilus preferences.

Nautilus preferences should have information *only* regarding the nautilus window. Setting system level policies here is a really bad usability move. Users neither need to know nor should they care that nautilus is the program actually handling the HAL events (if indeed it is). The file manager is not the natural place to look for this option. Not least because YOU NEED THE FILE MANAGER OPEN in order to find it. From the users perspective, the file manager is not always open, and hence system level settings should be kept well away from it.

This is a serious usability regression. If it is an upstream issue, then a bug report should be filed (which I am happy to do). Despite the fact that Nautilus has this option, it is sufficiently non-discoverable that an alternative move would be to still include the old "Removable drives and media" capplet and duplicate the options (a crap solution, but arguably better than the current situation). The natural place to put options regarding removable drives and media is the "REMOVABLE DRIVES AND MEDIA" capplet. If there is a desire to remove this capplet, then do it all or don't do it at all.

Richard Laager (rlaager) wrote :

I asked a few co-workers to "Change what happens when you insert a DVD." They all went to the preferences, not surprisingly. They all then opened the Removable... applet. If we rename the applet, then they'll simply be lost in the preferences with nowhere to go. This functionality should either be moved back or the preference item should act as a shortcut to open the Nautilus preferences to that pane. I informed them of the GNOME change and the universal response was asking why distros aren't putting the pressure on GNOME for an obviously bad design decision, or patching it themselves.

Changed in nautilus:
status: New → Confirmed
Changed in nautilus:
status: Unknown → New
A. Walton (awalton) wrote :

"Not least because YOU NEED THE FILE MANAGER OPEN in order to find it. From the users perspective, the file manager is not always open, and hence system level settings should be kept well away from it."

Not to detract from your plight, but this part is false. The file manager is always open from the perspective of users ("it's the thing that draws the desktop icons", people often confuse this with just "GNOME being open" though), and you can access that dialog from outside of Nautilus, via the "File Management" properties applet (nautilus-file-management-properties).

Not that I don't agree with you that it could or should live elsewhere (even though Nautilus does the mounting now). There's an open bug to rename that applet to fit its new behavior, but that's even more silly... I don't believe there is any technical reason it has to live inside of Nautilus, we're just setting handlers for the x-content/* mime-types.

A possible rationalization would be that the current "Removable Media" dialog has the distinct feel of old, especially mentioning palm pilots and forcing users to enter the exact command rather than choosing a viable app from a list. Doing this would currently require moving another dialog, the application chooser, out of Nautilus and into the platform, e.g. into Gtk+ (which is something we want to do anyways so Firefox and the like can use it). Any change made at this point, especially one as drastic as the above, would have to be done for GNOME 2.24 so it's yet-another-workflow-disruption even if it is just restoring it to the "old" location.

Anyways, the above is just a thought. I'm not responsible for the design or implementation of it (though I guess I could be if this is something we really want to distro-patch in; it's a pretty big delta so it should be thought out carefully, and we should probably get rid of those awful combo boxes and fix bug http://bugzilla.gnome.org/show_bug.cgi?id=522364 while we're at it). For now, the interested people should contact/cc the author David Zeuthen, to see his opinion on it.

Changed in gnome-volume-manager:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Confirmed → Triaged
Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Confirmed → Triaged
Changed in nautilus:
status: New → Confirmed
Martin Pitt (pitti) wrote :

We don't install g-v-m by default any more, which already helps a bit with reducing the confusion.

Changed in gnome-volume-manager:
status: Triaged → Invalid
Changed in gnome-volume-manager:
status: New → Invalid
Vish (vish) wrote :

Thank you for bringing this to our attention. Unfortunately a paper cut should be a small usability issue that affects many people and is quick and easy to fix. I'm afraid this bug can't be addressed as part of this project.

gnome- volume-manager is not in the default install anymore, hence Not a papercut.
A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut

Don't worry though, This bug has been marked as "invalid" ONLY in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
Changed in nautilus:
importance: Unknown → Medium
Changed in gnome-volume-manager:
importance: Unknown → Medium
status: Invalid → Unknown
Changed in nautilus:
status: Confirmed → Fix Released
Vish (vish) on 2010-12-08
Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Fix Committed
Changed in gnome-volume-manager (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in gnome-volume-manager:
status: Unknown → Invalid
Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.