external usb disks no longer mount in gutsy

Bug #132349 reported by Rocko on 2007-08-14
12
Affects Status Importance Assigned to Milestone
gnome-volume-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: hal

After the latest Gutsy updates of 14/7/07, my external drives no longer mount when inserted.

They are still visible in hal-device-manager and the debug log shows a nm_hal_device_added() message for each device.

Trying to mount manually with

    sudo gnome-mount -d <device>

results in the error message 'You are not privileged to mount the volume [volume name]'.

Trying to mount with

    sudo gnome-mount -h <hal-udi>

says there is probably no media in the drive.

Every six seconds, the daemon log shows the message:

nm_policy_device_change_check:: old_dev has link? 1
nm_policy_device_change_check:: old_dev && new_dev

Rocko (rockorequin) wrote :

I suspect it might be a fault with gnome-volume-manager instead of hal.

I can mount the drives with 'sudo mount', and hal-device reports they are mounted.

Rocko (rockorequin) wrote :

The problem still exists after the upgrade to kernel 2.6.22-10.

Other application versions that might be of use are:

gnome-volume-manager 2.17.0-ubuntu1
gnome-mount 0.6.1-ubuntu2
nautilus 1:2.19.90-0ubuntu1
hal 0.5.9.1-ubuntu2

I can confirm this. I have this problem too.

Changed in gnome-volume-manager:
status: New → Confirmed
Krešo Kunjas (deresh) wrote :
Rocko (rockorequin) wrote :

I tried some of the suggestions in the forums, but they didn't help.

However, I installed tribe5 from scratch and now my drives automount again.

Rocko (rockorequin) wrote :

I can consistently break automounting in tribe5 (although rebooting the PC fixes it):

1. I Run gparted.

2. I tell it to unmount the external 120 GB USB drive. It does so (and then crashes when rescanning devices).

3. I re-run gparted and tell it to format the external drive to FAT32. It does so (and then crashes when rescanning devices).

Now neither of my external drives will automount until I reboot the PC. I can still manually mount them with the sudo mount command, though.

Rocko (rockorequin) wrote :

After yesterday's updates it is broken again. The drives do not automount any more, even after a complete reboot.

Rocko (rockorequin) wrote :

I found what seems to be the problem, thanks to bug #131107. gparted creates the file:

/usr/share/hal/fdi/policy/gparted-disable-automount.fdi

which stops any drives from automounting.

I removed the file and restarted hal with "sudo /etc/init.d/hal restart" but this didn't have any effect; but after I rebooted completely, my drives now automount.

Normally gparted deletes the file when it exits. I assume that (a) because gparted crashed, it didn't delete the file; (b) originally when I was rebooting, the file was flagged each time for deletion upon exit, so it didn't persist, and after reboot the drives mounted; but at some point the file became persistent and this broke automounting.

Although gparted needs to stop drives from automounting (eg see bug #37768 and its duplicates), it's a bit dangerous to allow a file that disables all automounting to persist through reboots. To the end user, it just looks like automounting is broken.

Krešo Kunjas (deresh) wrote :

it's now working for me with latest updates. maybe it's fixed?

and no i didn't have gparted-disable-automount.fdi nor i have done anything to try to fix it. It just have gone away...

After removing gparted-disable-automount.fdi it works for me too.

flowbot (flowbot) wrote :

great stuff - was having the same problem after using gparted, and removing gparted-disable-automount.fdi got it all happening again for me, too.

Hendrick Musche (hmu) wrote :

I'm marking this as duplicate, as its obviously actually a bug in gparted.

Suchawato (anavi) wrote :

Hi.
I'm having similar problems.
After installing Gutsy,
My 5'th Gen iPod video will not mount at all.
And, I am having a problem with my LaCie external Hard Drive.
At first, I could not read or write to it as Gutsy annoyingly made it a Root only permission by default. This was really irritating, but not unfixable.
Then, after I changed the permissions so that all users could read/write/delete/change files, it seemed to work fine.
Then, the other day when I tried to copy my school assignment to the school folder on my LaCie, it (Gutsy) would not let me. "Access Denied; you don't have permissions to write to this folder". When I used
Code:

gksudo nautilus

to try to re-change the permissions as Root, I got; "The Owner Could Not Be Changed; Couldn't change the owner of "LaCie" because it is on a read-only disk".
There is no switch or button on the LaCie, that makes it "read only".
It's a USB external drive. There would be no point in making it "read only"
It Isn't read only.
I don't care what Gutsy thinks.
I can access it fine on the Macs at school.
So at the moment, I am unable to use it on this computer.

Kjell Braden (afflux) wrote :

Suchawato, the bug you're reporting seems to be a different one. Please open a new bug report for it.

iwan (iwan-it04) wrote :

thank's, removing gparted-disable-automount.fdi it works for me too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers