support for the windows autorun mecanism - patch included

Bug #123313 reported by Hanusz leszek on 2007-06-30
14
Affects Status Importance Assigned to Milestone
gnome-volume-manager
Fix Released
Wishlist
gnome-volume-manager (Baltix)
Undecided
Unassigned
gnome-volume-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: gnome-volume-manager

Hello,

I have included a patch to implement this specification:
https://wiki.ubuntu.com/autorun

It would allow to autorun windows cd's by reading the autorun.inf file.

description: updated
description: updated
Changed in gnome-volume-manager:
status: Unknown → New
Vijay Kiran Kamuju (infyquest) wrote :

We should not hard code the wine path, but should search for it.
If it fails only then only we should resort to it.
The searching should be done first using the package managers like rpm,deb.
Inorder to search for wine path by searching for standard app
installations like wine,cxoffice,cedega in this order)
If it fails then it should search for it using the 'which wine' ouptut.
If that too fails we should use hardcoded paths. (as last resort).

I would say that please have a look at wine module code in guidance.
for checking whether wine has been installed or not.
and to get its path.

Martin Pitt (pitti) wrote :

Very interesting, thank you!

I am not convinced about asking a question like "Do you think that this is safe?" to an user, since usually they have no chance of giving a profound answer (telling apart a good setup.exe from a Sony trojan). However, if the defaults are sane (if you press Enter in a hurry, you'll chose "Not start"), this would be a cool feature. Also, it should not ask that question if wine is not installed.

I'll take a closer look at this soon, thank you!

Changed in gnome-volume-manager:
assignee: nobody → pitti
importance: Undecided → Wishlist
status: New → Confirmed
Changed in gnome-volume-manager:
status: New → Fix Released
CirclingTheSun (circlingthesun) wrote :

I see reading the autorun.inf has been implemented in hardy. I get the following error dialog when the program being autorun is a .exe:

"Error autorunning software
Cannot find the autorun program"

I have wine installed

levmatta (levmatta) wrote :

I have the exact same problem ("Cannot find the autorun program") in a DELL Inspiron 1525 Laptop, running Hardy Alpha 6 EMT64.
Then I installed Wine and the problem PERSISTED.

Martin Pitt (pitti) on 2008-03-19
Changed in gnome-volume-manager:
assignee: pitti → nobody
Hanusz leszek (leszek-skynet) wrote :

Two different implementations were made after my initial patch so I consider this bug report as obsolete.
Closing as Invalid.
For the bug appearing in hardy, you can go there :
https://bugs.launchpad.net/ubuntu/+source/gnome-volume-manager/+bug/205414

It probably won't work soon because I noticed that some code moved from gnome-volume-manager to nautilus and I saw this in the code:

} else if (_check_file (root, "autorun.exe", TRUE)) {
/* TODO */
} else if (_check_file (root, "AUTORUN.EXE", TRUE)) {
/* TODO */
} else if (_check_file (root, "autorun.inf", FALSE)) {
/* TODO */
} else if (_check_file (root, "AUTORUN.INF", FALSE)) {
/* TODO */
}

Changed in gnome-volume-manager:
status: Confirmed → Invalid
Hanusz leszek (leszek-skynet) wrote :

see below

Changed in gnome-volume-manager:
status: New → Invalid
Gbax (bax320) wrote :

How about a fix???

Changed in gnome-volume-manager:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.