/dev/sda3 is mounted despite the 'noauto' option in fstab

Bug #120829 reported by ingo on 2007-06-17
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-volume-manager (Ubuntu)
Low
Unassigned
Nominated for Karmic by makita

Bug Description

Binary package hint: mount

besides the Ubuntu feisty installation I have 2 other Linux-partititions formatted ext3. As they contain another system I do not want Ubuntu to touch them. So I edited /etc/fstab and added the option 'noauto' for those entries.
Ubuntu does not respect these options and still mounts them at every boot-up.

Example with /dev/sda3:

1. line in fstab:
# /dev/sda3
UUID=72478130-3425-47ca-92e5-7270e8d3b6b2 /media/sda3 ext3 user,noauto 0 0

2. line in 'cat /proc/mounts':
/dev/disk/by-uuid/72478130-3425-47ca-92e5-7270e8d3b6b2 /media/sda3 ext3 rw,nosuid,nodev,noexec,data=ordered 0 0

The 'noauto' option is just ignored! Linux in no way should mount 'foreign' filesystems without confirmation by the user
also with respect to security (removable media is a different story).

I thus placed a '#' in front of the line in fstab, now Ubuntu complains about 'error mounting local filesystems' on every boot.

ProblemType: Bug
Architecture: amd64
Date: Sun Jun 17 13:03:31 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/gnome-panel
Package: gnome-panel 1:2.18.1-0ubuntu3.1
PackageArchitecture: amd64
ProcCmdline: gnome-panel --sm-client-id default1
ProcCwd: /home/ingo
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-panel
Uname: Linux pp 2.6.20-15-generic #2 SMP Sun Apr 15 06:17:24 UTC 2007 x86_64 GNU/Linux

ingo (ingo-steiner) wrote :
ingo (ingo-steiner) wrote :

> thus placed a '#' in front of the line in fstab, now Ubuntu complains about 'error mounting local filesystems' on every boot.

This issue has been resolved meanwhile, it was my fault: a typo in /etc/fstab.
It is not related to the obove described bug which still persists (noauto option is ignored)

jwmislan (jwmislan) wrote :

My Machine : MSI-16332 - Notebook
OS: Ubuntu 7.04 - AMD64
Fresh Install

I also have this same problem.
I use noauto in fstab but feisty ignores this mount option.

I have 3 other os's w/multi partitions, and feisty insists on mounting everything in sight ( like a blabber-mouth ) : O
Just ignore the owners security preferences, and do what feisty thinks - that reminds me of you know who.
This looks like, and is to me, a high priority security issue that - needs to be fixed - FAST -
So what's the hold up in offering a solution from ubuntu security team ??

 I could comment out the enteries in fstab - like hitting it with a Sledge - Hammer ?
why not have a simple option for the mount utility - hmmm lets see -
how about somthing like ( NOAUTO or noauto ) ??
that should work, i like noauto better it's quieter : - )

 Only option a the moment is ( Sledge-Hammer ) approach to shut it up.
 Is it just me - that I like to have full control of what's going on my machine.
Imagine the many unwitting that don't know that all their partitions are forced open to attacks from anywhere.

I better shut up now before they start getting any ideas eh ?

 I'll Be Back !!

Arnold

ingo (ingo-steiner) wrote :

Arnold,

in fact you are right - depending on conditions this can be a big security hole.
It also is contradicting to the Linux-philosophy 'do not touch foreign data unless the user tells you to do so'.
Moreover there seems to be no reaction on this issue.
Therefore I did change the description flag to 'also affects security#

Ingo

ingo (ingo-steiner) wrote :

Meanwhile I gathered some more information:

1. if the only option in /etc/fstab is 'noauto' all is fine, it gets not mounted

2. if the option 'user' is also added (noauto,user) it gets mounted

Conclusion: some process/application performs the mounting in user space.
    However I am unable to find out, how to avoid that, must be some
    process of the distribution or desktop?

'mount' seems to perform correctly, I therefor do assign this bug to the distribution

Ingo

BrownCoal (faith-is-blind) wrote :

I also have the problem of noauto being ignored. It worked fine in Dapper, but in Feisty, if the "user" option is used it ignores "noauto", and if "user" is removed it doesn't automount but then doubleclicking on the drives icon results in the message "You are not privileged to mount the volume". I've searched the ubuntu forum, wiki and google. Here's what I have found so far; I have turned up a few pages of interest but I just haven't been able to find any solution.

This page describes how to force hal to ignore certain drives/partitions at startup: http://ubuntuforums.org/showpost.php?p=2605508&postcount=34

Here is a detailed explanation of fstabs peculiar behaviour: http://ubuntuforums.org/showthread.php?p=2563990

Here are two pages that detail what I expect fstab "noauto" and "user" options to do: http://ubuntuforums.org/showthread.php?t=283131
http://www.tuxfiles.org/linuxhelp/fstab.html

Any help is much appreciated!!

ingo (ingo-steiner) wrote :

I just installed Gusty Beta and checked for that issue:
it has been fixed, 'noauto,user' no longer mounts the partitition, and users are allowed to mount manually.
Thanks to the maintainers!

It would now be great to have that important fix also backported to Feisty.

Best regards, Ingo

BrownCoal (faith-is-blind) wrote :

Well, I have finally found the problem... It very simply involves the single setting [system>preferences>removable drives and media>storage>mount removable media when inserted]. Deselecting this makes noauto work as usual. I also managed to remove the desktop drive icons; open terminal and type "gconf-editor" and deselect [/apps/nautilus/desktop/volumes_visible].

The question now is why the developer/s decided that a gnome preference (and a non-passworded one at that!) should override fstab... If this has indeed been corrected in Gutsy as Ingo suggested, then hopefully in means that the devs have reverted to the regular approach of giving fstab full command of mounting drives.

BrownCoal (faith-is-blind) wrote :

Pleasingly, disabling the option [system>preferences>removable drives and media>storage>mount removable media when inserted] still allows usb devices to be mounted automatically.

What's happening here is that the drives are defined to not be automatically mounted on boot ("noauto") but are defined to permit users to mount them.

When a user logs in, it looks like it's mounting them.

Gnome-volume-manager or whatever does that bit these days should respect the noauto flag?

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? May you please try the same with Karmic? Thanks in advance.

Changed in gnome-volume-manager (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
ingo (ingo-steiner) wrote :

> status: New → Incomplete

are you joking??

This bug was reported for Feisty more then 2 years ago. Feisty is no longer maintained, so it should be marked
-> OUTDATED!

And now asking to check with Karmic just demonstrates the main deficiency of this bug reporting system:

A bug is reported for a certain release and to my experience rarely fixed in that release. A new release might fix that bug automatically (or not), but at the same time introduce several other bugs. That way Ubuntu never gets better as you expect ("helping to make Ubuntu better").

Bugs should be tied to a release and should be fixed in that very release, instead of beeing ignored most of the time. Therefore I meanwhile have given up to report bugs here as it appears useless. This even applies to Hardy which is a LTS release where I got replies on bug reports like:

"fixed in Jaunty, won't fix in Hardy"
"Please check whether it is still present in Intrepid?"
....
Please consider that Hardy is going to survive both Intrepid and Jaunty with regard to maintenence!

Changed in gnome-volume-manager (Ubuntu):
status: Incomplete → Confirmed
Alessio Bolognino (themolok) wrote :

I'm using Karmic and the bug seems to be still here. I mean, I have an external hdd, but I want gnome-volume-manager to automount only one partition, so I put in my fstab something like this:

/dev/disk/by-id/usb-SAMSUNG_HD103SI_1f00bfdf194b130251000000-0:0-part3 /media/Monolith hfsplus force,user,noauto 0 0
/dev/disk/by-id/usb-SAMSUNG_HD103SI_1f00bfdf194b130251000000-0:0-part2 /media/Monolith-Boot-OSX hfsplus force,noauto 0 0

I want g-v-m to mount only the first one, I set the noauto option because I don't want it to be mounted during boot, the force option is needed because it's a hfsplus partition with journaling. The "user" option should the one to do the trick, but g-v-m still complains when failing to mount the second partition, but it shouldn't try do it in first place! I know, it's just a warning, but it's annoying.

I attached a screenshot, in the foreground there is the error message I'd like to get rid of, in the background there is the window that nautilus opens when automounting the first partition.

Ubfan (ubfan1) wrote :

I've been dancing around this problem for the last few releases too. My workaround is to use /mnt instead of /media in fstab and then Gnome will obey the noauto. Ideally, I would still get these noauto partitions listed in Places/Other Removable Media menu so I could choose to mount them with a click, but that feature seemed to go away. gconf-editor apps/nautilus/preferences has
a medianoautomount option which may help your situation.

Ingo Ruhnke (grumbel) wrote :

The bug is still present in Ubuntu 10.10 and it seems I can confirm what Ubfan has mentioned, namely that the cause is the /media/ directory, as all my drives that mount elsewhere haven't been auto-mounted. Also this bug is only triggered sporadically, most the time it works fine and doesn't automount drives it shouldn't, but every now and then all drives will appear.

Jean (jean-harrault) wrote :

We are in 2015 and this bug seams to be still present in the 15.10 ubuntu version. I want to do a backup of my NAS on a internal hard drive, so just mount this hard drive during the backup and then unmount it. The issue is that it is auto mounted at boot even with the noauto option in the fstab.

@Jean, it's 2016, 16.04, and this bug is still present...
Tried `noauto` + a lot of different combinations, it is always ignored and mounted.

amk (9-launchpad-mikus-sk) wrote :

16.04. /etc/fstab contains
UUID=9bb5096d-7c9b-4a53-b298-7974b9cd6a74 /mnt/WD4 ext4 noauto,nofail,errors=remount-ro 0 0

Upon plugging the disk, following gets logged:
[190158.370855] sdd: sdd1
[190158.371844] sd 7:0:0:0: [sdd] Attached SCSI disk
[190158.649144] EXT4-fs (sdd1): warning: mounting unchecked fs, running e2fsck is recommended
[190158.655863] EXT4-fs (sdd1): mounted filesystem with ordered data mode. Opts: errors=remount-ro

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers