'Always perform this action': Ignore for photo card option doesn't work.

Bug #102495 reported by TM on 2007-04-03
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-volume-manager (Ubuntu)
Low
Martin Pitt
Declined for Feisty by Henrik Nilsen Omma
Declined for Gutsy by Henrik Nilsen Omma

Bug Description

When inserting flash memory card used in a digital camera (Canon PowerShot SD300), the "Photo Import" dialog appears asking me if I want to "Import Photos" or "Ignore" the card. There is also a checkbox titled "Always perform this action". Clicking the checkbox and then clicking "Ignore" does not have the desired effect -- the same dialog appears the next time the photo card is inserted.

Paul Dufresne (paulduf) wrote :

Is this on GNOME or KDE?
Using 7.04, Gutsy or other?

TM (junkmail-media) wrote :

I've verified this bug in GNOME for both 6.10 and 7.04.

Paul Dufresne (paulduf) wrote :

Thanks for giving the requested information.
Seems there is enough information for me to confirm the bug.
Stopping my assignment to this bug, as I was working only as a bug triager.

Changed in gnome-volume-manager:
assignee: dufresnep → nobody
status: Incomplete → Confirmed
fhucho (fhucho) wrote :

When I plug in my mobile phone k750i, the "Photo Import" dialog appears, I check the checkbox "Always perform this action" and consequently press the "Ignore" button. But when I plug it next time, the dialog appears again - the option "Always perform this action" doesn't work.
I am using Ubuntu 7.04 with Gnome.

Henrik Nilsen Omma (henrik) wrote :

Ignore probably just cancels the whole action. I agree that the correct behavior would be to remember that choice. Perhaps a separate Cancel button should be provided for 'Do nothing this once'.

This bug was nominated for Gutsy but does currently not qualify for a 7.10 stable release update (SRU) and the nomination is therefore declined.
According the the SRU policy, the fix should already be deployed and tested in the current development version before an update to the stable releases will be considered. With 7.10 now released, that policy applies to this bug. See: https://wiki.ubuntu.com/StableReleaseUpdates .
The bug is not being closed as work will continue on fixing it for the next release, Hardy Heron (8.04). If the state of this bug should change such that it qualifies for the SRU process, please contact the person who originally declined it and ask them to re-evaluate it. To help improve the state of this bug see: https://wiki.ubuntu.com/Bugs/HowToTriage .

Changed in gnome-volume-manager:
importance: Undecided → Low
KipBond (kipbond) wrote :

"Ignore probably just cancels the whole action. I agree that the correct behavior would be to remember that choice. Perhaps a separate Cancel button should be provided for 'Do nothing this once'."

Your options are: 1) Ignore or 2) Import Photos -- the dialog box is: "Photo Import: A photo card has been detected. There are photos on the card. Would you like to add these pictures to your album?" See attached screenshot.

"Ignore" would seem to do what you are suggesting a separate "Cancel" button would do: just not do anything. the "Import Photos" button would copy the photos from the SD card to the local drive.

The thing that is NOT working here, is the optional check-box that says: "Always perform this action". It is defaulted to not checked -- meaning every time a card is inserted, you will get this dialog box to select whether you want to import photos, or ignore it (this time). If you check the "Always perform this action" box, the system should either always 1) Ignore or always 2) Import Photos depending on which button you subsequently click.

DaveAbrahams (boostpro) wrote :

This comes up every time I plug in my iPhone. Horribly annoying. Why give me the checkbox if you're going to ignore its setting. Can we please at least have this bug accepted for Hardy?

Thanks.

Hammer89 (soc-intel) wrote :

I have the same problem with my iPod Touch.... definitely annoying.

Yeah, this bug is really frustrating, I experience it almost every day...
I don't understand why this bug still exists, it can't be so hard to repair...

On Sun, Mar 16, 2008 at 8:08 PM, Hammer89 <email address hidden> wrote:
> I have the same problem with my iPod Touch.... definitely annoying.
>
>
>
> --
> 'Always perform this action': Ignore for photo card option doesn't work.
> https://bugs.launchpad.net/bugs/102495
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Hammer89 (soc-intel) wrote :

I just figured out a way to sortof fix the problem...

Open a terminal and type "gconf-editor" (sans quotes)... then in the list on the left navigate to / --> desktop --> gnome --> volume_manager --> prompts... then change the value for "camera_import_photos" to "1"

Hope that helps someone. :)

Martin Pitt (pitti) on 2008-03-17
Changed in gnome-volume-manager:
assignee: nobody → pitti
status: Confirmed → In Progress
fhucho (fhucho) wrote :

Hammer: thanks for the effort, it will definitely help me!
Also thanks to Martin that he started to work on this bug.

On Mon, Mar 17, 2008 at 12:35 PM, Martin Pitt <email address hidden> wrote:
> ** Changed in: gnome-volume-manager (Ubuntu)
> Assignee: (unassigned) => Martin Pitt (pitti)
> Status: Confirmed => In Progress
>
>
>
> --
> 'Always perform this action': Ignore for photo card option doesn't work.
> https://bugs.launchpad.net/bugs/102495
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Martin Pitt (pitti) wrote :

This is not relevant for Hardy any more. Nautilus handles Cameras now, and there is no dialog any more. By default, the chosen application is just opened, and you can change the behaviour in the nautilus media preferences.

Changed in gnome-volume-manager:
status: In Progress → Invalid

This dialog still appears in Hardy and still does not work correctly.

Changed in gnome-volume-manager:
status: Invalid → Confirmed

This appears in Hardy everytime I plug in my iPhone. Agreed that the selections are ambiguous. Ignore + Always Perform this Action = No Result

James Roper (jroper2-gmail) wrote :

I too have seen this bug in Hardy, the fix suggested by Hammer works in Hardy too.

It may seem strange to the developers that someone would plug in a camera without wanting to import photos, but importing photos is not the only reason to plug in a camera device, you may also plug it in purely to charge it, which, in the case of an iPhone, is something you may do many times a day (every time I sit down at my desk at work), in which case, you definitely don't want a pop up appearing asking you if you want to import photos.

Hammer's fix worked on my 8.04 too.

Just found out when this bug appeared, so it can be easier for the developers to find it:

https://bugs.launchpad.net/ubuntu/+source/gnome-volume-manager/+bug/75130

I marked this bug as a duplicate of #75130.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers