Gnome-Voice-Control: Stuck on Calibration on amd64

Bug #253105 reported by Ben Carlin on 2008-07-29

This bug report was converted into a question: question #40773: Gnome-Voice-Control: Stuck on Calibration.

90
This bug affects 19 people
Affects Status Importance Assigned to Milestone
gnome-voice-control
Expired
High
gnome-voice-control (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: gnome-voice-control

The program is installed but when I click "start Control" the button changes from "Idle" to "Calibration" and it stays there. Nothing happens.. Also perhaps related Audacity doesn't seem to pick up my microphone. However I know my microphone works as I tried it in the program "Sound Recorder" after changing the default input from "Aux" to "Line-in" perhaps related?

Very annoying :-(

I would be very grateful for any help on the matter!

Cheers!

Hello Ben,

Thank you for your report. I have heard about this problem, and I'll see with upstream developers if it is fixed, and if it's a bug in gnome-voice-control, or something else.

As a workaround, I might suggest this from comment #10 from bug 219303:

"I finally managed to fix this other bug : when recording with Audacity, it appeared than only the left channel was recorded. After some changes in the volume mixer, Audacity recorded then both left and right channel, and Voice Control has now its normal behavior (Init -> Calibration -> Ready)."

I'm sorry for this inconvenience.

Ben Carlin (ben-5carlins) wrote :

Hey Saša,

Thanks for the quick reply. I have looked into this work around but unfortunately "Audacity" is not working either and I'm not really sure what settings to change to make it work. The Simple "Sound Recorder" does work however so I know my microphone is working.. I think obviously these two problems are related as someone got there "Gnome Voice Control" to work after changing settings for "Audacity".

The problem with "Audacity" for me is that when I try to record, both the channels both appear as if they are recording but they are just straight lines going across the page as the recording continues. They are not detecting any input from the microphone? Hmm very strange.

Thanks again.

Hello Ben,

As far as I can see, the problem might be that your sound card is
recording only left channel, when it's recording in mono. Try right
clicking on Volume control, then open the controls. Click on Settings.
I have a "Mix mono" switch to select. That maybe enables mixing of
both left and right channel into one, when recording in mono. Also,
check with other sound devices. Some of theme have two volume controls
for recording, so maybe one of them is muted.

My volume control doesn't have a settings button on it so I'm not to sure where to find this "Mix Mono" button? This is what my volume control looks like...

Thanks again!

Ben Carlin (ben-5carlins) wrote :

Also I don't know if this would help..

Hello Ben,

Look under the recording tab for the muted channel. Also, check out
the options inside File menu. I switched to 8.10 alpha 3 last night,
and the volume control is a bit different. I suppose there should be
options or settings under the File menu. Try changing the devices and
see if any of the recording controls are muted.

Unrelated to this, I'll switch this bug report to a question, since I
don't think this actually qualifies as a bug. We'll see if we need to
open another bug report and against which program after we solve your
problem.

I think this is not a bug. Some setting should be changed in volume control to fix this. After the problem is solved, we can open another bug report for this, in case it's really a bug.

Changed in gnome-voice-control:
status: New → Invalid
Saša Bodiroža (jazzva) wrote :

This is a bug, known upstream, so I'm making this a bug report again in order to track status of the upstream bug.

Changed in gnome-voice-control:
importance: Undecided → High
status: Invalid → Confirmed
Changed in gnome-voice-control:
status: Unknown → Confirmed
Michał Karnicki (karni) wrote :

I'm on HP Pavilion tx1320us, Audacity shows my mic working on both channels. My lap is AMD64, gnome-voice-control gets stuck on "Calibration". I'm adding my 3 cents to this bug report.

Changed in gnome-voice-control:
status: Confirmed → Invalid
Siegfried Gevatter (rainct) wrote :

According to upstream this is fixed in trunk (which requries a newer pocketsphinx version).

Diego561982 (diego-samuelle) wrote :

Im running Jaunty amd64 on a lg-e500 laptop, and have the same problem: stucks on calibration. please someone could help me? i've tried all possible sound configurations and nothing, mi mic works whit audacity and skype
(Im am from Uruguay, sorry for my english)

Diego561982 (diego-samuelle) wrote :

running jaunty on a amd64, an following this bug since a year ago! please, y am not technic but really need this aplication, can somebody help me? y ussually instal soft only from the oficial repos. is too hard for me use the terminal
i imagine that someone can resolve the problem and actualice the package on synaptics. and please, response to mi mail, even to tell me that there is no solution, i dont want to leave ubuntu. Gracias.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-voice-control - 0.4-0~ppa3

---------------
gnome-voice-control (0.4-0~ppa3) karmic; urgency=low

  * New upstream release (LP: #303628).
     - Works on amd64 systems (LP: #253105).
  * Improve the package's description, update to the current Standards Version,
    change debian/copyright to the machine-readable format and other changes.

 -- Siegfried-Angel Gevatter Pujals <email address hidden> Sat, 05 Sep 2009 01:11:05 +0200

Changed in gnome-voice-control (Ubuntu):
status: Confirmed → Fix Released
Siegfried Gevatter (rainct) wrote :

The last upload was accidental and doesn't work correctly. Unfortunatelly it looks like this won't be fixed in time for Karmic, but it's quite likely that we will have a working Gnome-Voice-Control in the Ubuntu release after that (Lucid Lynx). Once we have a working version I'll make it available in my PPA for Jaunty and Karmic users.

Changed in gnome-voice-control (Ubuntu):
status: Fix Released → Triaged

Same problem here, Applet stays at "Calibrating" and uses 100% cpu. Ubuntu karmic 64bit. Mic and sound work fine in other apps.

FiReSTaRT (dlyh) wrote :

I had a similar experience as Gunther. Nvidia chipset, but no memory leaks. Just calibrating forever. Audacity detects both channels when recording from the mic. Hoping for the fix to work in the version that'll come stock with Lucid.

Siegfried Gevatter (rainct) wrote :

Yes, that's a known bug with the version of gnome-voice-control currently in Ubuntu.

This is fixed in the latest version, but it has some other problem causing crashes so I couldn't update the package to it.

FiReSTaRT (dlyh) wrote :

Just to let you guys know, it's still happening under Lucid. Same as my previous post.

Luis Vieira (luis-avieira) wrote :

I confirm that the same problem happens to me.
2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux
gnome-voice-control : 04really0.2-0ubutu2
Stuck on calibration.

Hadrien Titeux (hadware) wrote :

I'm under Lucid Lynx, installed it today, and you know what? It Doesn't work :(
I'm also running a 64-bit Intel CPU (Centrino vPro 2).
Everything else works fine, and audacity in particular. I googled the problem and did not find a fix :(

Please get it fixed, this could be really great.

Siegfried Gevatter (rainct) wrote :

I've uploaded a 0.4 package to my PPA: https://edge.launchpad.net/~rainct/+archive/voice

As I've already said before, this one works on 64-bit systems, but when I try it I get frequent crashes. Some feedback on how it work on other systems would be nice.

Diego561982 (diego-samuelle) wrote :

Sorry, y added your ppa (on lucid) but the gnome-voice-control is not abaiable for this distro
Any solution??

Siegfried Gevatter (rainct) wrote :

Thanks for trying it out, Diego. I've just uploaded a version for Lucid to my PPA and it should be available soon.

Changed in gnome-voice-control:
importance: Unknown → High
status: Invalid → Expired
FiReSTaRT (dlyh) wrote :

I just wanted to note that this issue persists on Maverick AMD64.

Lepirate (groseb) wrote :

Mine calibrates since 3 hours. I think the bug isn't resolved. Why is this bug marked as expired ?
(same config as FiReSTaRT)

Julian Perelli (jperelli) wrote :

Hello
@Sigfried Gevatter: Can you upload a version for Maverick 10.10?
Thanks!

Livia (liviars) wrote :

This but also affects me.
gnome-voice-control gets stuck on "Calibration", after I chose 'Start Control'.
I'm using a Dell Inspiron 1525 - Ubuntu 10.10 - Maverick Meerkat. AMD64 build.
Version of gnome-voice-control: 0.4really0.2-0ubuntu2

pschonmann (pschonmann) wrote :

0.4really0.2-0ubuntu2 @ natty and still not works

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.