nautilus crashes when copying a 4G file on a vfat volume

Bug #70535 reported by wild.ideas on 2006-11-06
204
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GnomeVFS
New
Critical
gnome-vfs2 (Ubuntu)
Low
Unassigned

Bug Description

Occurred while copying an 8GB backup file from an internal HD to a USB HD. The Nautilus process crashed while unattended, likely after the screensaver had kicked in. ("Blank Screen" was selected for the screensaver to reduce CPU load.)

wild.ideas (wild-ideas) wrote :

Crash file for Nautlius attached...

wild.ideas (wild-ideas) wrote :

Found the smoking gun: Nautilus died after copying 4294967295 bytes = 2^32-1 bytes -- a 4GB boundary error.

wild.ideas (wild-ideas) wrote :

'cp' crashed with the same problem, at the same point in the file. (No suprise there.)

wild.ideas (wild-ideas) wrote :

This is odd: Nautilus was able to copy this file initially from one internal HD to another, without crashing at 4GB. In this case, the source HD was NTFS and the destination was ext3.

wild.ideas (wild-ideas) wrote :

Workaround: Divide files > 4GB with 'split', then copy the pieces, then join them again with 'cat'.

wild.ideas (wild-ideas) wrote :

Aha! This is *not* a 'cp' or Nautilus bug, per se -- I think this is a problem with this USB hard drive. Now the question is, is it a particular idiosyncrasy with this external drive, or is it a fundamental limitation of USB technology? (If the latter, then Nautilus --and 'cp'?-- would be improved by refusing any attempts to transfer files >= 4GB to a USB device, perhaps suggesting that the file be split first.)

Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been
reported into our bug tracking system, but please feel free to report
any further bugs which you find.

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Rejected
Sebastien Bacher (seb128) wrote :

not a duplicate

Changed in nautilus:
status: Rejected → Confirmed
Michael R. Bernstein (webmaven) wrote :

I just experienced a similar crash, copying from my main HD to an NTFS-formatted external USB HD. Crash report attached.

Crash during copy from a SAMBA filesystem to my FAT32 partition

Sebastien Bacher (seb128) wrote :

Louis-Xavier, thank you for your comment, no need of new crash file when a bug already has one and nobody requested for a new one

Sebastien Bacher (seb128) wrote :

frequent dups about that

Changed in nautilus:
importance: Medium → High
Sergio (sbp-m) wrote :

Nautilus crashed during the copy a 4.2 Gb iso image from XFS to Fat32 in another disk. I suppose that if the problem is not from nautilus but the fs itself, nautilus should show an alert or something, but not crash :)

Here is the compressed crash report

Sergio (sbp-m) wrote :

Nautilus crashed during the copy a 4.2 Gb iso image from XFS to Fat32 in another disk. I suppose that if the problem is not from nautilus but the fs itself, nautilus should show an alert or something, but not crash :)

Here is the compressed crash report

Sebastien Bacher (seb128) wrote :

For information there is noo need of a new crash file when the bug is not Needs Info with a comment asking for one

Kurt von Finck (mneptok) wrote :

FAT32 has a file size limit of 4GB. FAT32 cannot store or manipulate files in excess of 4GB. On any platform.

This is a limitation of FAT32, not a bug.

----------

"The maximum possible size for a file on a FAT32 volume is 4 GiB minus 1 B (232−1 bytes). For most users, this has become the most nagging limit of FAT32 as of 2007, since video capture and editing applications and some other software can easily exceed this limit. Most new Windows machines now ship with NTFS and thus avoid these problems, but those who run dual boot systems or who move external data drives between computers with different operating systems have little choice but to stick with FAT32 (although between Windows and Linux it is possible to use ext2 or ext3 through the use of external drivers such as ext2 IFS)."

http://en.wikipedia.org/wiki/Fat32

----------

I agree, FAT 32 can't handle Those hudge files, but nautilus should not
crash, it should raise an error like "FAT 32 file system is unable to handle
files larger than 4GB, Sorry".
IMHO this is a minimum.

Did you try to copy a 4.5GB from a NTFS volume to a FAT32 volume on Windows
? Explorer does not crash !!!!!

2007/2/21, Kurt von Finck <email address hidden>:
>
> FAT32 has a file size limit of 4GB. FAT32 cannot store or manipulate
> files in excess of 4GB. On any platform.
>
> This is a limitation of FAT32, not a bug.
>
> ----------
>
> "The maximum possible size for a file on a FAT32 volume is 4 GiB minus 1
> B (232−1 bytes). For most users, this has become the most nagging limit
> of FAT32 as of 2007, since video capture and editing applications and
> some other software can easily exceed this limit. Most new Windows
> machines now ship with NTFS and thus avoid these problems, but those who
> run dual boot systems or who move external data drives between computers
> with different operating systems have little choice but to stick with
> FAT32 (although between Windows and Linux it is possible to use ext2 or
> ext3 through the use of external drivers such as ext2 IFS)."
>
> http://en.wikipedia.org/wiki/Fat32
>
> ----------
>
> --
> nautilus crashes when copying a 4G file on a vfat volume
> https://launchpad.net/bugs/70535
>

I Think that people understand your point... =)

Louis-Xavier Brusset wrote:
> I agree, FAT 32 can't handle Those hudge files, but nautilus should not
> crash, it should raise an error like "FAT 32 file system is unable to handle
> files larger than 4GB, Sorry".
> IMHO this is a minimum.
>
> Did you try to copy a 4.5GB from a NTFS volume to a FAT32 volume on Windows
> ? Explorer does not crash !!!!!
>
> 2007/2/21, Kurt von Finck <email address hidden>:
>> FAT32 has a file size limit of 4GB. FAT32 cannot store or manipulate
>> files in excess of 4GB. On any platform.
>>
>> This is a limitation of FAT32, not a bug.
>>
>> ----------
>>
>> "The maximum possible size for a file on a FAT32 volume is 4 GiB minus 1
>> B (232−1 bytes). For most users, this has become the most nagging limit
>> of FAT32 as of 2007, since video capture and editing applications and
>> some other software can easily exceed this limit. Most new Windows
>> machines now ship with NTFS and thus avoid these problems, but those who
>> run dual boot systems or who move external data drives between computers
>> with different operating systems have little choice but to stick with
>> FAT32 (although between Windows and Linux it is possible to use ext2 or
>> ext3 through the use of external drivers such as ext2 IFS)."
>>
>> http://en.wikipedia.org/wiki/Fat32
>>
>> ----------
>>
>> --
>> nautilus crashes when copying a 4G file on a vfat volume
>> https://launchpad.net/bugs/70535
>>
>

On 2/21/07, Sergio <email address hidden> wrote:
>
> Nautilus crashed during the copy a 4.2 Gb iso image from XFS to Fat32 in
> another disk. I suppose that if the problem is not from nautilus but the
> fs itself, nautilus should show an alert or something, but not crash :)
>
> Here is the compressed crash report

FAT32 has 32-bit limitations. The maximum of 32-bit is equivalent to
4,294,967,295 or 1x32 in binary. Transferring files greater than 4.2GB is
not supported in those filesystem. Other filesystems with 32-bit limitations
are ReiserFS and HFS/HFS+. Transferring files greater than 4.2GB requires
LFS (Large File Support), among those are ext2/3/4, Reiser4, xfs, jfs and
ntfs.

Hope this helps.

** Attachment added: "compressed crash report"
> http://librarian.launchpad.net/6488181/_usr_bin_nautilus.1000.crash.bz2
>
> --
> nautilus crashes when copying a 4G file on a vfat volume
> https://launchpad.net/bugs/70535
>

--
Carpe Diem

Sebastien Bacher (seb128) wrote :
Changed in gnome-vfs:
status: Unknown → Unconfirmed
Jamey (jamey-vodafone) wrote :

Ok, I have just read a lot about file size limitations on FAT32 being 4GB - before I post a dup bug while copying a 6GB file to an SMB share (the underlaying FS is ext3 AFAIK) should SMBFS have a problem with files >2GB??

This bug will be affected by the outcome of Bug 75574 -- namely Nautilus will need to react appropriately when the cp fails due to a filesystem limit. I don't know how (or whether it's appropriate) to mark it as "dependent upon" another bug.

Changed in gnome-vfs2:
status: Confirmed → Triaged
Alex van Niel (alexvanniel) wrote :

Will this bug be fixed in the next version of Ubuntu? In gutsy it is still present. Trying to copy a file bigger in size then the filesystem can handle (>4gb on fat32 for instance) although enough space is available will still make nautilus disappear and reappear shortly afterwards. Not really a disaster, more of a minor annoyance. Would be nice if this could be fixed. In the meantime, I will have to pay attention that I don't copy files bigger then 4gb to filesystems that don't support that (fat).

Sebastien Bacher (seb128) wrote :

could somebody try if that's still an issue in hardy intrepid or jaunty since nautilus is using gvfs now?

Changed in gnome-vfs2:
importance: High → Low
MoLE (moleonthehill) wrote :

Hi Sebastien and others.

I have tested copying a 4.2Gb iso to a fat32 volume using nautilus, the operation fails as expected but nautilus does not crash, but generates an error dialog which I have attached a screenshot of.

The only issue that remains is the partial file is left on the target volume at 4.0Gb, I would expect nautilus to perhaps delete the partial file rather than leave the file in an unusable state?

MoLE (moleonthehill) wrote :

Sorry, I forgot to add this is on Ubuntu 8.10, fully updated as of today.

Pedro Villavicencio (pedro) wrote :

Is someone experiencing this with Intrepid or Jaunty ? if so we should move both reports, this one and the upstream one to gvfs. Thanks.

benste (benste) wrote :

Hi, toay I backed up all my data to an external HDD, nautilus failed with 2 files, bothe where Virtualbox images bigger than 4 gb. I got an error message to which is attached.

Using the command line I got the same error, so I think it's not related to nautilus, but CP in general:

benste@VAIO-fe31m:/media/disk-1$ cp ~/Desktop/Ubuntu.vdi /media/disk-1/bensteLINsave/__configs/.VirtualBox/VDI/
cp: Schreiben von „/media/disk-1/bensteLINsave/__configs/.VirtualBox/VDI/Ubuntu.vdi“: File too large

-> I'll try it in jaunty this evening.

benste (benste) wrote :

I looked up wikipedia and found out that FAT32 only supports a maximum file size of 4gb !
http://en.wikipedia.org/wiki/File_Allocation_Table#VFAT

I would recommend to close this bug, because per default all external drives use vfat for windows compability. ;-(

No, no, no, don't close it, fix it! There's 19 duplicates and something like 50 people watching this bug. I've finished my education, had two kids and changed jobs three times since I opened this bug in 2005. Can we please not just close it, but fix it instead by issuing an error message? Trying to do something that will never work should be considered a bug.

It's got to be less than five lines of code the right place:

if( targetdir.fstype == "FAT32" && file.size > 4GB ) {
   echo "Error: You are trying to copy a file larger than 4GB to a FAT32 formatted filesystem. FAT32 doesn't support file sizes larger than 4GB.";
   return 1;
}

benste (benste) wrote :

I would never close a bug if there are others subscribed like Sebastian Baecher, who know much more about all things like me :-)
It was only my subjective opinion to do so, because Fat doesn't allow bigger than 4 Gb and Nautlius gave an error message without crashing in 8.10 today.:-)

It's great that Nautilus doesn't crash anymore, but the error message isn't very helpful. Nautilus probably just catches the return value from cp and shows the error message. I'm not confident cp is the best place to fix this, because then cp would need to know about other filesystem limits like vnode count, disk space etc, which would make cp unreasonably complex. Nautilus itself is probably a better place for this.

Sebastien Bacher (seb128) wrote :

this bug is a gnome-vfs one which is not used by nautilus since hardy, could somebody confirm that's still an issue in jaunty and open a new nautilus bug if that's the case?

Changed in gnome-vfs:
importance: Unknown → Critical

Not reproducible in Trusty. Nautilus notes:
Error while copying “file.txt”.
There was an error copying the file into /media/username/2B08-D81A.
Show more detail
Error splicing file: File too large

Changed in gnome-vfs2 (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.