[edgy] gnome shows duplicated mounts

Bug #57701 reported by Nicolò Chieffo on 2006-08-25
208
Affects Status Importance Assigned to Milestone
GnomeVFS
Invalid
Undecided
Unassigned
gnome-vfs2 (Ubuntu)
High
Sebastien Bacher

Bug Description

I've just installed and upgraded edgy.
during the configuration I chose to mount 3 partitions.
the gnome desktop (not the disk mounter applet) shows 6 partitions mounted! of course every partion is duplicated, and I see:

DATI, DATI(2), XP, XP (2), hda7, /mnt/ubuntu

NOTE: the last two are the same partition. I think that I gave the label "/mnt/ubuntu" to that partition during a previous install of fedora.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. I'll look at that issue and fix it

Changed in gnome-vfs2:
importance: Untriaged → High
HanSheng (hansheng) wrote :

ya, mee too~`
i ask somedays ago~``

http://www.ubuntuforums.org/showthread.php?t=249187

Me too. Trying to remove the mount with the volume name gives me an "access denied" error.

Oh, and trying to remove the mount, I think, crashed the package. See attachment.

Same thing here

I have Dapper Drake on a partition and recently install Knot 2 on another partition. The two installations share the same /home directory (partition).

On the desktop and in Places I see duplicated entries :

hdc1 - hdc1(2) - data - data(2)

gnome-vfs logic for /etc/fstab, /proc/mount is incompatible with the new UUID=
scheme in fstab, they don't use the same name for the device, and there's at least an other bad interaction with hald.

BTW what is the logic for mounting partitions from an external drive?

Sander D (sanderd) wrote :

A quick workaround for those annoyed by the duplicate icons, is changing /etc/fstab. By default it uses codes starting with "UUID=". If you replace those codes with the appropriate names like /dev/sda1 for the volumes displayed twice, and remount them (sudo umount /media/VolumeName && sudo mount /media/VolumeName), Nautilus should display them correctly. I don't know whether there are any advantages of using UUID though.

Sebastien Bacher (seb128) wrote :

I'll try to fix that for edgy beta

mazime (lumassy) wrote :

Hi, i've try to edit /etc/fstab with correct device /dev/hda1 (standard fstab) and restart Ubuntu Knot3.
After restart the icons are not visible on desktop, the devices is not mounted.
This problem is for my vfat partitions.
I don't have another ext3 partition.

The strange thing is that the diskmounter applet only shows the
correct partitions!

unsubscribe

On 9/22/06, Nicolò Chieffo <email address hidden> wrote:
>
> The strange thing is that the diskmounter applet only shows the
> correct partitions!
>
> --
> [edgy] gnome shows duplicated mounts
> https://launchpad.net/bugs/57701
>

unsubscribe

Changed in gnome-vfs:
status: Unknown → Unconfirmed
Onkar Shinde (onkarshinde) wrote :

@C Pirnat

Unsubscribe doesn't work by sending mail. You have to go the bug page and click the Unsubscribe link in upper left corner.

Well I can't be cause I am unsubscribed from there but I still keep
receiving emails.

On 9/25/06, Onkar Shinde <email address hidden> wrote:
>
> @C Pirnat
>
> Unsubscribe doesn't work by sending mail. You have to go the bug page
> and click the Unsubscribe link in upper left corner.
>
> --
> [edgy] gnome shows duplicated mounts
> https://launchpad.net/bugs/57701
>

Sebastien Bacher (seb128) wrote :

This upload fixes the issue:

" gnome-vfs2 (2.16.0-0ubuntu3) edgy; urgency=low
 .
   * debian/patches/08_uuid_mount.patch:
     - don't list duplicate entries for devices listed by their uuid
       (Ubuntu: #57701)"

Changed in gnome-vfs2:
status: Confirmed → Fix Released
cenora (cenora) wrote :

Same here on a newly installed 7.04 system + "Automatix NTFS read/write mounter".

System configuration:

HDA1 (Local HD with Windows XP)
SDA1 (External USB drive with Ubuntu - running my OS from this partition + 500GB NTFS partition)
SDB1 (External USB drive with Ubuntu - installed for other PC + 250GB NTFS partition)

Here are the logs:

~$ mount
/dev/sda2 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
/sys on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
devshm on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
lrm on /lib/modules/2.6.20-16-386/volatile type tmpfs (rw)
/dev/hda1 on /media/hda1 type fuseblk (rw,nosuid,nodev,noatime,allow_other,blksize=4096)
/dev/sda1 on /media/sda1 type fuseblk (rw,nosuid,nodev,noatime,allow_other,blksize=4096)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/sdb2 on /media/LinuxUSB type ext3 (rw,nosuid,nodev)
/dev/sdb1 on /media/USB250GB type ntfs (rw,nosuid,nodev,umask=222,utf8)
~$
~$ more /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda2 -- converted during upgrade to edgy
UUID=e5276077-2d98-45b6-9804-a5dc9c8c2bb7 / ext3 defaults,errors=remount-ro 0 1
# /dev/hda1 -- converted during upgrade to edgy
# /dev/sda1 -- converted during upgrade to edgy
# /dev/sda3 -- converted during upgrade to edgy
UUID=6ecd9946-ccd1-4478-9de1-d6c8dda33614 none swap sw 0 0
/dev/cdrom /media/cdrom0 udf,iso9660 user,noauto 0 0
# Generated by Automatix
## End of Automatix mounted partitions

# Generated by Automatix
/dev/hda1 /media/hda1 ntfs-3g defaults,locale=en_US.utf8 0 0
/dev/sda1 /media/sda1 ntfs-3g defaults,locale=en_US.utf8 0 0
## End of Automatix mounted partitions
~$

cenora (cenora) wrote :

BTW, I'd like to add that this problem is intermittent - sometimes after I logout and login again, the drives look good - 1 icon per partition.

Regards,
cenora

Nicolò Chieffo (yelo3) wrote :

closing this to lower open bug numbers, since it is fixed now, and gnomevfs will be deprecated

Changed in gnome-vfs:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.