mounted partitions have poor names

Bug #38764 reported by Matthew East on 2006-04-08
18
Affects Status Importance Assigned to Milestone
gnome-vfs2 (Ubuntu)
Medium
Martin Pitt

Bug Description

The partitions mounted on my desktop now have names, rather than being named after where they are mounted. The Windows disk is called "IBM_PRELOAD", which is fair enough I suppose.

However, there is a real problem with my other Ubuntu partition. It is on the desktop named "/". This looks bad, but also has another serious problem: I already have a root directory. So it looks like a link to my current root directory, and when I click, it looks like it too (given that it has the same structure). However, it isn't, it's /media/sda5.

Changed in hal:
status: Unconfirmed → Confirmed
Martin Pitt (pitti) wrote :

just discussed this issue with Seb. We will special-case away '/' labels.

Martin Pitt (pitti) on 2006-05-12
Changed in gnome-vfs2:
assignee: nobody → pitti
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

 gnome-vfs2 (2.14.1-0ubuntu4) dapper; urgency=low
 .
   * Add debian/patches/17_improve_volume_labels.patch:
     - Ignore '/' volume labels, they lead to much confusion. Closes: LP#38764
     - Show the mount point (with '/media/' prefix stripped off) instead of 'XX
       MB removable device' for mounted volumes without a label.

Changed in gnome-vfs2:
status: In Progress → Fix Released
Jonathan Rascher (bcat) wrote :

"Show the mount point (with '/media/' prefix stripped off) instead of 'XX MB removable device' for mounted volumes without a label."

This behavior seems to be broken in Hardy. I have a computer with two external hard drives (NTFS-formatted) mounted to /media/external and /media/backup, respectively. They both showed up on the desktop as "250.1 GB Media" until I gave them labels using ntfslabel from the ntfsprogs package. Does this have to do with the switch to gvfs?

Sebastien Bacher (seb128) wrote :

don't comment on closed bug, the gvfs equivalent is bug #190366

Jonathan Rascher [2008-04-24 1:38 -0000]:
> Does this have to do with the switch to gvfs?

Yes, it does. Can you please look for an existing bug against
nautilus/gvfs and if there isn't one, report a new one? Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers