Ubuntu

Please transition gnome-vfs to multi-arch

Reported by Tom Ellis on 2012-04-10
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-vfs (Ubuntu)
Medium
Adam Stokes
Precise
Medium
Adam Stokes

Bug Description

[Impact]
Please transition gnome-vfs to support multi-arch.

This package is still required by some third party applications.

[Test Case]
Install i386 within amd64 environment.
Verify i386 applications link proper architecture dependent library.

[Regression Potential]
Potential is minimal as no new code changes are present only build rules.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: libgnomevfs2-0 1:2.24.4-1ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
ApportVersion: 2.0-0ubuntu5
Architecture: amd64
Date: Tue Apr 10 12:00:32 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120401)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-vfs
UpgradeStatus: No upgrade log present (probably fresh install)

Tom Ellis (tellis) wrote :
Changed in gnome-vfs (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Tom Ellis (tellis) wrote :

I've attached a debdiff for review.

I've been testing this in my multi-arch ppa and it seems OK.
https://launchpad.net/~tellis/+archive/multiarch/

Changed in gnome-vfs (Ubuntu):
status: New → Confirmed

The attachment "gnome-vfs_2.24.4-1ubuntu3.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Jani Monoses (jani) wrote :

Tom can you update this for quantal?

Micah Gersten (micahg) wrote :

precise and quantal have the same version, it's just a s/precise/quantal/ at the top of the changelog, taking a look

Changed in gnome-vfs (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Micah Gersten (micahg)
status: Confirmed → In Progress
Changed in gnome-vfs (Ubuntu):
milestone: none → ubuntu-12.04.1
milestone: ubuntu-12.04.1 → none
Chris J Arges (arges) on 2012-06-14
Changed in gnome-vfs (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
status: New → In Progress
Changed in gnome-vfs (Ubuntu):
importance: Undecided → Medium
Changed in gnome-vfs (Ubuntu Precise):
importance: Undecided → Medium
description: updated
Adam Stokes (adam-stokes) wrote :

Attaching quantal debdiff for sponsorship

Sebastien Bacher (seb128) wrote :

Thank you for your work, some notes/questions:
- libgnomevfs2-common is arch: all and the dbus gnome-vfs-daemon.service it contains has a full path to the daemon which will work only on the arch where the arch all package was built, it should probably be changed to be arch: any
- libgnomevfs2-bin has no Multi-Arch field, shouldn't it be m-a: foreign?
- shouldn't libgnomevfs2-0 conflicts with the old libgnomevfs2-extras to avoid upgrading the lib to the multiarch version but having the -extra binaires in the previous non multiarch location?

Micah Gersten (micahg) wrote :

Unassigning myself since I haven't gotten to this for a while, I'll take another look when I'm piloting in 2 weeks if no one beats me to it

Changed in gnome-vfs (Ubuntu):
assignee: Micah Gersten (micahg) → nobody
status: In Progress → Confirmed
Adam Stokes (adam-stokes) wrote :

seb128,

re:
"
- shouldn't libgnomevfs2-0 conflicts with the old libgnomevfs2-extras to avoid upgrading the lib to the multiarch version but having the -extra binaires in the previous non multiarch location?
"

Im not entirely sure here as the way it seems to me is libgnomevfs2-common conflicts libgnomevfs2-extra which is depended on by libgnomevfs2-0. So wouldn't the previous -extra get removed once libgnomevfs2-common is upgraded?

Thanks
Adam

Adam Stokes (adam-stokes) wrote :
Changed in gnome-vfs (Ubuntu Precise):
assignee: nobody → Adam Stokes (adam-stokes)
Changed in gnome-vfs (Ubuntu):
assignee: nobody → Adam Stokes (adam-stokes)
status: Confirmed → In Progress
Clint Byrum (clint-fewbar) wrote :

Unsubbing ubuntu-sponsors since the merge proposal makes it redundant on the sponsoring report.

Adam Stokes (adam-stokes) wrote :

rdeps testing:

./gnome-sharp2_2.24.2-2-amd64-20120808-1143:Status: successful
./gst-plugins-base0.10_0.10.36-1ubuntu1-amd64-20120808-1151:Status: successful
./shotwell_0.12.3-0ubuntu1-amd64-20120808-1250:Status: successful
./gnome-python_2.28.1+dfsg-1-amd64-20120808-1137:Status: successful
./inkscape_0.48.3.1-1ubuntu4-amd64-20120808-1203:Status: successful
./libgnomeui_2.24.5-2ubuntu2-amd64-20120808-1237:Status: successful
./libgnome_2.32.1-2ubuntu1-amd64-20120808-1232:Status: successful
./libgsf_1.14.21-2.1-amd64-20120808-1244:Status: successful

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-vfs - 1:2.24.4-1ubuntu3

---------------
gnome-vfs (1:2.24.4-1ubuntu3) quantal; urgency=low

  * Add breaks for libgnomevfs2-common << 2.24.4
  * In addition to breaking on earlier versions we
    force libgnomevfs2-common to be reinstalled
    this ensures all library locations are properly created and files
    exist in their architecture specific installation.
  * Update build deps version to receive the full support of multi-arch
    processing.
  * Rebuilt with multi-arch support (LP: #977940)
 -- Adam Stokes <email address hidden> Tue, 10 Jul 2012 14:19:59 -0400

Changed in gnome-vfs (Ubuntu):
status: In Progress → Fix Released
Changed in gnome-vfs (Ubuntu Precise):
milestone: ubuntu-12.04.1 → ubuntu-12.04.2

Hello Tom, or anyone else affected,

Accepted gnome-vfs into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-vfs/1:2.24.4-1ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-vfs (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Cláudio Carvalho (clavalho) wrote :

I got to install i386 within amd64 system, no conflict. The i386 and amd64 are now co-installable.
I had no problem testing Symphony, which was depending only on this fix.
Thank you.

Mark Russell (marrusl) on 2012-09-18
tags: added: verification-done
removed: verification-needed
tags: added: verification-done-precise

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-vfs - 1:2.24.4-1ubuntu2.1

---------------
gnome-vfs (1:2.24.4-1ubuntu2.1) precise-proposed; urgency=low

  * Add breaks for libgnomevfs2-common << 2.24.4
  * In addition to breaking on earlier versions we
    force libgnomevfs2-common to be reinstalled
    this ensures all library locations are properly created and files
    exist in their architecture specific installation.
  * Update build deps version to receive the full support of multi-arch
    processing.
  * Rebuilt with multi-arch support (LP: #977940)
 -- Adam Stokes <email address hidden> Tue, 10 Jul 2012 14:19:59 -0400

Changed in gnome-vfs (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers