gnome-commander crashed with SIGSEGV in strcmp()

Bug #395835 reported by Csipak Attila on 2009-07-05
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gnome-vfs (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-commander

I'm using Ubuntu 9.04, gnome-commander 1.2.7-1build1. I've just added a new ftp site to Remote Connections, but then I accidentally tried to connect to the GNOME Commander site set up by default in the list. I attempted to cancel connecting, then came the crash.

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/gnome-commander
Package: gnome-commander 1.2.7-1build1
ProcCmdline: gnome-commander
ProcEnviron:
 LANG=hu_HU.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: gnome-commander
StacktraceTop:
 strcmp () from /lib/tls/i686/cmov/libc.so.6
 do_read_directory (method=0xb692f1c0,
 do_get_file_info (method=0xb692f1c0, uri=0x948b0f8,
 gnome_vfs_get_file_info_uri_cancellable (uri=0x948b0f8,
 gnome_vfs_get_file_info_uri (uri=0x948b0f8, info=0x94864c8,
Title: gnome-commander crashed with SIGSEGV in strcmp()
Uname: Linux 2.6.28-13-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Revision history for this message
Csipak Attila (corphicks) wrote :
visibility: private → public
Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt (retraced)

StacktraceTop:strcmp () at ../sysdeps/i386/i686/strcmp.S:40
do_read_directory (method=0xb692f1c0,
do_get_file_info (method=0xb692f1c0, uri=0x948b0f8,
gnome_vfs_get_file_info_uri_cancellable (uri=0x948b0f8,
gnome_vfs_get_file_info_uri (uri=0x948b0f8, info=0x94864c8,

Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt (retraced)
Changed in gnome-commander (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Marcin Wider (mwider) on 2009-11-03
Changed in gnome-commander (Ubuntu):
status: New → Confirmed
Revision history for this message
Marcin Wider (mwider) wrote :

Thanks for your bugreport.

I can reproduce this issue with Ubuntu 9.10 (1.2.8.2-0ubuntu1)

Changed in gnome-commander (Ubuntu):
assignee: nobody → Marcin Wider (mwider)
Revision history for this message
Marcin Wider (mwider) wrote :

This is a problem in gnome-vfs,

I can reproduce similar segmentation fault after

$gnomevfs-ls ftp://ftp.gnome.org/pub/GNOME/

with problems with link_uri = 0x0 in code:

    if (strcmp (gnome_vfs_uri_get_host_name (uri),
         gnome_vfs_uri_get_host_name (link_uri)) != 0) {
     /* Links must be in the same host */
     res = GNOME_VFS_ERROR_NOT_SAME_FILE_SYSTEM;
     break;
    }

affects: gnome-commander (Ubuntu) → gnome-vfs (Ubuntu)
Changed in gnome-vfs (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Marcin Wider (mwider) wrote :

bug occurs when we receive symlink without name ('.' or '..'), for example

$gnomevfs-ls ftp://ftp.gnome.org/pub/GNOME/

. (Symbolic Link, x-special/symlink) size 19
.. (Directory, x-directory/normal) size 15
FGO-FOOTER.html (Regular, text/html) size 350
FGO-HEADER.html (Regular, text/html) size 2150
FULL (Regular, application/octet-stream) size 1158

I attached debdiff that fix this issue (against gnome-vfs_2.24.2-1ubuntu1)

Changed in gnome-vfs (Ubuntu):
assignee: Marcin Wider (mwider) → nobody
status: In Progress → Confirmed
assignee: nobody → Ubuntu Sponsors for main (ubuntu-main-sponsors)
Marcin Wider (mwider) on 2009-11-12
Changed in gnome-vfs (Ubuntu):
assignee: Ubuntu Sponsors for main (ubuntu-main-sponsors) → nobody
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your work there, gnomevfs is not really being sed nowadays though, could you send the patch upstream and to Debian too though?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-vfs - 1:2.24.2-1ubuntu2

---------------
gnome-vfs (1:2.24.2-1ubuntu2) lucid; urgency=low

  * debian/patches/25_ftp_directory_read.patch: Added check that
    the symlink_name is not NULL before calling functions on it.
    (LP: #395835)
 -- Marcin Wider <email address hidden> Thu, 12 Nov 2009 10:02:48 +0100

Changed in gnome-vfs (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers